Expired articles not automatically removed from list

NEW
Unassigned

Status

MailNews Core
Networking: NNTP
17 years ago
10 years ago

People

(Reporter: WD, Unassigned)

Tracking

(Blocks: 1 bug, {memory-footprint, perf})

Trunk
memory-footprint, perf

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
BuildID:    2001090603

My News server expires articles after a certain period of time, as I would
expect most to.   The problem is, when I open a newsgroup, it always displays
all headers, including the expired articles.   All the expired ones do all show
up as non-bold, though.

Reproducible: Always
Steps to Reproduce:
1.Subscribe to a newsgroup on a server which expires articles
2.Re-visit that newsgroup at a later date, when some articles would be expired
3.

Actual Results:  The expired articles are still in the list of messages

Expected Results:  Expired articles are automatically removed from the list when
the newsgroup is clicked on and updated.  (no need to click link to manually do it)

If I click on an expired article, I get something like the following:

Error!
newsgroup server responded:no such article number in this group

Perhaps the article has expired

<pLMYl5dhX7hK-pn2-lhtnQDpCf40E@localhost> (284484)

Click here to remove all expired articles
Severity: normal → enhancement
Hardware: PC → All

Comment 1

17 years ago
isn't this a dupe of 97598 ?
(Reporter)

Comment 2

17 years ago
The original posting of bug 97598 is not the same as what I've described here. 
That bug is about clicking the link to delete expired articles not actually
doing anything.   But this bug is supposed to be about that link not even being
there in the first place.   (Mozilla should do housekeeping automatically,
without presenting a link to the user in the first place)

The last comment of bug 97598 seems to be along these lines I think...

Updated

17 years ago
Blocks: 106267

Comment 3

17 years ago
Here's an example. I read n.p.m.mail-news via my ISP's news server. However it
expires old articles. Thus if I try an read the very first message that Mozilla
still has in its list I get this instead:

> Error!
>
> newsgroup server responded:article not available (15840 out of range)
>
> Perhaps the article has expired
>
> <1004058717.650@com-and.com> (15840)
>
> Click here to remove all expired articles

This is because the news server currently only holds 534 articles from 17677 to
18210. Surely Mozilla can automatically remove the headers for 15840 to 17676?

I don't know if this is related, but if I click Get Messages the total number of
messages drops to 534, until new headers get downloaded.

Comment 4

17 years ago
Upping severity slightly and adding regression because this did work in 4.x
Severity: enhancement → minor
Keywords: regression
(Reporter)

Comment 5

17 years ago
Is seems that there is a pref for this...
-> WFM
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

17 years ago
I'm not sure what I was thinking here.
re-opening
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 7

17 years ago
I'm upping the severity on this.
Without manual user intervention to clean up expired articles, the disk space
used by mozilla will keep growing and growing.....
Severity: minor → normal

Updated

17 years ago
Keywords: 4xp, footprint
I fail to see how this can be 4xp, when 4.x didn't have any automatic remove
functionality for expired articles.  I also fail to see how this can be a
regression, since technically that keyword is reserved for features that were
implemented and have stopped working.  Expired articles has remained at the same
level of functionality (or improved) since M3.
Keywords: 4xp, regression

Comment 9

17 years ago
I can assure you that 4.x does automatically expire articles.

If I read, say, rec.humor.funny in 4.x I currently have 9 articles in the thread
pane because that's how many my ISP is keeping on its server.

Meanwhile Mozilla thinks there are 107 articles, because that's how long ago I
subscribed. So Mozilla is keeping unusable summary information on 98 articles :-(

Sorry for adding the regression keyword, I probably hadn't heard of 4xp then :-)
Keywords: 4xp

Comment 10

15 years ago
No more work on this topic since 1.5 years? At least I would really appreciate
this feature.

Comment 11

15 years ago
This is a typical NNTP log:

0[e24020]: (df14920) Next state: NNTP_RESPONSE
0[e24020]: (df14920) Receiving: 200 secnews.netscape.com Netscape-Collabra/3.52
03615 NNRP ready (posting ok).
0[e24020]: (df14920) Next state: NNTP_LOGIN_RESPONSE
0[e24020]: (df14920) Next state: NNTP_SEND_MODE_READER
0[e24020]: (df14920) Sending: MODE READER
0[e24020]: (df14920) Next state: NNTP_RESPONSE
0[e24020]: (df14920) Receiving: 200 secnews.netscape.com Netscape-Collabra/3.52
03615 NNRP ready (posting ok).
0[e24020]: (df14920) Next state: NNTP_SEND_MODE_READER_RESPONSE
0[e24020]: (df14920) Next state: SEND_FIRST_NNTP_COMMAND
0[e24020]: (df14920) Next state: NEWS_DISPLAY_NEWS_RC
0[e24020]: (df14920) Sending: GROUP netscape.public.mozilla.layout
0[e24020]: (df14920) Next state: NNTP_RESPONSE
0[e24020]: (df14920) Receiving: 211 11785 1 12603 netscape.public.mozilla.layout
0[e24020]: (df14920) Next state: NEWS_DISPLAY_NEWS_RC_RESPONSE
0[e24020]: (df14920) Next state: NEWS_DISPLAY_NEWS_RC
0[e24020]: (df14920) Next state: NEWS_DONE
0[e24020]: (df14920) Next state: NEWS_FREE
0[e24020]: (df14920) CleanupAfterRunningUrl()
0[e24020]: (df14920) setting busy to 0

In other words, news is simply ignoring the response to the GROUP command :-(
Assignee: sspitzer → bienvenu
Status: REOPENED → NEW

Comment 12

15 years ago
Actually I just figured that that's a bad example because article 1 exists.

0[e24020]: (df8ac00) Next state: NNTP_SEND_MODE_READER_RESPONSE
0[e24020]: (df8ac00) Next state: SEND_FIRST_NNTP_COMMAND
0[e24020]: (df8ac00) Next state: NEWS_DISPLAY_NEWS_RC
0[e24020]: (df8ac00) Sending: GROUP alt.pl.mozilla
0[e24020]: (df8ac00) Next state: NNTP_RESPONSE
0[e24020]: (df8ac00) Receiving: 211 2233 1350 3582 alt.pl.mozilla
0[e24020]: (df8ac00) Next state: NEWS_DISPLAY_NEWS_RC_RESPONSE
0[e24020]: (df8ac00) Next state: NEWS_DISPLAY_NEWS_RC
0[e24020]: (df8ac00) Next state: NEWS_DONE
0[e24020]: (df8ac00) Next state: NEWS_FREE
0[e24020]: (df8ac00) CleanupAfterRunningUrl()
0[e24020]: (df8ac00) setting busy to 0

I would expect this to expire articles 1-1349.
Product: MailNews → Core

Comment 13

13 years ago
There appears to be a regression.  Using Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.12) Gecko/20050915, I no longer see the "remove expired messages" link when trying to open an expired message.  The message pane is entirely blank.  So now, newsgroups cannot even be expired manually, and increase without bound.

Comment 14

12 years ago
(In reply to comment #13)
> There appears to be a regression.  ... I no longer see the "remove expired
> messages" link when trying to open an expired message.  The message pane is
> entirely blank.  So now, newsgroups cannot even be expired manually, and
> increase without bound.

Alan, do you still see this?
David, was this intentionally removed?  (I've never seen it myself)

Comment 15

12 years ago
no, I don't think it was intentional - could it be that there's a string missing, i.e., the string we use to generate the text of the expired article message.

Updated

10 years ago
Assignee: bienvenu → nobody
Keywords: perf
QA Contact: stephend → networking.news
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.