Closed Bug 985371 Opened 7 years ago Closed 7 years ago

[DSDS][Fugu] Voicemail notification for SIM1 always shows/dials voicemail number for SIM2

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:1.4+)

RESOLVED WORKSFORME
blocking-b2g 1.4+

People

(Reporter: echang, Unassigned)

References

Details

Attachments

(3 files)

Attached image Voicemail.png
GAIA_REV=d2651c13d6370d62bf833b31c7e2e5f054510136
GECKO_REV=c8a17e25111585c0eebb829f8208190ea432c71e
GAIA_BRANCH=mozillaorg/master
GECKO_BRANCH=mozillaorg/master
BUILD_TAG=jenkins-B2G.master.fugu-32
BuildID=20140318053055

1. Leave a voicemail for SIM1.
2. Default Outgoing calls in Sim Manager set to SIM1.(not relevant)
3. Drag down notification for SIM1 voicemail.
4. <ISSUE> It shows the voicemail number set for SIM2 in notificaion.

http://youtu.be/gh52ghDSQTo
Blocks: 975918
blocking-b2g: --- → 1.4?
blocking-b2g: 1.4? → 1.4+
I suspect the fix would probably just to change the tag of the notification.
i.e., at https://github.com/mozilla-b2g/gaia/blob/master/apps/system/js/voicemail.js#L83 we define a set of options for the notifcation. Specifically, the 'tag' will be used to replace previous notifications. The current code will overwrite notifications sent for SIM1 when sending one for SIM2.

Making the tag SIM-unique (maybe using the voicemail number?) would fix this. Unfortunately, I can't fix this right now.
Looks like I misunderstood the report, in fact. Hence, it's not my code's fault \o/
Julien, seems like we put the wrong info into the notification. Is this a dialer bug?
Flags: needinfo?(felash)
I don't know much about Dialer (:rik would know) but I think that the voicemail is purely a Gecko+System thing.

Maybe the event received from mozVoicemail does not have the right information?
Flags: needinfo?(felash)
(In reply to Julien Wajsberg [:julienw] (away until March 24) from comment #5)
> Maybe the event received from mozVoicemail does not have the right
> information?

The event has the right information, we only get the SIM number (1 or 2) and the voice message count from this event. The voicemail number can come from either settings, or if there is no setting we query mozVoicemail for it. In the video, voicemail numbers are set up as `123` and `222`, so these are most likely coming from settings. If there is a bug here it is probably in how we are querying/caching the settings.

That said, I have spent the last hour or so trying to reproduce this bug on my fugu with the latest master. I have switched sim cards slots, used the default voicemail numbers, set up custom voicemail numbers in settings, rebooted the device, sent multiple voicemails before and after changing the settings, before and after reboot; and the notification always has the right voicemail number (ie from SIM 1 and not SIM 2). Can we get verification that this bug is still happening on the latest master?

BuildID: 20140319053035
gaia: 80de82c8866acf585fa580a28bc5d434aad323b7
Keywords: qawanted
(In reply to Alexandre LISSY :gerard-majax [DND 03/22-03/29] from comment #2)
> i.e., at
> https://github.com/mozilla-b2g/gaia/blob/master/apps/system/js/voicemail.
> js#L83 we define a set of options for the notifcation. Specifically, the
> 'tag' will be used to replace previous notifications. The current code will
> overwrite notifications sent for SIM1 when sending one for SIM2.
> 
> Making the tag SIM-unique (maybe using the voicemail number?) would fix
> this. Unfortunately, I can't fix this right now.

I don't think the tag is the problem, since it seems like getting voicemail notifications from SIM 1 followed by one from SIM 2 would cause the whole notification to get replaced, and not have mismatched voicemail callback numbers.

That said, we probably do want to have separate notifications for each SIM, and so would make sense to make the tags unique per SIM.
Hi, Michael, Just want to make sure that the icon of voicemail notification, does that look like an SMS bubble or an voicemail icon? 
(In reply to Michael Henretty [:mhenretty] from comment #6)
> (In reply to Julien Wajsberg [:julienw] (away until March 24) from comment
> #5)
> > Maybe the event received from mozVoicemail does not have the right
> > information?
> 
> The event has the right information, we only get the SIM number (1 or 2) and
> the voice message count from this event. The voicemail number can come from
> either settings, or if there is no setting we query mozVoicemail for it. In
> the video, voicemail numbers are set up as `123` and `222`, so these are
> most likely coming from settings. If there is a bug here it is probably in
> how we are querying/caching the settings.
> 
> That said, I have spent the last hour or so trying to reproduce this bug on
> my fugu with the latest master. I have switched sim cards slots, used the
> default voicemail numbers, set up custom voicemail numbers in settings,
> rebooted the device, sent multiple voicemails before and after changing the
> settings, before and after reboot; and the notification always has the right
> voicemail number (ie from SIM 1 and not SIM 2). Can we get verification that
> this bug is still happening on the latest master?
> 
> BuildID: 20140319053035
> gaia: 80de82c8866acf585fa580a28bc5d434aad323b7
(In reply to Michael Henretty [:mhenretty] from comment #6)
> (In reply to Julien Wajsberg [:julienw] (away until March 24) from comment
> #5)
> > Maybe the event received from mozVoicemail does not have the right
> > information?
> 
> The event has the right information, we only get the SIM number (1 or 2) and
> the voice message count from this event. 

Right, I didn't understand well enough the issue. If the dialing phone number is wrong, this comes definitely from [1].

So maybe we'd need to know whether the faulty number comes from "numbers" (ie the settings) or from the "voicemail.getNumber" API? Is this SIM-dependent? Variant-dependent?

[1] https://github.com/mozilla-b2g/gaia/blob/master/apps/system/js/voicemail.js#L57-L61
(In reply to Eric Chang [:ericcc] [:echang] from comment #8)
> Hi, Michael, Just want to make sure that the icon of voicemail notification,
> does that look like an SMS bubble or an voicemail icon? 

It looks like the voicemail icon (the thing that looks like eye glasses rather than speech bubble).

(In reply to Julien Wajsberg [:julienw] (away until March 24) from comment #9)
> So maybe we'd need to know whether the faulty number comes from "numbers"
> (ie the settings) or from the "voicemail.getNumber" API? Is this
> SIM-dependent? Variant-dependent?

Good question! Eric, did you set up custom voicemail numbers through Call Settings before you reproduced this bug, or were the voicemail numbers '123' and '222' already there when you flashed the phone? Also, can you still reproduce this bug with the latest build?
Flags: needinfo?(echang)
Attached is the adb logcat with ril ON. 

I set them by myself because the voicemail number are not set in either these 2 SIMs or Call settings, and the voicemail notification will shows like "SIM 1 - One new voicemail <LF> One new voicemail" (without number on it)
Flags: needinfo?(echang)
v1.4                                           
Gaia      7d716de0c186416b5b123baa1f3242e23d50529b
Gecko     47333352bbb537a81255370c1d7c2d9096e3c733
BuildID   20140328041552                  
Version   30.0a2                          

Currently I am not able to reproduce this using latest v1.4
but there is another bug which is already filed, and reproduced.

1. VM number set in Call settings for both SIMs
2. VM received for SIM2
3. VM number correct in notification
4. <ISSUE> Tap on notification and dial from SIM 1<default>!! 
https://bugzilla.mozilla.org/show_bug.cgi?id=985311

SIM1 VM - 123
SIM2 VM - 222

But SIM1 [0] is calling out 222 here, it should be SIM 2 [1] who tries to call.

line: 684
I/Gecko   (  107): TelephonyProvider: Dialing 222
I/Gecko   (  107): RIL Worker: [0] Received chrome message {"number":"222","isDialEmergency":false,"rilMessageClientId":0,"rilMessageToken":49,"rilMessageType":"dial"}
Another thing to mention is that is I do not set the VM in call settings in the first place, then a vm notification without number comes, "SIM 1 - One new voicemail <LF> One new voicemail".
Even if I set the vm number now, I won't be able to call by tapping the notification.
Which is the same behavior in Buri, is that following any spec?
(In reply to Eric Chang [:ericcc] [:echang] from comment #12)
> Created attachment 8398413 [details]
> VM number set, VM received for SIM2, VM number correct, Tap on notification
> and dial from SIM 1<default>
> 
> v1.4                                           
> Gaia      7d716de0c186416b5b123baa1f3242e23d50529b
> Gecko     47333352bbb537a81255370c1d7c2d9096e3c733
> BuildID   20140328041552                  
> Version   30.0a2                          
> 
> Currently I am not able to reproduce this using latest v1.4
> but there is another bug which is already filed, and reproduced.

Ok, we will close this one, and track that problem in the other bug. Thanks for testing this :)

(In reply to Eric Chang [:ericcc] [:echang] from comment #13)
> Another thing to mention is that is I do not set the VM in call settings in
> the first place, then a vm notification without number comes, "SIM 1 - One
> new voicemail <LF> One new voicemail".
> Even if I set the vm number now, I won't be able to call by tapping the
> notification.
> Which is the same behavior in Buri, is that following any spec?

I believe this is bug 983459.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.