Closed Bug 985888 Opened 6 years ago Closed 6 years ago

[DSDS] SIM indicators should display currently in-use SIM cards

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

defect
Not set

Tracking

(blocking-b2g:1.4+, b2g-v1.4 fixed, b2g-v2.0 fixed)

RESOLVED FIXED
1.4 S4 (28mar)
blocking-b2g 1.4+
Tracking Status
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed

People

(Reporter: drs, Assigned: drs)

References

Details

Attachments

(1 file)

In bug 978814, we did everything needed to make sure that we always re-use the currently in-use SIM card when we have an active call and want to place another. However, we didn't fix the visuals to reflect this, so you could press a button with the SIM indicator "SIM1" but it could really call SIM2 with no way of you knowing that this either would or did happen.
This is less bad than bug 978814, but it's bad enough that I think we should 1.4+ it.
blocking-b2g: --- → 1.4?
Depends on: 978814
Component: Gaia → Gaia::System
blocking-b2g: 1.4? → 1.4+
This seems like a feature to me. Do we have UX specs for this?
Flags: needinfo?(firefoxos-ux-bugzilla)
(In reply to Gregor Wagner [:gwagner] from comment #2)
> This seems like a feature to me. Do we have UX specs for this?

What in particular are you asking for? I can't think of any ambiguities here that would require UX decisions, but of course if you or someone on UX thinks otherwise, we should talk about it.
Assignee: nobody → drs+bugzilla
Component: Gaia::System → Gaia::Dialer
Depends on: 980982
(In reply to Gregor Wagner [:gwagner] from comment #2)
> This seems like a feature to me. Do we have UX specs for this?
This was discussed via private emails with Carrie first. I don't think she has updated the spec documents though.
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(cawang)
Comment on attachment 8394727 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/17440

r+ with the change in the test mentioned on github.
Attachment #8394727 - Flags: review?(anthony) → review+
https://github.com/mozilla-b2g/gaia/commit/3153a7f80ae68908f4a741d4fb3985fa01c0a507
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
This has conflicts on v1.4.
Flags: needinfo?(drs+bugzilla)
Target Milestone: --- → 1.4 S4 (28mar)
Backed out in https://github.com/mozilla-b2g/gaia/commit/7e36c05affc3f989cb1ad9c13368152515f1f21a
Status: RESOLVED → REOPENED
Flags: needinfo?(drs+bugzilla)
Resolution: FIXED → ---
Hi, 
About the conclusion from the email thread, the expected behaviour here would be:
1. call log
1.1 in call log, any item you tap will take you back to dialer with the number prepopulated 
2. dialer 
2.1 in dialer, the Dial button will indicate the SIM1 or SIM2 that you can add call using (which will be the SIM you are currently in call using and long press is disabled) 
3. contacts
3.1 in contacts detail page, the phone number associated with the contact will indicate the SIM1 or SIM2 that you can add call using (which will be the SIM you are currently in call using and long press is disabled).

I will add them to the spec, but can you take this as reference for now?
Thanks.
Flags: needinfo?(cawang)
(In reply to Carrie Wang [:carrie] from comment #10)
> Hi, 
> About the conclusion from the email thread, the expected behaviour here
> would be:
> 1. call log
> 1.1 in call log, any item you tap will take you back to dialer with the
> number prepopulated 

That's news to me. When you tap on a number in the call log, it pops up a menu with one of the items being a "Call" button. If there's no call in progress, it shows the SIM picker menu. The way we're doing it in this patch and bug 978814 is, if there's already a call in progress, the "Call" button immediately calls on that active SIM.

Is this functionality ok, or do you want us to go back and change it?

> 2. dialer 
> 2.1 in dialer, the Dial button will indicate the SIM1 or SIM2 that you can
> add call using (which will be the SIM you are currently in call using and
> long press is disabled) 
> 3. contacts
> 3.1 in contacts detail page, the phone number associated with the contact
> will indicate the SIM1 or SIM2 that you can add call using (which will be
> the SIM you are currently in call using and long press is disabled).

Yeah, that's how it works with this patch on both counts.
Flags: needinfo?(cawang)
In case it is needed, the DSDS specs are here:
https://mozilla.box.com/s/ttysiykrklmeq6lkfof8

and also here:
https://github.com/mozilla-b2g/gaia-specs
But also please note that Carrie is updating the specs with decisions made in an email thread.
(In reply to Stephany Wilkes from comment #12)
> In case it is needed, the DSDS specs are here:
> https://mozilla.box.com/s/ttysiykrklmeq6lkfof8
> 
> and also here:
> https://github.com/mozilla-b2g/gaia-specs

(In reply to Stephany Wilkes from comment #13)
> But also please note that Carrie is updating the specs with decisions made
> in an email thread.

Unfortunately, this functionality is not yet covered in the spec. Based on bug 926345 comment 55, bug 926345 comment 56, and the lack of progress on bug 920011, I think we should defer item 1.1 from comment 10 to another bug/patch for 1.5.
(In reply to Doug Sherk (:drs) from comment #11)
> (In reply to Carrie Wang [:carrie] from comment #10)
> > Hi, 
> > About the conclusion from the email thread, the expected behaviour here
> > would be:
> > 1. call log
> > 1.1 in call log, any item you tap will take you back to dialer with the
> > number prepopulated 
> 
> That's news to me. When you tap on a number in the call log, it pops up a
> menu with one of the items being a "Call" button. If there's no call in
> progress, it shows the SIM picker menu. The way we're doing it in this patch
> and bug 978814 is, if there's already a call in progress, the "Call" button
> immediately calls on that active SIM.
> 
> Is this functionality ok, or do you want us to go back and change it?
> 
> > 2. dialer 
> > 2.1 in dialer, the Dial button will indicate the SIM1 or SIM2 that you can
> > add call using (which will be the SIM you are currently in call using and
> > long press is disabled) 
> > 3. contacts
> > 3.1 in contacts detail page, the phone number associated with the contact
> > will indicate the SIM1 or SIM2 that you can add call using (which will be
> > the SIM you are currently in call using and long press is disabled).
> 
> Yeah, that's how it works with this patch on both counts.

The issue is related to the function "calling directly from call log".
Currently, we haven't implemented the feature yet, but we already delivered the spec. For single SIM, if users tap the call log, the call will be dialed directly. If it's DSDS, tapping the call log will be directed to Dialer with the number prepopulated. In this way, users can switch SIM card by long-tapping the call button here.
Hence, getting back to the "in-progress call" scenario, I'd expect that the feature is created based on the use case I mentioned above. Press "add call" and get to the call log to select a call history, the user will be led to dialer with number prepopulated, but the call button shows the currently used SIM and the "long-tap" function is disabled. This is what I saw from our email thread "BUG 926345".

I'd like to update the spec, but need to reach a conclusion here. ni? Anthony to confirm with the previous discussion.
Flags: needinfo?(cawang) → needinfo?(anthony)
(In reply to Carrie Wang [:carrie] from comment #15)
> The issue is related to the function "calling directly from call log".
> Currently, we haven't implemented the feature yet, but we already delivered
> the spec. For single SIM, if users tap the call log, the call will be dialed
> directly. If it's DSDS, tapping the call log will be directed to Dialer with
> the number prepopulated. In this way, users can switch SIM card by
> long-tapping the call button here.

OK, I understand. That definitely falls out of the scope of this bug, though. We will have to get the DSDS functionality working in the case that you described in bug 920011 or a followup.

> Hence, getting back to the "in-progress call" scenario, I'd expect that the
> feature is created based on the use case I mentioned above. Press "add call"
> and get to the call log to select a call history, the user will be led to
> dialer with number prepopulated, but the call button shows the currently
> used SIM and the "long-tap" function is disabled. This is what I saw from
> our email thread "BUG 926345".

This doesn't answer what we should do for now. We either have to 1.4+ bug 920011 and do that now, or decide on an alternate way for the time being. The way we decided on for this patch is described in comment 11.
Flags: needinfo?(cawang)
For now, what we've implemented is:
- Display the SIM in use where we usually display the preferred SIM.
- If an action usually displays a SIM Picker (long tap on voicemail hotkey or tap on call log unknown contact menu), we just use the in use SIM.
Carrie: Is that an ok behaviour for 1.4?

We won't mark bug 920011 as 1.4+. It's a new feature, it will ride the trains.
The described 1.1 behaviour is ok to me to update the specs.
Flags: needinfo?(anthony)
Yes, for now is ok. (but I really don't like the behaviour of calling the unknown contact from Call log, but it will be revised when we implement bug 920011). 
Thanks everyone!
Flags: needinfo?(cawang)
https://github.com/mozilla-b2g/gaia/commit/527b6c799a0fa38aa79bb54628a3ab1dd8eef1e6
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Relanded on v1.4: https://github.com/mozilla-b2g/gaia/commit/5be1f41fb6ed0b7a179d2db52f5dfcc095bf9c8d

I verified the test pass locally this time and tested it on a device. It's on top of bug 987024 now, which was an unfulfilled dependency last time I landed this.
You need to log in before you can comment on or make changes to this bug.