Closed Bug 985940 Opened 9 years ago Closed 2 years ago

Tab list does not retract after swiping to close a tab

Categories

(Firefox for Android Graveyard :: General, defect)

29 Branch
ARM
Android
defect
Not set
normal

Tracking

(firefox28 affected, firefox29 affected, firefox30 affected, firefox31 affected, firefox37 affected, firefox38 affected, firefox39 affected, firefox40 affected)

RESOLVED INCOMPLETE
Tracking Status
firefox28 --- affected
firefox29 --- affected
firefox30 --- affected
firefox31 --- affected
firefox37 --- affected
firefox38 --- affected
firefox39 --- affected
firefox40 --- affected

People

(Reporter: u421692, Unassigned)

Details

Attachments

(1 file)

Attached image screenshot
Device: Asus Transformer TF101
Build: Aurora 30.0a2 (2014-03-19)
 
Steps to reproduce:
1. Open Fennec and tap on the tab menu button (top left). Make sure you have a few tabs opened.
2. Quick swipe over a tab

Expected result:
Tab is closed and tab list is retracted

Actual result:
Tab is not closed(if is focused) and tab list is not retracted(see attached screenshot)

Note: The issue is intermittent and I was able to reproduce it only on tablets.
I've reproduced this issue on every FF branch, however, this might be a regression, since I can not reproduce this issue on FF 24.
Can reproduce on Alcatel One Touch 8008D (Android 4.1.2)
Summary: [TABLET] Tab list does not retract after swiping to close a tab → Tab list does not retract after swiping to close a tab
Also reproducible on Motorola Razr (Android 4.1.2) in both portrait and landscape mode.
Are you sure this affects 36+? We have the new tablet UI enabled (bug 1014156) and users can no longer swipe-to-close.

Please reopen if so.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
(In reply to Michael Comella (:mcomella) from comment #3)
> Are you sure this affects 36+? We have the new tablet UI enabled (bug
> 1014156) and users can no longer swipe-to-close.
> 
> Please reopen if so.

This issue is reproducible on phones. Both devices from comment 1 and comment 2 are phones.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Since these devices are 4.1.2, I'm going to guess they're older - sounds like we have a race condition.
We have completed our launch of our new Firefox on Android. The development of the new versions use GitHub for issue tracking. If the bug report still reproduces in a current version of [Firefox on Android nightly](https://play.google.com/store/apps/details?id=org.mozilla.fenix) an issue can be reported at the [Fenix GitHub project](https://github.com/mozilla-mobile/fenix/). If you want to discuss your report please use [Mozilla's chat](https://wiki.mozilla.org/Matrix#Connect_to_Matrix) server https://chat.mozilla.org and join the [#fenix](https://chat.mozilla.org/#/room/#fenix:mozilla.org) channel.
Status: REOPENED → RESOLVED
Closed: 8 years ago2 years ago
Resolution: --- → INCOMPLETE
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.