X_CreatePixmap: BadAlloc Crash with oxygen-gtk when opened link with right click [@ mozalloc_abort(char const*) | NS_DebugBreak | X11Error ]

RESOLVED FIXED

Status

()

defect
--
critical
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: raul.malea, Unassigned)

Tracking

({crash, reproducible})

31 Branch
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox30-, firefox31-, firefox36 affected)

Details

(Whiteboard: [tbird crash][workaround:comment 8], crash signature)

Reporter

Comment 1

5 years ago
Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0 ID:20140319030201 CSet: 3bc3b9e2cd99

I used openSUSE 13.1 with KDE 4.11.5


Application Basics
------------------

Name: Firefox
Version: 31.0a1
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0

Crash Reports for the Last 3 Days
---------------------------------

Report ID: bp-2cb2a284-07e0-494f-894c-fb4962140320
Submitted: 15 minutes ago

Report ID: bp-4cb3abf7-8c9c-4f77-bc08-d5ac22140320
Submitted: 14 hours ago

Report ID: bp-b8b27244-8668-4f73-a85d-10e662140318
Submitted: 2 days ago

Report ID: bp-44190333-5cd6-4e89-bd31-977a12140318
Submitted: 2 days ago

Report ID: bp-f29c4d6c-6238-49b2-bd66-453712140317
Submitted: 3 days ago

All Crash Reports

Extensions
----------

Name: Adblock Plus
Version: 2.5.1
Enabled: true
ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

Name: Add-on Compatibility Reporter
Version: 2.0.3
Enabled: true
ID: compatibility@addons.mozilla.org

Name: British English Dictionary
Version: 1.19.1
Enabled: true
ID: en-GB@dictionaries.addons.mozilla.org

Name: Bugzilla Tweaks
Version: 1.12.1.1
Enabled: true
ID: jid0-qBnIpLfDFa4LpdrjhAC6vBqN20Q@jetpack

Name: Cheevos
Version: 1.5
Enabled: true
ID: jid1-bpzDizt9E1R7nw@jetpack

Name: FlashGot
Version: 1.5.5.98
Enabled: true
ID: {19503e42-ca3c-4c27-b1e2-9cdb2170ee34}

Name: Google Shortcuts
Version: 2.1.7.1
Enabled: true
ID: {5C46D283-ABDE-4dce-B83C-08881401921C}

Name: Lightbeam
Version: 1.0.8
Enabled: true
ID: jid1-F9UJ2thwoAm5gQ@jetpack

Name: Nightly Tester Tools
Version: 3.7
Enabled: true
ID: {8620c15f-30dc-4dba-a131-7c5d20cf4a29}

Name: openSUSE Firefox Extensions
Version: 1.0.2
Enabled: true
ID: susefox@opensuse.org

Name: Submit Word
Version: 1.1.0
Enabled: true
ID: submitword@suseromania.ro

Name: Bookmark Duplicate Cleaner
Version: 0.2
Enabled: false
ID: bookmarkdup@localghost.net

Name: Download Statusbar
Version: 0.9.10
Enabled: false
ID: {D4DD63FA-01E4-46a7-B6B1-EDAB7D6AD389}

Name: Firebug
Version: 1.12.7
Enabled: false
ID: firebug@software.joehewitt.com

Name: Firefox OS Simulator
Version: 4.0.1
Enabled: false
ID: r2d2b2g@mozilla.org

Name: Greasemonkey
Version: 1.15
Enabled: false
ID: {e4a8a97b-f2ed-450b-b12d-ee082ba24781}

Name: ImageSearch
Version: 0.3.1
Enabled: false
ID: jid1-NOlwYOe3E3vApg@jetpack

Name: Mozilla Reps Companion
Version: 1.1
Enabled: false
ID: jid1-4QxcVDv2lBVyfQ@jetpack

Name: Mozmill Crowd
Version: 0.1.5
Enabled: false
ID: mozmill-crowd@quality.mozilla.org

Name: Mozmill test Addon
Version: initial.rev11
Enabled: false
ID: jid0-eXBmaisIIhuqsxKsdxROTr5TCwc@jetpack

Name: NoScript
Version: 2.6.8.17
Enabled: false
ID: {73a6fe31-595d-460b-a920-fcc0f8843232}

Name: pearltrees
Version: 6.0.15
Enabled: false
ID: collector@broceliand.fr

Name: Quick Locale Switcher
Version: 1.7.8.5
Enabled: false
ID: {25A1388B-6B18-46c3-BEBA-A81915D0DE8F}

Name: StumbleUpon
Version: 4.16
Enabled: false
ID: {AE93811A-5C9A-4d34-8462-F7B864FC4696}

Name: Stylish
Version: 1.4.2
Enabled: false
ID: {46551EC9-40F0-4e47-8E18-8E5CF550CFB8}

Name: Test Pilot
Version: 1.2.3
Enabled: false
ID: testpilot@labs.mozilla.com

Name: Web Developer
Version: 1.2.5
Enabled: false
ID: {c45c406e-ab73-11d8-be73-000a95be3b12}

Name: Yoono
Version: 7.7.29
Enabled: false
ID: {d9284e50-81fc-11da-a72b-0800200c9a66}

Name: YSlow
Version: 3.1.8
Enabled: false
ID: yslow@yahoo-inc.com

Important Modified Preferences
------------------------------

accessibility.typeaheadfind: true
accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 61440
browser.cache.disk.smart_size_cached_value: 358400
browser.cache.disk.smart_size.enabled: false
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.places.importBookmarksHTML: false
browser.places.smartBookmarksVersion: 7
browser.sessionstore.upgradeBackup.latestBuildID: 20140319030201
browser.startup.homepage: about:home
browser.startup.homepage_override.buildID: 20140319030201
browser.startup.homepage_override.mstone: 31.0a1
dom.mozApps.used: true
extensions.lastAppVersion: 31.0a1
font.name.monospace.x-central-euro: Courier New
font.name.monospace.x-western: Droid Sans Mono
font.name.sans-serif.x-central-euro: Arial
font.name.sans-serif.x-western: Droid Serif
font.name.serif.x-central-euro: Times New Roman
font.name.serif.x-western: Droid Serif
font.size.fixed.x-central-euro: 13
general.autoScroll: true
general.useragent.locale: ro-RO
network.cookie.prefsMigrated: true
places.database.lastMaintenance: 1395245202
places.history.expiration.transient_current_max_pages: 104858
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
plugin.soname.list:
print.print_bgcolor: false
print.print_bgimages: false
print.print_colorspace: default
print.print_downloadfonts: false
print.print_evenpages: true
print.print_footerright:
print.print_in_color: true
print.print_margin_bottom: 0.5
print.print_margin_left: 0.5
print.print_margin_right: 0.5
print.print_margin_top: 0.5
print.print_oddpages: true
print.print_orientation: 0
print.print_page_delay: 50
print.print_paper_data: 0
print.print_paper_height: 297.00
print.print_paper_name: iso_a4
print.print_paper_size_type: 1
print.print_paper_size_unit: 1
print.print_paper_width: 210.00
print.print_plex_name: default
print.print_resolution_name: default
print.print_scaling: 1.00
print.print_shrink_to_fit: true
print.print_to_file: false
print.print_unwriteable_margin_bottom: 22
print.print_unwriteable_margin_left: 25
print.print_unwriteable_margin_right: 25
print.print_unwriteable_margin_top: 22
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.can_change_colorspace: false
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.can_change_downloadfonts: false
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.can_change_jobtitle: false
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.can_change_num_copies: true
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.can_change_orientation: true
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.can_change_paper_size: true
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.can_change_plex: false
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.can_change_printincolor: true
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.can_change_resolution: false
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.can_change_spoolercommand: false
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.colorspace.0.name: default
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.colorspace.count: 1
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.has_special_printerfeatures: true
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.orientation.0.name: portrait
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.orientation.1.name: landscape
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.orientation.count: 2
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.paper.0.height_mm: 210
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.paper.0.is_inch: false
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.paper.0.name: A5
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.paper.0.width_mm: 148
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.paper.1.height_mm: 297
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.paper.1.is_inch: false
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.paper.1.name: A4
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.paper.1.width_mm: 210
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.paper.2.height_mm: 420
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.paper.2.is_inch: false
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.paper.2.name: A3
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.paper.2.width_mm: 297
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.paper.3.height_mm: 279
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.paper.3.is_inch: true
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.paper.3.name: Letter
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.paper.3.width_mm: 215
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.paper.4.height_mm: 355
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.paper.4.is_inch: true
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.paper.4.name: Legal
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.paper.4.width_mm: 215
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.paper.5.height_mm: 431
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.paper.5.is_inch: true
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.paper.5.name: Tabloid
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.paper.5.width_mm: 279
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.paper.6.height_mm: 254
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.paper.6.is_inch: true
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.paper.6.name: Executive
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.paper.6.width_mm: 190
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.paper.count: 7
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.plex.0.name: default
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.plex.count: 1
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.resolution.0.name: default
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.resolution.count: 1
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.supports_colorspace_change: false
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.supports_downloadfonts_change: false
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.supports_jobtitle_change: false
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.supports_orientation_change: true
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.supports_paper_size_change: true
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.supports_plex_change: false
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.supports_printincolor_change: true
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.supports_resolution_change: false
print.tmp.printerfeatures.HP_LaserJet_Professional_M1132_MFP.supports_spoolercommand_change: false
privacy.clearOnShutdown.offlineApps: true
privacy.donottrackheader.enabled: true
privacy.sanitize.migrateFx3Prefs: true
storage.vacuum.last.index: 1
storage.vacuum.last.places.sqlite: 1394976080

Graphics
--------

Adapter Description: NVIDIA Corporation -- GeForce GTX 560 Ti/PCIe/SSE2
Device ID: GeForce GTX 560 Ti/PCIe/SSE2
Driver Version: 4.4.0 NVIDIA 331.49
GPU Accelerated Windows: 0/1 Basic
Vendor ID: NVIDIA Corporation
WebGL Renderer: NVIDIA Corporation -- GeForce GTX 560 Ti/PCIe/SSE2
windowLayerManagerRemote: false
AzureCanvasBackend: cairo
AzureContentBackend: cairo
AzureFallbackCanvasBackend: none
AzureSkiaAccelerated: 0

JavaScript
----------

Incremental GC: true

Accessibility
-------------

Activated: false
Prevent Accessibility: 0

Library Versions
----------------

NSPR
Expected minimum version: 4.10.4
Version in use: 4.10.4

NSS
Expected minimum version: 3.16 Basic ECC
Version in use: 3.16 Basic ECC

NSSSMIME
Expected minimum version: 3.16 Basic ECC
Version in use: 3.16 Basic ECC

NSSSSL
Expected minimum version: 3.16 Basic ECC
Version in use: 3.16 Basic ECC

NSSUTIL
Expected minimum version: 3.16
Version in use: 3.16
Crash Signature: [@ mozalloc_abort(char const*) | NS_DebugBreak | X11Error ]
Keywords: crash, reproducible
See Also: → 733324
Might be interesting to watch Firefox pixmap usage with something like "xrestop -b -m 1|grep -A 16 Firefox" to see whether this is growing, and whether using a different gtk theme resolves the issue.
Summary: Crash when opened link with right click [@ mozalloc_abort(char const*) | NS_DebugBreak | X11Error ] → X_CreatePixmap: BadAlloc Crash with oxygen-gtk when opened link with right click [@ mozalloc_abort(char const*) | NS_DebugBreak | X11Error ]
Reporter

Comment 3

5 years ago
(In reply to Karl Tomlinson (:karlt) from comment #2)
> Might be interesting to watch Firefox pixmap usage with something like
> "xrestop -b -m 1|grep -A 16 Firefox" to see whether this is growing, and
> whether using a different gtk theme resolves the issue.

Different gtk theme?

I do not understanding .:) It same with Firefox theme?
Check ~/.gtkrc-2.0 and GTK2_RC_FILES for something setting
gtk-theme-name="oxygen-gtk", and remove that line.
I'm hesitant to track this without some more investigating since this is not a top crash and could possibly impact a very small segment of users.

Comment 6

5 years ago
Any chance this bug will be fixed in the near future?
I had never seen this one when using Kubuntu 13.10. I upgraded today to 14.4.1 and now Thunderbird is unusable because of this crash. It always crashes when I right-click a link or Alt+F for menu, but I also saw it crash after trying to snooze Lightning reminders and when clicking menu button. I'm not using Thunderbird from Ubuntu but Earlybird build from Mozilla (07-21 build initially, 08-02 now) so this seems to depend on system packages installed not Thunderbird version. It also crashes in safe mode. oxygen-gtk is the default theme for GTK2 apps on this system, if I choose Raleigh instead crashes stop but both Firefox and Thunderbird widgets look ugly. Firefox does not crash for me.

How to move this bug forward? Any additional info I could provide to help fixing it?
Ok, I think I found a workaround for myself. It seems that gtk2-engines-oxygen has some application name specific code. Inside oxygenapplicationname.cpp for example there is

// tag all mozilla-like applications (XUL)
static const std::string XulAppNames[] =
{
    "firefox",
    "thunderbird",
    "seamonkey",
    "iceweasel",
    "icecat",
    "icedove",
    "xulrunner",
    "komodo",
    "aurora",
    "zotero",
    ""
};

Note that it has aurora but not earlybird (at least in 1.4.4 source I looked at). I used to run Earlybird so that Thunderbird executable was symlinked to /usr/bin/earlybird. If instead I run Thunderbird executable with full path it does not crash. A symlink named thunderbird might also work, didn't try that.

Updated

5 years ago
Blocks: 1062145

Comment 9

5 years ago
(In reply to Merike (:merike) from comment #8)
> Ok, I think I found a workaround for myself. It seems that
> gtk2-engines-oxygen has some application name specific code. Inside
> oxygenapplicationname.cpp for example there is

Is the best way forward to reach out to KDE and ask them to add earlybird, instantbird, firefoxdeveloperedition(?) etc to that file?
Flags: needinfo?(gasell+mozilla)

Comment 10

5 years ago
(In reply to Merike (:merike) from comment #8)
> Note that it has aurora but not earlybird (at least in 1.4.4 source I looked
> at). I used to run Earlybird so that Thunderbird executable was symlinked to
> /usr/bin/earlybird. If instead I run Thunderbird executable with full path
> it does not crash. A symlink named thunderbird might also work, didn't try
> that.

Symlinking the executable to one of the names listed in comment #8 indeed works. (We can hardly expect our users to do this though)

Comment 11

5 years ago
(In reply to aleth [:aleth] from comment #9)
> Is the best way forward to reach out to KDE and ask them to add earlybird,
> instantbird, firefoxdeveloperedition(?) etc to that file?

I filed https://bugs.kde.org/show_bug.cgi?id=341181, please add any further application names there if I have missed any.
(In reply to aleth [:aleth] from comment #9)
> Is the best way forward to reach out to KDE and ask them to add earlybird,
> instantbird, firefoxdeveloperedition(?) etc to that file?

Probably, although this fixed list based approach is always going to bite some xul-based apps not listed. Also, I believe earlybird and dev edition are not necessary because they run as thunderbird and firefox. I only had issues with earlybird because it was symlinked to a different name than thunderbird but that's not the default case.
Flags: needinfo?(gasell+mozilla)

Comment 13

5 years ago
(In reply to Merike (:merike) from comment #12)
> Probably, although this fixed list based approach is always going to bite
> some xul-based apps not listed. Also, I believe earlybird and dev edition
> are not necessary because they run as thunderbird and firefox. I only had
> issues with earlybird because it was symlinked to a different name than
> thunderbird but that's not the default case.

Ah, I misunderstood your comment then - thanks!
bp-707edd2f-ef03-44f3-a8cd-118fd2150430 pewog
Whiteboard: [tbird crash][workaround:comment 8]

Comment 15

4 years ago
Now fixed (at least for the listed XUL apps) upstream for oxygen-gtk 1.4.
http://quickgit.kde.org/?p=oxygen-gtk.git&a=commit&h=b1ee5fb80c44c6c8a625333af1cfdc997d408805
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Updated

4 years ago
Duplicate of this bug: 1062145
You need to log in before you can comment on or make changes to this bug.