Closed Bug 986465 Opened 6 years ago Closed 6 years ago

[Messaging] In list of messages to delete, contact name overlaps the photo

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

x86
Windows 7
defect
Not set

Tracking

(blocking-b2g:1.3+, b2g-v1.3 fixed, b2g-v1.3T fixed, b2g-v1.4 fixed, b2g-v2.0 fixed)

VERIFIED FIXED
1.4 S4 (28mar)
blocking-b2g 1.3+
Tracking Status
b2g-v1.3 --- fixed
b2g-v1.3T --- fixed
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed

People

(Reporter: lolimartinezcr, Assigned: steveck)

References

Details

(Keywords: regression)

Attachments

(2 files)

Attached image 2014-03-21-09-13-15.png
1.4
Platform version: 30.0a2
Build ID: 20140320052229
Git commit: ee89ad8c
Reproducible: 100%

Prerequisites: 
Send messages to added contact with name/surname long.

STR:
1) Tap messages aplication.
2) Tap in message sended to contact with name/surname long.
3) Tap "..." button (top-right)
4) Tap "Delete messages" button

Actual result:
Contact name overlaps the photo (See attached image)

Expected result:
Correct screen with name not overlapt the photo.
I was not aware that in edit mode we are leaving the contact's photo in the list of threads...
In fact, in first Firefox OS version we remove it in order to avoid that kind of errors as there was no enough space for checkbox, name and photo. 

Now I am checking Visual refresh spec for v1.5 and in edit mode the photo is not included so I suspect that the picture should not be there.

I am also reproducing this overlapping in v1.3 and it's not a minor bug, so before nominating, I would like Ayman and Julien to clarify if the bug is the contact name overlapping or including the photo in threads list edit mode, just to be sure where the problem is and QA can check the Regression window.
Flags: needinfo?(felash)
Flags: needinfo?(aymanmaat)
QAwanted: does it happen in 1.1?

I actually don't know how it should behave.
Flags: needinfo?(felash)
Keywords: qawanted
Checking a comercial build for v1.1, the photo is not included in the edit mode of the list of threads
Okay, so I think we should do the same here, this somehow regressed.
Keywords: regression
Nominating to v1.3, it's a regression that it's affecting v1.3 and v1.4, as it has not been specified including the contact's photo in edit mode.

It's not a minor bug and although it's reproduced in edit mode, from a user point of view is very ugly to see that overlapping so removing it is the solution.
blocking-b2g: --- → 1.3?
QA Contact: astole
Before we add the regression keywords here, let's prove this is not reproducing on 1.1.
(In reply to Jason Smith [:jsmith] from comment #6)
> Before we add the regression keywords here, let's prove this is not
> reproducing on 1.1.

Does not repro in 1.1, different functionality than in 1.4

Environmental Variables:
Device: Buri 1.1 MOZ
BuildID: 20140318041202
Gaia: 44a2ddf63373f8e95c784faf4ed4d60081699c61
Gecko: 2c70ef07c5b3
Version: 18.0
Firmware Version: V1.2-device.cfg
Keywords: qawanted
David,

Please help reassign as its an ugly UX.
blocking-b2g: 1.3? → 1.3+
Flags: needinfo?(dscravaglieri)
I'll take it first.
Assignee: nobody → schung
Flags: needinfo?(dscravaglieri)
(In reply to Maria Angeles Oteo (:oteo) from comment #1)
> I was not aware that in edit mode we are leaving the contact's photo in the
> list of threads...
> In fact, in first Firefox OS version we remove it in order to avoid that
> kind of errors as there was no enough space for checkbox, name and photo. 
> 
> Now I am checking Visual refresh spec for v1.5 and in edit mode the photo is
> not included so I suspect that the picture should not be there.
> 
> I am also reproducing this overlapping in v1.3 and it's not a minor bug, so
> before nominating, I would like Ayman and Julien to clarify if the bug is
> the contact name overlapping or including the photo in threads list edit
> mode, just to be sure where the problem is and QA can check the Regression
> window.

from a UX PoV this is a regression. I specified that photographs associated to a contact would be removed when the Message app inbox is put into edit mode in order to make way for the checkboxes that come in on the left hand side of the screen ...and it certainly worked this way in earlier versions (as your regression tests have proved).

We should fix this as a priority not only because it is a regression but because the problem will be quite prevent in markets where users have longer names such as South America.
Flags: needinfo?(aymanmaat)
(In reply to ayman maat :maat from comment #10)

> from a UX PoV this is a regression. I specified that photographs associated
> to a contact would be removed when the Message app inbox is put into edit
> mode in order to make way for the checkboxes that come in on the left hand
> side of the screen ...and it certainly worked this way in earlier versions
> (as your regression tests have proved).
> 
> We should fix this as a priority not only because it is a regression but
> because the problem will be quite prevent in markets where users have longer
> names such as South America.

After some investigation, the portrait of contact is moved out of screen for edit mode in the earlier version like you said, and it might be a regression in bug 972245. Do you suggest we should remove the portrait in edit mode like the earlier version or keep it in the same position?
Flags: needinfo?(aymanmaat)
(In reply to Steve Chung [:steveck] from comment #11)
> (In reply to ayman maat :maat from comment #10)
> 
> After some investigation, the portrait of contact is moved out of screen for
> edit mode in the earlier version like you said, and it might be a regression
> in bug 972245. Do you suggest we should remove the portrait in edit mode
> like the earlier version or keep it in the same position?

Hey steve, we should remove the portrait like in earlier versions in order to make room for the check boxes coming in on the left hand side of the screen.
Flags: needinfo?(aymanmaat)
Attached file Link to github
Hi Julien, I resume the previous behavior based on Ayman's comment. Fortunately it's only one-line css fixing :)
Attachment #8396283 - Flags: review?(felash)
Comment on attachment 8396283 [details] [review]
Link to github

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 972245 regression
[User impact] if declined: Brolen UI in message edit mode
[Testing completed]: No (css changes only)
[Risk to taking this patch] (and alternatives if risky): no
[String changes made]: no
Attachment #8396283 - Flags: approval-gaia-v1.3?(fabrice)
Comment on attachment 8396283 [details] [review]
Link to github

Hi Steve! I've tested your patch when checking the new 'edit' mode (check https://bugzilla.mozilla.org/show_bug.cgi?id=986433) and works as a charm. I'll give you the R+, but if you want to wait till having Julien's feedback is fine!

Thanks a lot for the surgical patch!!! :)
Attachment #8396283 - Flags: review+
Comment on attachment 8396283 [details] [review]
Link to github

If Borja is fine with it, then I don't need to look more at it ;)
Attachment #8396283 - Flags: review?(felash)
Attachment #8396283 - Flags: approval-gaia-v1.3?(fabrice) → approval-gaia-v1.3+
Blocks: 972245
Keywords: regression
In master: 0aaacfb35bc914814904a02a49e1abb9a56ac099
     v1.3: 0cd29242483f7635082bbb5c25629e3a0995d2fb
     v1.4: 6bcb9fa87afd6fc3e57a2eda7f69cc2641a90444
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.4 S4 (28mar)
tested and working
1.5 
Gecko fa7c5ad
Gaia 7c73c66

1.4
Gecko a15cb07
Gaia 441c4bc

1.3
Gecko c54bdf7
Gaia 11d027e
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.