[Windows Classic] New tab button stealing focus from unselected tabs

VERIFIED FIXED in Firefox 29

Status

()

Firefox
Theme
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Tss, Assigned: mconley)

Tracking

(Depends on: 1 bug, Blocks: 1 bug)

31 Branch
Firefox 31
x86
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox29 verified, firefox30 verified, firefox31 verified)

Details

(Whiteboard: [Australis:P3])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140322030204

Steps to reproduce:

Using Windows Classic theme, when you hover over the rightmost unselected tab (next to the new tab button), new tab button takes focus when the cursor is still over the unselected tab's close button.

Bug 978752 - "Tab strip gradient is broken in customization mode on Windows XP in classic mode" introduced some z-index layering to tabs and new tab button, and I think that's the origin of the problem. I used

main-window[tabsintitlebar]:not([sizemode=fullscreen]) .tabbrowser-tab:not([selected=true]) {
    z-index: 2 !important;
    }

#main-window[tabsintitlebar]:not([sizemode=fullscreen]) .tabbrowser-tab[selected=true] {
    z-index: 3 !important;
    }

to set the tabs on higher layers, and it seems to fix the issue.

Updated

3 years ago
Blocks: 978752, 872617
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [Australis:P3]

Updated

3 years ago
Summary: New tab button stealing focus from unselected tabs → [Windows Classic] New tab button stealing focus from unselected tabs

Updated

3 years ago
Component: Untriaged → Theme
(Assignee)

Comment 1

3 years ago
Created attachment 8396490 [details] [diff] [review]
Patch v1

Naive patch. Should I put some space between these z-index's for add-ons?
Assignee: nobody → mconley
Status: NEW → ASSIGNED
Attachment #8396490 - Flags: review?(gijskruitbosch+bugs)
(Assignee)

Comment 2

3 years ago
Comment on attachment 8396490 [details] [diff] [review]
Patch v1

Nope nope nope - this overlaps the selected tab.
Attachment #8396490 - Flags: review?(gijskruitbosch+bugs)
(Assignee)

Comment 3

3 years ago
Created attachment 8396602 [details] [diff] [review]
Patch v2

So, this appears to be better. Layering seems to be right. Kept my eye on things like the separators and the overflow arrow buttons, and didn't see anything hairy.

As before, I wonder if I should space out the indexes a little bit for add-ons to jam things in between. Open to suggestions there.
Attachment #8396490 - Attachment is obsolete: true
Attachment #8396602 - Flags: review?(gijskruitbosch+bugs)

Comment 4

3 years ago
Comment on attachment 8396602 [details] [diff] [review]
Patch v2

Review of attachment 8396602 [details] [diff] [review]:
-----------------------------------------------------------------

WFM.
Attachment #8396602 - Flags: review?(gijskruitbosch+bugs) → review+
(Assignee)

Comment 5

3 years ago
Thanks!

remote:   https://hg.mozilla.org/integration/fx-team/rev/eefdd02dd206
Whiteboard: [Australis:P3] → [Australis:P3][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/eefdd02dd206
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Whiteboard: [Australis:P3][fixed-in-fx-team] → [Australis:P3]
Target Milestone: --- → Firefox 31

Comment 7

3 years ago
Comment on attachment 8396602 [details] [diff] [review]
Patch v2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Australis! But also, bug 978752
User impact if declined: weird overlap between tabs and new tab button
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): relatively low, just changes z-indices of the tabs
String or IDL/UUID changes made by this patch: none
Attachment #8396602 - Flags: approval-mozilla-beta?
Attachment #8396602 - Flags: approval-mozilla-aurora?
Attachment #8396602 - Flags: approval-mozilla-beta?
Attachment #8396602 - Flags: approval-mozilla-beta+
Attachment #8396602 - Flags: approval-mozilla-aurora?
Attachment #8396602 - Flags: approval-mozilla-aurora+
This code needs some documentation. It's not even obvious why .tabs-newtab-button has z-index:1 in the first place, let alone that this is what made you give .tabbrowser-tab a z-index too.
Aurora: https://hg.mozilla.org/releases/mozilla-aurora/rev/9fc38ffaff75
status-firefox29: --- → affected
status-firefox30: --- → fixed
status-firefox31: --- → fixed
(Assignee)

Comment 10

3 years ago
(In reply to Dão Gottwald [:dao] from comment #8)
> This code needs some documentation. It's not even obvious why
> .tabs-newtab-button has z-index:1 in the first place, let alone that this is
> what made you give .tabbrowser-tab a z-index too.

Sure, I can add that documentation. Would you mind filing a bug and assigning it to me?

Comment 11

3 years ago
not-the-right-revsee-comment-13
Beta: https://hg.mozilla.org/releases/mozilla-beta/rev/e24101b952ad
status-firefox29: affected → fixed

Updated

3 years ago
Depends on: 990099

Updated

3 years ago
Keywords: verifyme
Reproduced the initial issue on nightly build from 2014-03-23, verified fixed on Windows XP 32bit, Windows 7 32bit/64bit using Firefox 29 beta 4, latest Aurora and latest Nightly.
Status: RESOLVED → VERIFIED
status-firefox29: fixed → verified
status-firefox30: fixed → verified
status-firefox31: fixed → verified
Keywords: verifyme
(Assignee)

Updated

3 years ago
Depends on: 989761
It looks like this should be the patch for beta (rather than e24101b952ad):

https://hg.mozilla.org/releases/mozilla-beta/rev/126e650100c6
(Assignee)

Comment 14

3 years ago
Yes, that's correct - thanks mcdavis941.
(Assignee)

Comment 15

3 years ago
Backed out of mozilla-central as https://hg.mozilla.org/integration/fx-team/rev/6a5529e2150d

We landed a better solution in Bug 989761. Back-outs for mozilla-aurora and mozilla-beta will follow once bug 989761 gets uplift approval.
(Assignee)

Comment 16

3 years ago
Ugh - I should have said backed out of fx-team, not mozilla-central. Of course this will get backed out of mozilla-central after merge.
(Assignee)

Comment 17

3 years ago
Backouts:

mozilla-central: https://hg.mozilla.org/mozilla-central/rev/6a5529e2150d

Aurora: https://hg.mozilla.org/releases/mozilla-aurora/rev/a9b6b1a08970

Beta: https://hg.mozilla.org/releases/mozilla-beta/rev/a90a4219b520


This problem was fixed with a different solution in bug 989761.
You need to log in before you can comment on or make changes to this bug.