Closed Bug 98751 Opened 22 years ago Closed 19 years ago

"Update Remembered Query" option

Categories

(Bugzilla :: Query/Bug List, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
Bugzilla 2.20

People

(Reporter: mestahl, Assigned: jouni)

References

Details

Attachments

(1 file)

As a new bugzilla user on a different project, I find it difficult to 
get the "memorized queries" correct the first time.  It takes a while
to establish a pattern of use, and figure out what makes a good query. 
Over time, I've established conventions about the use of certain fields
(Priority, CC, etc.) that make the previously memorized query no longer
useful.  

However, there's no way to update a memorized query once it's been created.
There is an "edit this query" option, but it doesn't affect the memorized 
queries.  The only solution is to memorize a new query based on the old 
one, then delete the old one.  Annoying.  

I'd like the ability to replace / update a memorized query. A good approach
would be to add an option to the Memorized query box at the bottom of the
screen, that allows a user to replace a memorized query with the current one.
You can load a query by using 'Edit This Query' on buglist.cgi or 'Load the
remembered query' on query.cgi.

You can update a query by using 'Remember this query as' on query.cgi, and using
the same name as an existing query.  I'm not sure what else is needed.
Thanks for the help.  What you mention will be sufficient.  Previous tests had
misled me to believe a query could not be overwritten.  I suspect I had not
typed the query name EXACTLY in my tests. 

It might still be nice to have an option like "Update remembered query [popup
menu]".  This would solve the problem of retyping the query name exactly.  But
this is much less important to me now that I can update the query indirectly.  
I'll agree with this statement.  It would be nice if the three options next to
the popup menu had a third option "Update the remembered query", and "Remember
this as query" did not allow you to overwrite an existing query.
Priority: -- → P3
Summary: Ability to Edit Memorized Queries → "Update Remembered Query" option
Target Milestone: --- → Bugzilla 2.18
Nobody has touched this in a while. Taking, as I'm going to consider something
like this for our installation pretty soon anyway. If someone has something
going on with this bug, note it in the comments so we won't do unnecessary
duplicate work.
Assignee: endico → jouni
OS: Linux → All
Hardware: PC → All
I find myself doing weekly reports using bugzilla, and having the ability to
replace a previously-remembered query with a new one via a drop-down list would
simplify my life substantially.
Gerv, what do you think about this? Your bug 179339 somewhat changed the
situation around this (ccing Dave and Myk as well -- they commented on the UI
created by Gerv's bug) 

The philosophy of this bug technically still remains, but I'm not sure this is
worth doing. Anyway, the idea of separating "save as a new query" and "overwrite
an existing query" hasn't yet been implemented. This could be done by adding a
"(Modify existing query) [ mystoredqueries  v]" UI item to the buglist footer,
but that would probably just cause confusion. 

However, a useful compromise could be to pass the stored query name to query.cgi
when clicking the "Edit this query" link. Then, after submitting the query, the
bottom bar would have the option "Overwrite existing query Foobar". That way you
wouldn't have to retype the name of your stored query each time you edit it.


Opinions on this?
I think Jouni's last idea might be OK.

You run a query, and click "Edit this query". The query name is passed across
and put into a hidden form field. When you run the new query, that field is used
as the default value of the "Save this query as" box - i.e. you just hit the
button to overwrite the query you originally edited.

Gerv
Enhancements which don't currently have patches on them which are targetted at
2.18 are being retargetted to 2.20 because we're about to freeze for 2.18. 
Consideration will be taken for moving items back to 2.18 on a case-by-case
basis (but is unlikely for enhancements)
Target Milestone: Bugzilla 2.18 → Bugzilla 2.20
Attached patch v1Splinter Review
This is pretty simple. It adds a couple of things:

- When outputting the "edit search" link (after buglist), append parameter
  &known_name=xxx if it's a stored query.
- In query.cgi, pass this parameter to the templates as $vars->{'known_name'}
- In search/knob.html.tmpl, push possible value of known_name to a hidden 
  field called 'query_based_on'
- In buglist.cgi, if query_based_on is given, pass it into templates as
  "defaultsavename"; then use this as the default content for the "Remember 
  search as" inputfield. 

(actually, the edit search link also gets the known_name parameter appended
from the defaultsavename, so that editing the query multiple times in a row
will still remember the query name)

Any suggestions re parameter names are welcome, of course.
Attachment #153639 - Flags: review?(gerv)
*** Bug 65393 has been marked as a duplicate of this bug. ***
Comment on attachment 153639 [details] [diff] [review]
v1

r=gerv - looks good. Have you checked this isn't going to impact any of the
other users of any of these templates (the series stuff, for example)?

Gerv
Attachment #153639 - Flags: review?(gerv) → review+
(In reply to comment #11)
> r=gerv - looks good. Have you checked this isn't going to impact any of the
> other users of any of these templates (the series stuff, for example)?

Well... The complexity of the query forms make it pretty unwieldy to test all
possible situations in any reasonable manner. I tried out all sorts of ways to
use and abuse the form, and nothing seemed broken - and code-wise, it should be
of minimal impact since no existing logic gets changed. Let's get it in and see
if something breaks ;-)
Status: NEW → ASSIGNED
Flags: approval?
Flags: approval? → approval+
Checking in buglist.cgi;
/cvsroot/mozilla/webtools/bugzilla/buglist.cgi,v  <--  buglist.cgi
new revision: 1.257; previous revision: 1.256
done
Checking in query.cgi;
/cvsroot/mozilla/webtools/bugzilla/query.cgi,v  <--  query.cgi
new revision: 1.130; previous revision: 1.129
done
Checking in template/en/default/list/list.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/list/list.html.tmpl,v 
<--  list.html.tmpl
new revision: 1.26; previous revision: 1.25
done
Checking in template/en/default/search/knob.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/search/knob.html.tmpl,v 
<--  knob.html.tmpl
new revision: 1.16; previous revision: 1.15
done
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.