Closed Bug 987963 Opened 8 years ago Closed 8 years ago

Reset isLoaded state in HomeFragment on configuration change

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

(fennec31+)

RESOLVED FIXED
Firefox 31
Tracking Status
fennec 31+ ---

People

(Reporter: Margaret, Assigned: lucasr)

References

Details

Attachments

(1 file)

Breaking this off from bug 942281 to land it (and uplift it) separately.

This issue is not specific to hub panels, but rather is a problem that has existed since our new about:home rewrite.
Blocks: 942281
Lucas already wrote a patch for this, moving it over here for posterity.
Attachment #8396664 - Flags: review+
After some further investigation, I realized that should only force reload in DynamicPanel due to its async UI creation. Built-in panels should be kept unchanged. I'll leave this patch in for now so that this issue doesn't block bug 942281 from landing. I'll fix this in bug 988355.
https://hg.mozilla.org/mozilla-central/rev/38b3e86f9e99
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 31
Duplicate of this bug: 987962
tracking-fennec: ? → 31+
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.