Closed Bug 988296 Opened 7 years ago Closed 7 years ago

imsSettings-header points to messageSettings, should be imsSettings ('Message settings' vs. 'IMS settings')

Categories

(Firefox OS Graveyard :: Gaia::Settings, defect)

x86_64
Windows 8.1
defect
Not set
normal

Tracking

(b2g-v1.4 verified, b2g-v2.0 verified)

VERIFIED FIXED
1.4 S4 (28mar)
Tracking Status
b2g-v1.4 --- verified
b2g-v2.0 --- verified

People

(Reporter: aryx, Assigned: aryx)

References

Details

(Keywords: late-l10n)

Attachments

(1 file)

Boot2Gecko 1.5.0.0-prerelease 20140325024149 on Keon

Opening Settings > Mobile & Data > IMS settings shows "Message settings" as header because imsSettings-header = {{messageSettings}}
Depends on: 969298
Sorry guys, my fault. Too much copy & paste leads to this issues.
Comment on attachment 8397054 [details] [review]
pull request, v1

r=me, thanks!
Attachment #8397054 - Flags: review?(arthur.chen) → review+
master: 2a64e655196e86b5c7f12a521507c328d59b23cd
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Comment on attachment 8397054 [details] [review]
pull request, v1

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Initial landing of IMS settings pane (bug 969298)
[User impact] if declined: IMS settings pane will have header 'Message settings'
[Testing completed]: Verified fix on Keon with B2G 1.5.0.0-prerelease 20140329
[Risk to taking this patch] (and alternatives if risky): None
[String changes made]: One string changed:
-imsSettings-header = {{messageSettings}}
+imsSettings-header2 = {{imsSettings}}
Attachment #8397054 - Flags: approval-gaia-v1.4?
(In reply to Archaeopteryx [:aryx] from comment #5)
> Comment on attachment 8397054 [details] [review]
> pull request, v1
> 
> NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to
> better understand the B2G approval process and landings.
> 
> [Approval Request Comment]
> [Bug caused by] (feature/regressing bug #): Initial landing of IMS settings
> pane (bug 969298)
> [User impact] if declined: IMS settings pane will have header 'Message
> settings'
> [Testing completed]: Verified fix on Keon with B2G 1.5.0.0-prerelease
> 20140329
> [Risk to taking this patch] (and alternatives if risky): None
> [String changes made]: One string changed:
> -imsSettings-header = {{messageSettings}}
> +imsSettings-header2 = {{imsSettings}}

Hi :aryx 3/28 was the hard string freeze on mozilla side to take any string changes for 1.4 here. Lets see if :flod from the l10n team has any ideas to help provide alternatives(may be reuse existing strings) here or an exception here else this may have to wait till v1.5.
Flags: needinfo?(francesco.lodolo)
Basically the header in English is currently wrong (it says "Message settings" instead of "IMS settings").

So, first step would be to determine if English needs to fix this string on 1.4 (I guess the answer is yes).

The alternative to breaking string freeze on 1.4, is to change the existing string (imsSettings-header) *only on 1.4* to

> imsSettings-header = {{imsSettings}}

And then reach out to localizers (currently there are 15 strings identical to en-US). It's far from ideal but it's also the only alternative to breaking string-freeze if English needs to fix it.
Flags: needinfo?(francesco.lodolo)
Asked Pike's opinion on this. Considering the amount of broken localizations, it's better to land the new string on 1.4, even if it breaks string freeze.
Yeah, we need to fix this, sadly.
An alternative would be to include a script which runs when the IMS settings pane gets loaded and checks if the header title == messageSettings string. If true, replace with imsSettings.
Comment on attachment 8397054 [details] [review]
pull request, v1

given comment #8, #9 approving this and requesting verification in parallel.
Attachment #8397054 - Flags: approval-gaia-v1.4? → approval-gaia-v1.4+
Keywords: verifyme
IMS settings header displays “IMS settings” 1.4, 2.0

1.4 Environmental Variables:
Device: Buri 1.4 MOZ
BuildID: 20140527000202
Gaia: 0542778892a294d224e75af4a76be5d42938bc90
Gecko: d583ae109f54
Version: 30.0
Firmware Version: v1.2-device.cfg

2.0 Environmental Variables:
Device: Flame 2.0 MOZ
BuildID: 20140527040202
Gaia: 6a391274cd436f8f0d1fad2db8c6b4805703259c
Gecko: cbe4f69c2e9c
Version: 32.0a1
Firmware Version: v1.2-device.cfg
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.