Closed Bug 989022 Opened 6 years ago Closed 6 years ago

JS error Causing a blank screen on Webpay if sim is not present.

Categories

(Core :: DOM: Device Interfaces, defect)

28 Branch
x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla28
blocking-b2g 1.3+
Tracking Status
b2g-v1.3 --- fixed
b2g-v1.3T --- fixed
b2g-v1.4 --- unaffected
b2g-v2.0 --- unaffected

People

(Reporter: scolville, Assigned: ferjm)

References

Details

(Keywords: regression)

Attachments

(3 files)

STR:

Reproduceable on FFOS 1.2/3 using a device *without* a sim inserted.

* Open marketplace 
* Find paid apps by entering :paid 
* Click purchase
* Get a blank screen

In the logcat you'll see the following error:

[JavaScript Error: "TypeError: this.iccInfo is null" {file: "chrome://browser/content/payment.js" line: 261}]

Reproducible on -dev/stage/prod
Blocks: 987861
Might be the same problem as bug 988621.

Can we confirm this doesn't happen on 1.1?
Component: General → Gaia::System::Window Mgmt
Keywords: qawanted
See Also: → 988621
QA Contact: pcheng
I was able to encounter the blank screen and Javascript error on the following:
v1.3 Environmental Variables:
Device: Buri v1.3 MOZ
BuildID: 20140401004003
Gaia: 24f562fce468fc948ac9e6185e002c23350cb9ee
Gecko: 0adf24a785f2
Version: 28.0
Firmware Version: v1.2-device.cfg

Attaching a logcat and a screenshot of the issue occurring.


Issue did NOT reproduce on the following:
v1.1 Environmental Variables:
Device: Buri v1.1 MOZ
BuildID: 20140318041202
Gaia: 44a2ddf63373f8e95c784faf4ed4d60081699c61
Gecko: 2c70ef07c5b3
Version: 18.0
Firmware Version: v1.2-device.cfg
Duplicate of this bug: 993048
Can we confirm this isn't reproducing on 1.1?
Component: Gaia::System::Window Mgmt → General
Keywords: qawanted
(In reply to Jason Smith [:jsmith] from comment #5)
> Can we confirm this isn't reproducing on 1.1?

Also - reconfirm this is still reproducing on the latest 1.3?
Reconfirming that issue occurs in latest Buri 1.3

Issue was reproduced following the original repro steps after SIM card was removed from the phone. Attempted to reproduce 10 times. 

1.3 Environmental Variables:
Device: buri 1.3 MOZ
BuildID: 20140407004003
Gaia: 9555c6d1b40ee40ac0713bba9f54d3943aff635f
Gecko: 4bba1932fb68
Version: 28.0
Firmware Version: v1.2-device.cfg

Issue DOES NOT occur in latest Buri 1.1 build. 
Attempted to reproduce 10 times.
Keywords: qawanted
QA Contact: pcheng → ddixon
blocking-b2g: --- → 1.3?
Component: General → DOM: Device Interfaces
Product: Firefox OS → Core
Version: unspecified → 28 Branch
Fernando - Can you take a look?
blocking-b2g: 1.3? → 1.3+
Flags: needinfo?(ferjmoreno)
David,

Is this a payments cert blocker?
Flags: needinfo?(dbialer)
yes.  It is a blocker.  Paid apps won't work on devices without a SIM.
Flags: needinfo?(dbialer)
Whiteboard: [cert]
Assignee: nobody → ferjmoreno
Flags: needinfo?(ferjmoreno)
Does this happen on master or only 1.3?
(In reply to Fernando Jiménez Moreno [:ferjm] from comment #11)
> Does this happen on master or only 1.3?

Unable to reproduce issue on latest Master 1.5 build. 

1.5 Environmental Variables:
Device: buri 1.5 MOZ
BuildID: 20140410040201
Gaia: 9d0b1bdf746823a94b13e6574c1d8304dc584763
Gecko: 690c810c8e3e
Version: 31.0a1
Firmware Version: v1.2-device.cfg

Currently finding the regression window.
Attached patch v1 (for 1.3)Splinter Review
Attachment #8405313 - Flags: review?(fabrice)
Attachment #8405313 - Flags: review?(fabrice) → review+
Thanks Fabrice.

This patch needs to land in 1.3 and 1.3t
Keywords: checkin-needed
Needs approval-mozilla-b2g28 to do so. Also, is 1.4 affected?
Whiteboard: [cert]
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #15)
> Needs approval-mozilla-b2g28 to do so. Also, is 1.4 affected?

Issue DOES NOT reproduce in latest 1.4 Aurora Build. 
 
Attempted to reproduce issue 3 times.

1.4 Environmental Variables:
Device: buri 1.4 MOZ
BuildID: 20140415000202
Gaia: c8f916c8569f6ee652237fd10ac925e08cd3d9bc
Gecko: f14047fa8d63
Version: 30.0a2
Firmware Version: v1.2-device.cfg
What's the status here?  Awaiting b2g28 approval?  If 1.3 and 1.3t are affected and it's been marked as a 1.3 blocker, I can't see why we wouldn't give that approval.

FWIW, it seems that Fernando is on PTO until next Thursday.
Flags: needinfo?(fabrice)
Looks like you're right Andrew.
Flags: needinfo?(fabrice)
Attachment #8405313 - Flags: approval-mozilla-b2g28+
QA Contact: ddixon
Per Faramarz's email, we need to close this out. We need this landed.
Keywords: checkin-needed
https://hg.mozilla.org/releases/mozilla-b2g28_v1_3/rev/d7eabc43ee13
Status: NEW → RESOLVED
Closed: 6 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla28
Duplicate of this bug: 1035307
You need to log in before you can comment on or make changes to this bug.