Closed Bug 989450 Opened 7 years ago Closed 7 years ago

TypeError: coercing to Unicode: need string or buffer, TestManifest found after Bug 987398

Categories

(Testing :: Mochitest, defect, P1)

x86_64
Windows 7
defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: Optimizer, Unassigned)

References

Details

(Keywords: regression)

Trying to run mochtests, I get this:

$ mach mochitest-browser toolkit/devtools/server/tests/browser/browser_storage_dynamic_windows.js
From _tests: Kept 15337 existing; Added/updated 3; Removed 0 files and 0 directories.
 0:11.73 MochitestServer : launching [u'c:\\fx-team\\firefox\\dist\\bin\\xpcshell.exe', '-g', u'c:\\fx-team\\firefox\\dist\\bin', '-v', '170', '-f', 'c:\\fx-team\\firefox\\_tests\\testing\\mochites
t/httpd.js', '-e', "const _PROFILE_PATH = 'c:\\\\users\\\\girish~1\\\\appdata\\\\local\\\\temp\\\\tmp8atzkz'; const _SERVER_PORT = '8888'; const _SERVER_ADDR = '127.0.0.1'; const _TEST_PREFIX = und
efined; const _DISPLAY_RESULTS = false;", '-f', './server.js']
 0:11.73 runtests.py | Server pid: 9260
 0:12.73 runtests.py | Websocket server pid: 10864
Error running mach:

    ['mochitest-browser', 'toolkit/devtools/server/tests/browser/browser_storage_dynamic_windows.js']

The error occurred in code that was called by the mach command. This is either
a bug in the called code itself or in the way that mach is calling it.

You should consider filing a bug for this issue.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

TypeError: coercing to Unicode: need string or buffer, TestManifest found

  File "c:\fx-team\testing/mochitest/mach_commands.py", line 587, in run_mochitest_browser
    return self.run_mochitest(test_paths, 'browser', **kwargs)
  File "c:\fx-team\testing/mochitest/mach_commands.py", line 628, in run_mochitest
    test_paths=test_paths, suite=flavor, **kwargs)
  File "c:\fx-team\testing/mochitest/mach_commands.py", line 369, in run_desktop_test
    result = runner.runTests(options)
  File "c:\fx-team\firefox\_tests\testing\mochitest\runtests.py", line 1092, in runTests
    testURL = self.buildTestPath(options)
  File "c:\fx-team\firefox\_tests\testing\mochitest\runtests.py", line 437, in buildTestPath
    if options.manifestFile and os.path.isfile(options.manifestFile):
  File "c:\mozilla-build\python\lib\genericpath.py", line 29, in isfile
    st = os.stat(path)
I'll work on this ASAP since I'm responsible, since it blocks others, and since it should be little effort.
Keywords: regression
Priority: -- → P1
Is your tree fully built? You told me on IRC this was an issue with 722363d66998. But the line numbers and source code don't line up to what's actually in that revision.

https://hg.stage.mozaws.net/gecko/file/722363d66998/testing/mochitest/runtests.py#l431

Specifically, there is no "if options.manifestFile and os.path.isfile" any more. There *was* before bug 987398. https://hg.stage.mozaws.net/gecko/rev/b151f7bd1c10#l2.1

I think your runtests.py in your objdir is out of date. Performing a full build should bring it up to date.

Reopen if I'm wrong.
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(scrapmachines)
Resolution: --- → WORKSFORME
ok, worked after mach build.

Actually I passed the wrong hg identity, I had already done hg pull -u before you asked for hg identity.
Flags: needinfo?(scrapmachines)
You need to log in before you can comment on or make changes to this bug.