Closed Bug 989626 Opened 6 years ago Closed 6 years ago

Prevent "Tell me when a website asks to store data for offline use" label from overflowing in Settings > Advanced > Network > Offline Web Content

Categories

(Firefox :: Theme, defect)

x86_64
Linux
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 31
Tracking Status
firefox31 --- verified

People

(Reporter: tchevalier, Assigned: dao)

References

Details

(Keywords: regression)

Attachments

(3 files)

With the new in-content preferences, when the label "Tell me when a website asks to store data for offline use" is longer than en-US in localized builds (for instance in French, see attached screenshot), it overflows on "The following websites are allowed to store data for offline use:", making both labels hard to read.

This was not the case with the window-based preferences.
Whiteboard: [Australis:P?]
Whiteboard: [Australis:P?] → [P=?]
Bug 738796 caused this.
Blocks: 738796
Whiteboard: [P=?]
Attached patch patchSplinter Review
Assignee: nobody → dao
Status: NEW → ASSIGNED
Attachment #8400448 - Flags: review?(jaws)
Duplicate of this bug: 991361
This is not the only place text is overflowing, there are other places in the prefs where it does the same. I'll post a list later.
https://hg.mozilla.org/mozilla-central/rev/a44dfcf94431
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 31
Depends on: 993084
[bugday-20140409]

Hi,

I can reproduce the issue on Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0 ID:20140408030205 CSet: 8883360b1edb (french localized build), in Normal and Safe Mode, also with clean profile on Debian Sid.

Let me know if you need more information.

Thanks,
Francesca
I confirm, still seeing the bug on the latest Nightly
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
what a mess...
Attachment #8405323 - Flags: review?(jaws)
https://hg.mozilla.org/mozilla-central/rev/7e929146003e
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
[bugday-20140416]

Hi, 

I can confirm that the issue is no longer present in the latest french localized nightly, Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0 ID:20140416030202 CSet: dd50745d7f35 on Linux.

I've not the right permissions to set the bug's status to Verified, so I'll just add the "verified" status flag for the relevant version (31).

Cheers,
Francesca
Resolved -> Verified, as per comment#12
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.