Closed Bug 989785 Opened 7 years ago Closed 7 years ago

apps/calendar/test/marionette/week_view_test.js failing because of week view regression

Categories

(Firefox OS Graveyard :: Gaia::Calendar, defect)

All
Gonk (Firefox OS)
defect
Not set
blocker

Tracking

(Not tracked)

RESOLVED FIXED
1.4 S5 (11apr)

People

(Reporter: philor, Assigned: mmedeiros)

References

Details

(Whiteboard: [p=3])

Attachments

(2 files)

At least, my guess for why it's suddenly failing today and didn't fail at the end of January or the end of February is that both February 1st and March 1st fell on a Saturday.

https://tbpl.mozilla.org/php/getParsedLog.php?id=36965880&tree=B2g-Inbound

10:35:53     INFO -  TEST-START | week view multiple months (eg. "Dec 2013 Jan 2014")
10:41:23     INFO - Automation Error: mozprocess timed out after 330 seconds running ['make', 'test-integration', 'NPM_REGISTRY=http://npm-mirror.pub.build.mozilla.org', 'REPORTER=mocha-tbpl-reporter', 'TEST_MANIFEST=./shared/test/integration/tbpl-manifest.json']

do {} while () seems like a rather bustage-prone pattern to use in a test, but it's particularly unfortunate in this suite, where bug 953212 means that hangs are not caught in any vaguely useful way.
Attached file disable test
We should fix this :)
Curiously enough, it's not failing on mozilla-aurora.
I don't think the problem is because of the start of the month.. I think the bug was probably introduced last week when I landed Bug 988079 - which was a patch for the Day View, but seems to affect the Week View in a different way. - and the test was only able to catch the regression since now it required more than a few swipes.

The test implementation is correct. It changes the date until it finds a header that displays 2 months. Pooling is the right implementation for it since the UI doesn't have a way to skip to a certain date. (it won't need swipe for longer than 2 months..)

If I backout the Bug 988079 it will probably break other marionette tests. So not sure how I should approach this.
Depends on: 988079
Depends on: 990148
Assignee: nobody → mmedeiros
Keywords: leave-open
Summary: apps/calendar/test/marionette/week_view_test.js fails when the month starts in the middle of the week → apps/calendar/test/marionette/week_view_test.js failing because of week view regression
Whiteboard: [p=2]
Target Milestone: --- → 1.4 S5 (11apr)
reverted the patch that introduced the bug and wrote more tests to ensure this kind of regression doesn't happen anymore.
Attachment #8399646 - Flags: review?(gaye)
Blocks: 987356
Hi Miller,

I think we could also migrate week_view_test.js to use new view code.
So Bug 987356 could be duplicated of this bug.
How do you think?

Thanks.
Sorry for that.
I didn't see the https://bugzilla.mozilla.org/show_bug.cgi?id=987356#c1 comment.
Thanks for the fix.
Attachment #8399646 - Flags: review?(gaye) → review+
landed: https://github.com/mozilla-b2g/gaia/commit/89005c32752bd61b3213e8bf4ba4c3927648c11f

PS: I think this is the first time that I see the calendar integration tests catching a real regression. sorry for all the trouble.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [p=2] → [p=3]
You need to log in before you can comment on or make changes to this bug.