[Sora][Wi-Fi]It's a long time to open wifi again after close wifi

RESOLVED WONTFIX

Status

defect
P1
normal
RESOLVED WONTFIX
6 years ago
2 years ago

People

(Reporter: sync-1, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created an attachment (id=684088)
 19:13:18 disable wifi begin, 19:13:28 disable wifi end, takes 10s
 
 Mozilla build ID: 20140312164001
 DEFECT DESCRIPTION:
  It's a long time to open wifi again after close wifi.
  REPRODUCING PROCEDURES:
  1.settings->Open wifi
  2.Close the wifi
  3.It need 10s to open wifi again ->ko
 Bettle Lite FF behavior: Open the Wi-Fi in two seconds,but search the AP is slowly.  The total time is similar with soul3.5 FF.
  EXPECTED BEHAVIOUR:
 The open Wi-Fi and search AP time is less 2s like samsung note2.
Attachment #8399183 - Attachment mime type: application/octet-stream → text/plain
Since most wifi disable flow send command to wpa_supplicant and wait for complete, and no other devices have reported such issue.
This is more likely a device-dependent issue, I suggest you find out the execution time of each step[1] and check the corresponding command handler in wpa_supplicant.

[1] http://dxr.mozilla.org/mozilla-central/source/dom/wifi/WifiWorker.js#949
Qcom engineer says that "unload driver" issued by wificommand.jsm does not work well. I want to know the work flow of this command. Please give us some guide.
The implementation of unload driver should be B2G/hardware/libhardware_legacy/wifi/wifi.c(might be different in Sora, I don't get the repo), it's pulled from vendor and we don't own these code.
Or you can try disable unload driver by adding "ro.moz.wifi.unloaddriver=1" to the platform property, the file path might like B2G/device/DEVICE_PATH/full_DEVICENAME.mk
According to comment 4, it is a vendor's bug.
Component: Wifi → Vendcom
(In reply to Wang Rong from comment #3)
> Qcom engineer says that "unload driver" issued by wificommand.jsm does not
> work well. I want to know the work flow of this command. Please give us some
> guide.

Hi Wang Rong -

If Qualcomm engineer mentioned that this issue is about unload driver, then you probably need to ask your driver/BSP team to check this problem, or, follow Chuck's advice to disable the unload driver mechanism to see if the performance improves.


Thanks

Vance
the performance doesn't improve by disabling unload driver.
It looks like supplicant stop cost 10 sec but not wifi driver:
01-01 07:55:55.369 I/Gecko   (  304): -*- WifiWorker component: ++wifiCommand.terminateSupplicant
01-01 07:55:55.579 I/Gecko   (  304): -*- WifiWorker component: Event coming in: CTRL-EVENT-TERMINATING 
01-01 07:56:05.499 I/Gecko   (  304): -*- WifiWorker component: ++ wifiCommand.stopSupplicant
01-01 07:56:05.609 D/DHCP    (  304): failed to set prefixLength 0: Cannot assign requested address
01-01 07:56:05.609 I/Gecko   (  304): -*- WifiWorker component: ++ wifiCommand.closeSupplicantConnection
01-01 07:56:05.689 I/Gecko   (  304): -*- WifiWorker component: ++ netUtil.disableInterface
01-01 07:56:05.689 I/Gecko   (  304): -*- WifiWorker component: ++unloadDriver

wpa_supplicant report termination but for unknown reason ,stopSupplicant is called after 10 seconds.
We need to find out what cost 10 seconds. You may help us about this.
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.