Closed Bug 990158 Opened 6 years ago Closed 6 years ago

Make inner windows use their wrapper cache

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla31

People

(Reporter: peterv, Assigned: peterv)

References

Details

Attachments

(1 file, 1 obsolete file)

Attached patch v1 (obsolete) — Splinter Review
No description provided.
Blocks: 789261
Attached patch v1.1Splinter Review
Attachment #8399572 - Attachment is obsolete: true
Attachment #8402817 - Flags: review?(bzbarsky)
Comment on attachment 8402817 [details] [diff] [review]
v1.1

>@@ -2335,66 +2320,65 @@ nsGlobalWindow::SetNewDocument(nsIDocume
>     if (aState) {
>-      mInnerWindowHolder = wsh->GetInnerWindowHolder();

Why is that line being removed?

The rest looks fine, though the crash-on-touch bits seem like dead code?  Maybe a followup to nix it?

r=me with the above removal fixed or explained.
Attachment #8402817 - Flags: review?(bzbarsky) → review+
(In reply to Boris Zbarsky [:bz] from comment #2)
> >-      mInnerWindowHolder = wsh->GetInnerWindowHolder();
> 
> Why is that line being removed?

Yeah, looks iffy. It didn't seem to cause problems but I've moved it into the patch that actually removes mInnerWindowHolder.

https://hg.mozilla.org/integration/mozilla-inbound/rev/f1e4f0f82a9a
https://hg.mozilla.org/mozilla-central/rev/f1e4f0f82a9a
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla31
Duplicate of this bug: 862145
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.