Closed Bug 990364 Opened 8 years ago Closed 8 years ago

Share options have dramatically shrunk

Categories

(Firefox for Android Graveyard :: General, defect)

31 Branch
All
Android
defect
Not set
normal

Tracking

(firefox30 verified, firefox31 verified, fennec30+)

VERIFIED FIXED
Firefox 31
Tracking Status
firefox30 --- verified
firefox31 --- verified
fennec 30+ ---

People

(Reporter: rnewman, Assigned: wesj)

References

Details

(Keywords: regression, reproducible)

Attachments

(2 files)

A whole bunch of my usual share destinations have gone missing in recent Nightly. I no longer have Pocket, Twitter, Facebook… 

It looks like we take the first 11 results and stop.

Relaunching Nightly didn't help. 

Sharing from other apps shows my full list, so this only affects Firefox.
Don't see this; I have a full listing (Nexus 5, 4.4.2). I cross checked 03/31 and 04/01.
See this. The list gets chopped on access to context-menu quickshare.
Blocks: 942270
Keywords: reproducible
New profile

* Launch Firefox
* Tap Marketplace
* Long tap on any link, tap share link
* See missing items

Open the Share menu, see same missing items
tracking-fennec: --- → ?
Attached patch PatchSplinter Review
This moves all of our share handlers to text/plain and uses the DEFAULT history file for all text/* handlers.
Attachment #8400866 - Flags: review?(mark.finkle)
Comment on attachment 8400866 [details] [diff] [review]
Patch

r+ with the assumption that you saw this fix the issue. If this is a good guess, I'd like to get an APK for Aaron (or somebody) to see if it fixes the issue.
Attachment #8400866 - Flags: review?(mark.finkle) → review+
tracking-fennec: ? → 30+
Assignee: nobody → wjohnston
Duplicate of this bug: 989532
https://hg.mozilla.org/mozilla-central/rev/47cfc15df7e9
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 31
Comment on attachment 8400866 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): New feature. Needed if we want to uplift 942270.
User impact if declined: No quickshare in context menus
Testing completed (on m-c, etc.): This has been on central for a few weeks. I think it (along with its fixed dependencies) are enough to move it forward.
Risk to taking this patch (and alternatives if risky): This is medium risk. Alternatives are to hold this back a release, but we've really wanted this in 30.
String or IDL/UUID changes made by this patch: None. I landed the strings in 30.
Attachment #8400866 - Flags: approval-mozilla-aurora?
Verified as fixed on Nightly 31.0a1(2104-04-14)
Attachment #8400866 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified as fixed on Aurora 30.0a2 (2014-04-17)
Based on comment 10&12 I will mark this bug as verified fixed.
Status: RESOLVED → VERIFIED
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.