Closed Bug 990395 Opened 7 years ago Closed 7 years ago

After installing Link Bubble, all web pages get a HelperApp icon

Categories

(Firefox for Android :: General, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 31
Tracking Status
firefox29 + verified
firefox30 --- verified
firefox31 --- verified

People

(Reporter: mfinkle, Assigned: wesj)

References

Details

Attachments

(1 file)

STR:
1. Install Link Bubble from the Play Store (the free version is enough).
2. Visit any webpage in Fennec
3. Note the "android robot" in the URLBar, meaning a HelperApp is available.

We should not show a HelperApp for common webpages.
What is Link Bubble and which helper app is associated here?
Hmm... Link Bubble must not register for the http scheme, but it does show up if I query for a uri like:

http://abc

It does not show up for:

http://www.example.com/index.html

That's because we extract a mimetype from the url with a file extension. LinkBubble doesn't like text/html apparently.

I think I'm going to remove our "http" handlers set and instead filter on apps that support

1.) "http://www.example.com"
2.) "http://www.example.com/index.html"

That should give us all the apps that support browsing with or without the text/html mimetype.
Attached patch PatchSplinter Review
This removes the httpHandlers and replaces it with a check for apps that will open a generic url. Sadly, I can't find any good overlap between the two different sets of handlers. Even if I could though, we want things like the Video player to be hidden on html pages and show on video pages, so we need to keep both lists separate for that anyway.
Attachment #8402948 - Flags: review?(mark.finkle)
Comment on attachment 8402948 [details] [diff] [review]
Patch

r+, but remove the Services.console.logStringMessage logging please
Attachment #8402948 - Flags: review?(mark.finkle) → review+
Comment on attachment 8402948 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): HelperApp
User impact if declined: Helper icon shows up all the time
Testing completed (on m-c, etc.): Landed on mc today. Only tested locally.
Risk to taking this patch (and alternatives if risky): This is medium risk. Trying to do this dance with "who is a browser?" on the system has proven to be a bit hard. Different apps identify themselves different ways. I don't have any good alternatives, but we could take this one without removing some of the old code to reduce the possibility of regressions.
String or IDL/UUID changes made by this patch: none.
Attachment #8402948 - Flags: approval-mozilla-beta?
Attachment #8402948 - Flags: approval-mozilla-aurora?
> Testing completed (on m-c, etc.): Landed on mc today.
Are you sure? I don't see it.
https://hg.mozilla.org/mozilla-central/rev/7c1123fda046
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 31
Comment on attachment 8402948 [details] [diff] [review]
Patch

Hmm, it doesn't seem to be a critical issue. If you don't mind, I will skip that for beta and approve for aurora...
Attachment #8402948 - Flags: approval-mozilla-beta?
Attachment #8402948 - Flags: approval-mozilla-beta-
Attachment #8402948 - Flags: approval-mozilla-aurora?
Attachment #8402948 - Flags: approval-mozilla-aurora+
(In reply to Sylvestre Ledru [:sylvestre] from comment #10)
> Comment on attachment 8402948 [details] [diff] [review]
> Patch
> 
> Hmm, it doesn't seem to be a critical issue. If you don't mind, I will skip
> that for beta and approve for aurora...

It's somewhat critical if a user has an app link Link Bubble installed. The "open in app" icon appears for every web page, which is something we do not want to happen. I'd like to make sure the patch in this bug does not make some other regression, but then re-request uplift to beta.
Comment on attachment 8402948 [details] [diff] [review]
Patch

OK! Let's try it then. We will always be able to backout it in beta10.
Attachment #8402948 - Flags: approval-mozilla-beta- → approval-mozilla-beta+
This is going to need rebasing for the beta uplift.
Flags: needinfo?(wjohnston)
Updated and pushed:
https://hg.mozilla.org/releases/mozilla-beta/rev/2ab3be04316a
Flags: needinfo?(wjohnston)
Device: Galaxy Nexus
Android 4.3 (In reply to Mark Finkle (:mfinkle) from comment #0)

using > STR:
> 1. Install Link Bubble from the Play Store (the free version is enough).
> 2. Visit any webpage in Fennec
> 3. Note the "android robot" in the URLBar, meaning a HelperApp is available.

I am not able to see this on latest nightly (04/16), latest aurora (04/16) and latest beta (29.0b8 04/15)
Setting the bug to Verified Fixed.
Depends on: 997237
Removing verifyme flag due to comment 16.
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.