throbber is not responsive, stalls

RESOLVED DUPLICATE of bug 308158

Status

()

--
major
RESOLVED DUPLICATE of bug 308158
17 years ago
5 years ago

People

(Reporter: Marko.Macek, Assigned: Marko.Macek)

Tracking

({perf})

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

17 years ago
Mozilla throbber is unable to reliably animate 32x32 image at 10 FPS.

On hardware where games can easily run 3D 800x600 x 50fps this is 100% pathetic.

100ms is also an acceptable maximum UI response time.
(Assignee)

Comment 1

17 years ago
This can be a meta bug for all issues related to user interface latency.
Depends on: 15122
Keywords: nsCatFood, perf
(Assignee)

Updated

17 years ago
Depends on: 49141, 66907, 77051
(Assignee)

Updated

17 years ago
Depends on: 55112, 84920
(Assignee)

Updated

17 years ago
Depends on: 30942
(Assignee)

Updated

17 years ago
Depends on: 28639, 70670

Comment 2

17 years ago
*** Bug 99054 has been marked as a duplicate of this bug. ***

Comment 3

17 years ago
Marko, I think, you should morph this bug.

This is an architecural problem: Most of the Mozilla code, incl. the UI, runs in
one thread. If any function needs more time, the UI is frozen. (I don't know,
why this has been coded that way.)

Some of the bugs you marked as blockers are functions that happen to take longer
than a second. But that is just a coincidence - if these bugs are fixed, others
will probably come up. The underlying problem is the lacking threading.

Also, the throbber is spinning smoothly is just one symptom. At the same time,
*all* of the UI is frozen.

I think, this should be a bug to decouple the UI from the rest of the code. This
is a major architectural rework, so don't expect it to get fixed before 1.0.
Ben, that's already filed, I believe
(Assignee)

Comment 5

17 years ago
Ben, using threads to do CPU consuming jobs is good. But some things just can't
be
done that way. Since layout drives the entire GUI it can't be just put into a
separate thread 
(using thread per toplevel window might be doable -- using fork to start a new
window keeps coming back to my mind ;).

Bug 66907 and but 77051 are like these. Not much sense in using a separate
thread for them.

Comment 6

17 years ago
No offense intended, but this seems more like your bug, and frankly, my 
name is on too many meta bugs, which generate more notifications than I 
can deal with at times.
Assignee: hyatt → Marko.Macek
QA Contact: jrgm → nobody

Comment 7

17 years ago
A unresponsive UI is very annoying for users. Any news on that (threading) ?
QA Contact: nobody → xptoolkit.widgets

Comment 8

8 years ago
is this really thought to still be a problem, given the changes made to throbber animation in recent releases (was it v3.6?  I forget which)

Updated

8 years ago
Whiteboard: [closeme 2011-04-15]

Comment 9

8 years ago
wsmwk, FF 4.0 is worse than ever in the last 5-10 years. Probably because of JS engine garbage collection or something like that.
That said, I don't think this bug is the right vehicle, as the throbber is just one symptom.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Whiteboard: [closeme 2011-04-15]
Duplicate of bug: 308158

Updated

8 years ago
No longer depends on: 15122, 30942, 49141, 28639, 55112, 66907, 70670, 77051, 84920
You need to log in before you can comment on or make changes to this bug.