gettyone.com - [DHTML] Dynamic Menus rendering broken

RESOLVED DUPLICATE of bug 212874

Status

RESOLVED DUPLICATE of bug 212874
17 years ago
3 years ago

People

(Reporter: markushuebner, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

17 years ago
Viewing www.gettyone.com the dynamic menus are broken.
Also the page-rendering is different between ns6.1 and the latest build.

using build 2001091003
(Reporter)

Updated

17 years ago
Keywords: dom0, dom1, mozilla0.9.5, qawanted
Summary: Dynamic Menus rendering broken → [DHTML] Dynamic Menus rendering broken

Comment 1

17 years ago
Seeing this on the 2001091003-0.9.4 build.
The site has:

<body onload="centerGlobalNav()">

as part of it's onload event.  This does:

function centerGlobalNav()
{
			centerLayers();
}

Which does:

function centerLayers() {

	var doc = document.layers;


and then uses doc.

Basically, the site is giving us NS4 JS.  Over to evangelism.  See also bug 79243
Assignee: attinasi → bclary
Component: Layout → US English
Depends on: 79243
Product: Browser → Tech Evangelism
QA Contact: petersen → zach
Version: other → unspecified
(Reporter)

Comment 3

17 years ago
why is the site having at http://www.gettyone.com/source/include/globalnav.js

function centerNS6() {
	var leftPos = getLeftPos();
	var globalNav = document.getElementById("globalNav");
	globalNav.style.left = leftPos;
	globalNav.style.visibility = "visible";
}

and there is browser detection also included?

Updated

17 years ago
Keywords: dom0, dom1, mozilla0.9.5, qawanted
Summary: [DHTML] Dynamic Menus rendering broken → gettyone.com - [DHTML] Dynamic Menus rendering broken

Updated

17 years ago
Blocks: 113492

Comment 4

17 years ago
ecomm
Assignee: bclary → aruner
Component: US General → US Ecommerce
QA Contact: zach → bclary

Updated

17 years ago
No longer blocks: 113492

Comment 5

16 years ago
Please *Assign*. No dyamic menus. Also, page is way off from top. Using
Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.1a) Gecko/20020608 (SeaMonkey
Mozilla.1.1 Alpha)

Comment 6

16 years ago
It is possible to use uabar to change your useragent string and fool the site to
display properly.  This is a handy extension for several websites out there.  Go
to the Mozilla projects page to find uabar.

Comment 7

15 years ago
tech evang june 2003 reorg
Assignee: aruner → english-us
Component: US Ecommerce → English US
QA Contact: bc → english-us

Comment 8

15 years ago

*** This bug has been marked as a duplicate of 212874 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.