Closed Bug 990802 Opened 6 years ago Closed 6 years ago

[B2G][Homescreen] Cancelling sharing link via email turns Homescreen wallpaper to a blank white screen

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.4+, b2g-v1.3 unaffected, b2g-v1.4 fixed, b2g-v2.0 unaffected)

RESOLVED FIXED
1.4 S5 (11apr)
blocking-b2g 1.4+
Tracking Status
b2g-v1.3 --- unaffected
b2g-v1.4 --- fixed
b2g-v2.0 --- unaffected

People

(Reporter: pcheng, Assigned: alive)

References

Details

(Keywords: regression)

Attachments

(3 files)

Attached image browser_wallpaper.png
Homescreen wallpaper changes to a blank browser page after attempting to share/email a google maps link, cancel out, and return to homescreen.

Repro Steps:
1) Update a Buri to BuildID: 20140401000202
2) Open Firefox browser and access any webpage (google.com)
3) Tap on the share icon
4) Tap 'Cancel' to close email set up
* If you have email already set up, then cancel sending the message.
5) Once returned back to browser, tap on Home button to return to homescreen

Actual:
Wallpaper changed to a blank browser page. Killing the browser process restores the wallpaper.

Expected:
Home screen appears correctly with the correct wallpaper

v1.4 Environmental Variables:
Device: Buri v1.4 MOZ
BuildID: 20140401000202
Gaia: 216cc2e5c8692ba71aa78a9f27e84e9da27952b8
Gecko: 9223243c65a2
Version: 30.0a2
Firmware Version: v1.2-device.cfg

Notes:
Repro frequency: 5/5, 100%
See attached: screenshot and logcat
This issue does NOT occur on 1.3 

Environmental Variables:
Device: Buri v1.3 MOZ
BuildID: 20140401004003
Gaia: 24f562fce468fc948ac9e6185e002c23350cb9ee
Gecko: 0adf24a785f2
Version: 28.0
Firmware Version: v1.2-device.cfg
blocking-b2g: --- → 1.4?
Duplicate of this bug: 989570
See Also: → 989570
Very likely a window management bug.

Alive, could you take a look?
Component: Gaia::Homescreen → Gaia::System::Window Mgmt
Flags: needinfo?(alive)
Assignee: nobody → alive
Flags: needinfo?(alive)
blocking-b2g: 1.4? → 1.4+
Whiteboard: [systemsfe]
Target Milestone: --- → 1.4 S5 (11apr)
Cut and dry blocker
This isn't a systemsfe issue.
Whiteboard: [systemsfe]
QA Contact: pcheng
The following regression window was found using tinderbox builds.

Last Working Environmental Variables:
Device: Buri 1.4 (Aurora)
BuildID: 20140331155732
Gaia: 55e9c12be944af0a0c51fab89f09501a4918ec24
Gecko: e807224656d8
Version: 30.0a2
Firmware Version: v1.2-device.cfg

First Broken Environmental Variables:
Device: Buri 1.4 (Aurora)
BuildID: 20140331162232
Gaia: 216cc2e5c8692ba71aa78a9f27e84e9da27952b8
Gecko: 883979177a51
Version: 30.0a2
Firmware Version: v1.2-device.cfg

Last Working Gaia / First Broken Gecko: Issue Does NOT reproduce
Gaia: 55e9c12be944af0a0c51fab89f09501a4918ec24
Gecko: 883979177a51

Last Working Gecko / First Broken Gaia: Issue DOES reproduce
Gaia: 216cc2e5c8692ba71aa78a9f27e84e9da27952b8
Gecko: e807224656d8

Gaia Pushlog:
https://github.com/mozilla-b2g/gaia/compare/55e9c12be944af0a0c51fab89f09501a4918ec24...216cc2e5c8692ba71aa78a9f27e84e9da27952b8
bug 970028 caused this.
Blocks: 970028
Duplicate of this bug: 991943
Duplicate of this bug: 993532
Interesting, v1.5 I cannot repro.
Attached file patch for 1.4
The root cause is the class is not removed correctly.
Attachment #8403744 - Flags: review?(timdream)
Comment on attachment 8403744 [details] [review]
patch for 1.4

It might be worthy to investigate what happened between the branches.
Attachment #8403744 - Flags: review?(timdream) → review+
(In reply to Tim Guan-tin Chien [:timdream] (MoCo-TPE) (please ni?) from comment #12)
> Comment on attachment 8403744 [details] [review]
> patch for 1.4
> 
> It might be worthy to investigate what happened between the branches.

cherry-pick & merge issue from bubble-tea.
https://github.com/mozilla-b2g/gaia/commit/2aedbb9d66b4f9473da1ce561d05a74757a4bfa1
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.