autocomplete popups consume clicks on the text field (breaks Go button in Firefox)

RESOLVED DUPLICATE of bug 1089005

Status

()

--
major
RESOLVED DUPLICATE of bug 1089005
5 years ago
5 days ago

People

(Reporter: karlt, Unassigned)

Tracking

({regression})

28 Branch
regression
Points:
13
Dependency tree / graph
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(firefox28 affected)

Details

(Whiteboard: [Australis:P-])

Attachments

(1 attachment)

1. Enter https://bugzilla.mozilla.org into the location bar.

Auto-complete drop down opens.

2. Click the "Go to the address in the location bar" icon.

Expected: drop down closes and page loads.

Actual: drop down closes and page does not load.

This makes it very confusing trying to select or paste text with the mouse
in the location bar.

The search bar behaves similarly wrt select and paste, but distinctly the
"Search" button is effective on click.
Created attachment 8400340 [details] [diff] [review]
partial revert of 07ea7b11adef

Used to identify http://hg.mozilla.org/integration/mozilla-inbound/rev/07ea7b11adef as the regressing changeset.
(Reporter)

Updated

5 years ago
Version: Trunk → 28 Branch
This is because the Go button is part of the textbox and the textbox is considered the popup's "anchor", causing consumeoutsideclicks="false" to be ignored there.
Component: XUL Widgets → XP Toolkit/Widgets: Menus
OS: Linux → All
Product: Toolkit → Core
Hardware: x86_64 → All
Summary: autocomplete dropdowns consume clicks → autocomplete popups consume clicks on the text field (breaks Go button in Firefox)
status-firefox28: --- → affected
Whiteboard: [Australis:P-]
Blocks: 981530
We've removed the triage tracker (Bug 981530).  To nominate bugs for the triage team to review you can set the firefox-backlog flag to '?'
No longer blocks: 981530
Flags: firefox-backlog?
Flags: firefox-backlog? → firefox-backlog+
Whiteboard: [Australis:P-] → [Australis:P-] p=13

Updated

5 years ago
Duplicate of this bug: 1012143
As you can see in file bug 1012143 : 

 - This bug also prevents the cursor from moving to where the user has clicked. 
 - This bug also occurs in the text field of a form, when there are one or several auto-complete suggestion(s).
Duplicate of this bug: 1023612
Points: --- → 13
Whiteboard: [Australis:P-] p=13 → [Australis:P-]
(Reporter)

Updated

4 years ago
Blocks: 1089005

Comment 7

6 months ago
This should be marked a duplicate of bug 1089005.

The fix in that bug seems to have resolved this issue. The steps in comment 0 don't reproduce anymore.
Thanks!
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1089005
Component: XP Toolkit/Widgets: Menus → XUL
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.