Closed Bug 991040 Opened 6 years ago Closed 6 years ago

Uncaught async Promise errors should appear as soon as possible during mochi tests

Categories

(Testing :: Mochitest, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla31

People

(Reporter: Yoric, Assigned: Yoric)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

As bug 976205, but for mochitests
Observation: We treat all our test suites as separate "smoke stacks." We should unify the logic for declaring and advancing tests so this code can be shared and consistent. One-off problem largely solved.
Definitely. I don't think that anyone is working on that, though.
Summary: Uncaught async Promise errors should cause mochi tests to fail → Uncaught async Promise errors should cause mochi tests to warn
Duplicate of this bug: 995199
Summary: Uncaught async Promise errors should cause mochi tests to warn → Uncaught async Promise errors should appear as soon as possible during mochi tests
https://hg.mozilla.org/mozilla-central/rev/55b4ac7353fd
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla31
You need to log in before you can comment on or make changes to this bug.