Closed Bug 991046 Opened 6 years ago Closed 6 years ago

box-shadow with transparent background and opacity does not respect overflow:hidden

Categories

(Core :: Web Painting, defect)

28 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla31
Tracking Status
firefox28 --- wontfix
firefox29 + wontfix
firefox30 + verified
firefox31 + verified
firefox-esr24 --- unaffected

People

(Reporter: danmana11, Assigned: mattwoodrow)

References

()

Details

(Keywords: regression)

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/33.0.1750.154 Safari/537.36

Steps to reproduce:

When a child element has a transparent background, a box-shadow and opacity != 1 it does not respect the overflow property of its parent. 

Setting a background-color different than "transparent", or opacity=1 solves the problem.

Issue is reproducible in Firefox 28, but did not occur in 26


Actual results:

The overflowing parts of the child element are visible, even if the parent has overflow:hidden


Expected results:

The overflowing parts of the child element should not be visible
Seeing this on Mac too.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(roc)
Summary: boz-shadow with transparent background and opacity does not respect overflow hidden → box-shadow with transparent background and opacity does not respect overflow:hidden
Tracking it because it is a regression. Hopefully, we are going to get a fix for 29.
Assignee: nobody → matt.woodrow
Attachment #8403040 - Flags: review?(roc)
Flags: needinfo?(roc)
Comment on attachment 8403040 [details] [diff] [review]
Include the clip when flattening nsDisplayOpacity

Review of attachment 8403040 [details] [diff] [review]:
-----------------------------------------------------------------

But would it not be simpler to just refuse to flatten? Either way's fine.
Attachment #8403040 - Flags: review?(roc) → review+
https://hg.mozilla.org/mozilla-central/rev/3627984da60d
https://hg.mozilla.org/mozilla-central/rev/3711e30f9967
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla31
Too late for 29 but please nominate for uplift to Aurora.
Flags: needinfo?(matt.woodrow)
Comment on attachment 8403040 [details] [diff] [review]
Include the clip when flattening nsDisplayOpacity

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug 939607
User impact if declined: Incorrectly drawn content sometime
Testing completed (on m-c, etc.): Been on m-c, reftest added.
Risk to taking this patch (and alternatives if risky): Very low risk.
String or IDL/UUID changes made by this patch: None
Attachment #8403040 - Flags: approval-mozilla-aurora?
Flags: needinfo?(matt.woodrow)
Attachment #8403040 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified as fixed on Firefox 30 beta 2 (20140505140302) and latest Aurora 31.0a2 (20140505004003) under Win 7 64-bit and Mac OSX 10.7.5.
Status: RESOLVED → VERIFIED
Keywords: verifyme
QA Contact: petruta.rasa
Depends on: 1003425
Component: Layout: View Rendering → Layout: Web Painting
You need to log in before you can comment on or make changes to this bug.