Closed Bug 991304 Opened 6 years ago Closed 6 years ago

[Tarako] [B2G][First Time Experience] No FTE/FTU appears when device is reset or reflashed

Categories

(Firefox OS Graveyard :: Vendcom, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:1.3T+, b2g-v1.3T verified)

VERIFIED FIXED
blocking-b2g 1.3T+
Tracking Status
b2g-v1.3T --- verified

People

(Reporter: bzumwalt, Assigned: dliang)

References

Details

(Keywords: smoketest, Whiteboard: [systemsfe], 1.3tarakorun2, vendcom)

Attachments

(2 files)

Description:
The First Time Experience app does not launch on Tarako when device is reset or reflashed.

Repro Steps:
1) Update a Tarako to BuildID: 20140402094402
2) Launch Settings app
3) Navigate to Device Information>More Information
4) Select "Reset Phone" and confirm

Actual:
No First Time Experience can be seen when resetting or reflashing device.

Expected:
FTE/FTU launches on device reset or reflash.

1.3t Environmental Variables:
Device: Tarako 1.3t MOZ
BuildID: 20140402094402
Gaia: 578fdccea89a88b417d296f8cf20b39099d44be4
Gecko: 34ed4cbc5a59
Version: 28.1
Firmware Version: sp8810

Notes:
Repro frequency: 3/3, 100%
See attached: logcat
Ni on reporter for the logcat. Is this a regression, if so get can get the regressing bug here ?or has this never worked on Tarako ?

Lucas A, reaching out to you as an FTE owner, any ideas here ? or can you please help pass this onto appropriate folks who may be able to help here?
Flags: needinfo?(ladamski)
Flags: needinfo?(bzumwalt)
(In reply to bhavana bajaj [:bajaj] from comment #1)
> Ni on reporter for the logcat. Is this a regression, if so get can get the
> regressing bug here ?or has this never worked on Tarako ?

We aren't going be able to determine if it's a regression - we only have a couple of tarako builds available for daily testing right now.
Leaving qawanted to get a logcat.
Keywords: qawanted
Why is this a smoketest blocker and do we not know if this is a regression? Did this pass before?
Flags: needinfo?(ladamski)
Whiteboard: [systemsfe]
blocking-b2g: 1.3T? → 1.3T+
(In reply to Gregor Wagner [:gwagner] from comment #4)
> Why is this a smoketest blocker and do we not know if this is a regression?
> Did this pass before?

It's a smoketest blocker because daily testing needs factory reset working correctly to diagnose bugs with minimal STR involved (i.e. being able to test to reproduce something from a clean state).

We probably won't be able to easily determine if it's a regression - we just got tarako builds on pvtbuilds, so we only have a couple of old builds available for regression ranges.
Attached file FTU_Logcat
Logcat attached
Flags: needinfo?(bzumwalt)
Keywords: qawanted
:gwagner looks like we've got the logcat here can you please take a look ?
Flags: needinfo?(anygregor)
Flags: needinfo?(anygregor)
Alex will take a look.
Assignee: nobody → lissyx+mozillians
Flashed a tarako with build from march 25th. Recovery on this one is fixed ; and I get working reset feature. So it would be a regression between those two builds.
Whiteboard: [systemsfe] → [systemsfe], 1.3tarakorun2
Okay, with the specified buildid, I do get the behavior exposed there. However, I'm doubtful about the tarako images I grabbed from pvtbuilds: they don't include the expected full subset of langages we used to have. Hence I'm wondering how those are built.
ni? Catlee on comment 10
Flags: needinfo?(catlee)
tarako has no FTU, because partner disables it.
device/sprd/sp6821a_gonk/prod_sp6821a.mk:
80: export NOFTU=1
Hi James, can we fix it on your side? thanks
Flags: needinfo?(catlee) → needinfo?(james.zhang)
(In reply to Joe Cheng [:jcheng] from comment #13)
> Hi James, can we fix it on your side? thanks

I have disable it for monkey test. I think we can open it for user.
Assignee: lissyx+mozillians → james.zhang
Flags: needinfo?(james.zhang)
fixed on my side.


commit 37c9fc7e80bf7956e13eeccd3faaf64bec14df52
Author: james.zhang <james.zhang@spreadtrum.com>
Date:   Wed Apr 9 12:58:50 2014 +0800

    Bug#269156 add FTU for user build
    
    [bug number  ]
    [root cause  ]
    [changes     ]
    [side effects]
    [self test   ] yes
    [reviewers   ]
    
    Change-Id: Ief2640bb939056551c47ea1e94a8f61b070e2be2

diff --git a/sp6821a_gonk/prod_sp6821a.mk b/sp6821a_gonk/prod_sp6821a.mk
index e818527..9064fa0 100644
--- a/sp6821a_gonk/prod_sp6821a.mk
+++ b/sp6821a_gonk/prod_sp6821a.mk
@@ -77,7 +77,11 @@ export GAIA_DISTRIBUTION_DIR=$(PWD)/device/sprd/sp6821a_gonk/
 export GAIA_APP_SRCDIRS=apps external-apps outoftree_apps customize_apps/engmode/assets customize_apps/ValidationTools/assets
 export PRODUCTION=1
 export MOZILLA_OFFICIAL=1
+
+ifneq ( $(TARGET_BUILD_VARIANT),user)
 export NOFTU=1
+endif
+
 export LOCALE_BASEDIR=$(PWD)/gaia-l10n/
 export LOCALES_FILE=$(PWD)/device/sprd/sp6821a_gonk/languages.json
 export GAIA_DEFAULT_LOCALE=en-US
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Still not seeing FTE in today's pvtbuilds, will retest tomorrow (the gaia in today's build is the same as in 04/08 build)

Tarako 1.3t
BuildID: 20140409004001
Gaia: 643f3e6676cbb89c62708a9f7cbef2edc795a552
Gecko: e757fdd55426
Version: 28.1
Base image: sp8810
We need clarification here. Based of comment 14 and comment 15 we now should have FTE in users build, and we still don't see it. 

I'm reopening this bug, please correct me if I'm mistaken. 

*Tarako pvtbuild
BuildID: 20140410004001
Gaia: 022b03a57e4b8c697a6066961e7581d07eb99305
Gecko: b9dba13d50a9
Version: 28.1

*base image: sp6821a
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
James, are you sure of this fix? The builds I get from pvtbuilds do not have any ftu.manifestURL value being set in /system/b2g/defaults/settings.json, thus FTU cannot run.

I suspect the make condition does not cover all cases, i.e. |ifneq ( $(TARGET_BUILD_VARIANT),user)| is not working, because it should be tested also against userdebug: the tarako.zip I'm flashing from has adb starting as a normal user, but allows to adb root, like any userdebug build.

A better fix would be: |ifneq ($(filter user userdebug, $(TARGET_BUILD_VARIANT)),)|
Flags: needinfo?(james.zhang)
FTY, doing a reset-gaia from uptodate v1.3t gaia:
 - with NOFTU=0, I get FTU
 - with NOFTU=1, I do not get FTU.

Everythings points to partner issue on this.
Component: Gaia::First Time Experience → Vendcom
Whiteboard: [systemsfe], 1.3tarakorun2 → [systemsfe], 1.3tarakorun2, vendcom
(In reply to Alexandre LISSY :gerard-majax from comment #19)
> FTY, doing a reset-gaia from uptodate v1.3t gaia:
>  - with NOFTU=0, I get FTU
>  - with NOFTU=1, I do not get FTU.
> 
> Everythings points to partner issue on this.

My mistake.
Flags: needinfo?(james.zhang)
We need use userdebug build to run monkey test, so I only enable FTU on user build.
(In reply to Alexandre LISSY :gerard-majax from comment #19)
> FTY, doing a reset-gaia from uptodate v1.3t gaia:
>  - with NOFTU=0, I get FTU
>  - with NOFTU=1, I do not get FTU.
> 
> Everythings points to partner issue on this.

Please check tomorrow user build, I have fixed this issue on my side.
It's my mistake, I found NOFTU default value is 1 in gaia make file. I have set it to 0 on user build.
Whiteboard: [systemsfe], 1.3tarakorun2, vendcom → [systemsfe], 1.3tarakorun2, vendcom, [POVB]
fixed on my side.
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
(In reply to James Zhang from comment #23)
> fixed on my side.

I still don't see the ftu.manifestURL being set in our gaia's settings.json, on build from today:

> alex@portable-alex:~/codaz/Mozilla/b2g/pvtbuilds/gaia/profile$ json_pp < settings.json | egrep 'ftu\.'
>    "keyboard.ftu.enabled" : false,
> alex@portable-alex:~/codaz/Mozilla/b2g/pvtbuilds/gaia/profile$

Can we ensure it's correctly applied on our side?

The commit id for the "device/sprd" project I see is 1241f56ff614a15e9c24dd402a4860912d4d9345. 

James, can you confirm whether the fix is expected to be there ? And can you cross check the settins.json on your builds ? Thanks!
Flags: needinfo?(james.zhang)
Please use this commit.

commit 894f36f779dee6d61fc72404cf561e007edb2634
Author: james.zhang <james.zhang@spreadtrum.com>
Date:   Mon Apr 14 22:32:32 2014 +0800

    Bug#269156 mozilla bug#991304 add FTU for user build
    
    [bug number  ]
    [root cause  ]
    [changes     ]
    [side effects]
    [self test   ] yes
    [reviewers   ]
    
    Change-Id: I59567237b1645524ee7d21936c8955c085d19c3d
Flags: needinfo?(james.zhang)
Still doesn't work. Can we please actually test this & make sure it works before we close the bug again?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
ni? James
Flags: needinfo?(james.zhang)
ni danny, you can check my hudson user build FTU on my seat.
I think I have fixed it on user build only.
Flags: needinfo?(james.zhang) → needinfo?(dliang)
Hi Naoki, do you know what is the build command for PVT user build? By the setting from sprd, the FTU should work on user build, but the result is negative.
Flags: needinfo?(nhirata.bugzilla)
(In reply to Danny Liang [:dliang] from comment #29)
> Hi Naoki, do you know what is the build command for PVT user build? By the
> setting from sprd, the FTU should work on user build, but the result is
> negative.

Danny has checked our user build on my seat.
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
I believe that keyboard FTU is different from the FTU itself.  Keyboard FTU will appear the first time you click into a field.

The patch should be in today's build.
https://tbpl.mozilla.org/php/getParsedLog.php?id=37938532&tree=Mozilla-B2g28-v1.3t&full=1 
shows : 09:30:56     INFO -  HEAD is now at 894f36f Bug#269156 mozilla bug#991304 add FTU for user build
so this should have the patch

The build config 

09:33:40     INFO - Running command: ['mock_mozilla', '-r', u'mozilla-centos6-i386', '-q', '--cwd', '/builds/slave/b2g_m-b28_v1_3t_tko_ntly-00000/build', '--unpriv', '--shell', u'/usr/bin/env VARIANT=user GAIA_OPTIMIZE=1 "LESSOPEN=|/usr/bin/lesspipe.sh %s" TMOUT=86400 CVS_RSH=ssh LOGNAME=cltbld USER=cltbld PATH=/tools/python27/bin:/usr/local/bin:/usr/lib64/ccache:/usr/local/bin:/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/cltbld/bin:/builds/slave/b2g_m-b28_v1_3t_tko_ntly-00000/build/compare-locales/scripts SYMBOL_SERVER_USER=b2gbld "WGET_OPTS=-c -q" CCACHE_UMASK=002 LANG=en_US.UTF-8 CCACHE_HASHDIR= TERM=linux SHELL=/bin/bash MOZ_BUILD_DATE=20140416004007 SHLVL=1 G_BROKEN_FILENAMES=1 HISTSIZE=1000 SYMBOL_SERVER_PATH=/mnt/netapp/breakpad/symbols_b2g/ LOCALES_FILE=/builds/slave/b2g_m-b28_v1_3t_tko_ntly-00000/build/gaia/locales/languages_dev.json SYMBOL_SERVER_HOST=symbolpush.mozilla.org PYTHONPATH=:/builds/slave/b2g_m-b28_v1_3t_tko_ntly-00000/build/compare-locales/lib L10NBASEDIR=/builds/slave/b2g_m-b28_v1_3t_tko_ntly-00000/build/gecko-l10n MOZILLA_OFFICIAL=1 "MOZ_CHROME_MULTILOCALE=es-ES pl pt-BR" CCACHE_DIR=/builds/ccache CCACHE_COMPRESS=1 _=/tools/buildbot/bin/python CCACHE_BASEDIR=/builds/slave/b2g_m-b28_v1_3t_tko_ntly-00000/build JS_BINARY=/builds/slave/b2g_m-b28_v1_3t_tko_ntly-00000/build/js HOSTNAME=bld-linux64-spot-104.build.releng.use1.mozilla.com SYMBOL_SERVER_SSH_KEY=/home/mock_mozilla/.ssh/b2gbld_dsa LOCALE_BASEDIR=/builds/slave/b2g_m-b28_v1_3t_tko_ntly-00000/build/gaia-l10n HISTCONTROL=ignoredups POST_SYMBOL_UPLOAD_CMD=/usr/local/bin/post-symbol-upload.py PWD=/builds/slave/b2g_m-b28_v1_3t_tko_ntly-00000 PROPERTIES_FILE=/builds/slave/b2g_m-b28_v1_3t_tko_ntly-00000/buildprops.json MAIL=/var/spool/mail/cltbld B2G_UPDATER=1 B2G_UPDATE_CHANNEL=tarako/1.3.0t/nightly ccache -z'] in /builds/slave/b2g_m-b28_v1_3t_tko_ntly-00000/build
09:33:40     INFO - Copy/paste: mock_mozilla -r mozilla-centos6-i386 -q --cwd /builds/slave/b2g_m-b28_v1_3t_tko_ntly-00000/build --unpriv --shell "/usr/bin/env VARIANT=user GAIA_OPTIMIZE=1 \"LESSOPEN=|/usr/bin/lesspipe.sh %s\" TMOUT=86400 CVS_RSH=ssh LOGNAME=cltbld USER=cltbld PATH=/tools/python27/bin:/usr/local/bin:/usr/lib64/ccache:/usr/local/bin:/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/cltbld/bin:/builds/slave/b2g_m-b28_v1_3t_tko_ntly-00000/build/compare-locales/scripts SYMBOL_SERVER_USER=b2gbld \"WGET_OPTS=-c -q\" CCACHE_UMASK=002 LANG=en_US.UTF-8 CCACHE_HASHDIR= TERM=linux SHELL=/bin/bash MOZ_BUILD_DATE=20140416004007 SHLVL=1 G_BROKEN_FILENAMES=1 HISTSIZE=1000 SYMBOL_SERVER_PATH=/mnt/netapp/breakpad/symbols_b2g/ LOCALES_FILE=/builds/slave/b2g_m-b28_v1_3t_tko_ntly-00000/build/gaia/locales/languages_dev.json SYMBOL_SERVER_HOST=symbolpush.mozilla.org PYTHONPATH=:/builds/slave/b2g_m-b28_v1_3t_tko_ntly-00000/build/compare-locales/lib L10NBASEDIR=/builds/slave/b2g_m-b28_v1_3t_tko_ntly-00000/build/gecko-l10n MOZILLA_OFFICIAL=1 \"MOZ_CHROME_MULTILOCALE=es-ES pl pt-BR\" CCACHE_DIR=/builds/ccache CCACHE_COMPRESS=1 _=/tools/buildbot/bin/python CCACHE_BASEDIR=/builds/slave/b2g_m-b28_v1_3t_tko_ntly-00000/build JS_BINARY=/builds/slave/b2g_m-b28_v1_3t_tko_ntly-00000/build/js HOSTNAME=bld-linux64-spot-104.build.releng.use1.mozilla.com SYMBOL_SERVER_SSH_KEY=/home/mock_mozilla/.ssh/b2gbld_dsa LOCALE_BASEDIR=/builds/slave/b2g_m-b28_v1_3t_tko_ntly-00000/build/gaia-l10n HISTCONTROL=ignoredups POST_SYMBOL_UPLOAD_CMD=/usr/local/bin/post-symbol-upload.py PWD=/builds/slave/b2g_m-b28_v1_3t_tko_ntly-00000 PROPERTIES_FILE=/builds/slave/b2g_m-b28_v1_3t_tko_ntly-00000/buildprops.json MAIL=/var/spool/mail/cltbld B2G_UPDATER=1 B2G_UPDATE_CHANNEL=tarako/1.3.0t/nightly ccache -z"
Flags: needinfo?(nhirata.bugzilla)
Reopening.  There's an issue where the manifest is missing:
04-16 23:50:20.560: I/GeckoDump(84): FTU manifest cannot be found skipping.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
communication's manifest.webapp does contain the ftu:

    "ftu": {
      "fullscreen": "true", 
      "launch_path": "/ftu/index.html", 
      "name": "FTU"
    },
I'm confuse, can I remove POVB flag first?
I think is mozilla build system issue, Danny has checked my hudson build result and see FTU.
Assignee: james.zhang → dliang
Whiteboard: [systemsfe], 1.3tarakorun2, vendcom, [POVB] → [systemsfe], 1.3tarakorun2, vendcom
There is FTU on my local user build, please must have the clean build to avoid any pollution on build flag.

SW information:
Gaia      718a06816327fcb6a18095f677cfff4b86adc292
Gecko     05ba231087b666aa36a620d0ae6f0dcfe57a3719
BuildID   20140417151943
Version   28.1
Flags: needinfo?(dliang)
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #34)
> communication's manifest.webapp does contain the ftu:
> 
>     "ftu": {
>       "fullscreen": "true", 
>       "launch_path": "/ftu/index.html", 
>       "name": "FTU"
>     },

But the Gaia settings.json I just got from pvtbuilds non eng build does not have any ftu.manifestURL !

From https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/nightly/mozilla-b2g28_v1_3t-tarako/latest/sources.xml, <project name="device/sprd" path="device/sprd" remote="sprd-aosp" revision="67a4cb67778ff70655e7010122211d90756e1e51"/>

Can someone make sure:
 - what build exactly is performed for testing by QA
 - if the device/sprd repository is uptodate ?
James, you're right.  It's not a PVOB issue.  I think it's our build issue and I think that's what Alexandre is suggesting.

Viral, can you help us or know who can help us with determining if we have the right manifest?
https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/nightly/mozilla-b2g28_v1_3t-tarako/latest/sources.xml
Flags: needinfo?(vwang)
Never mind Viral.

bug 994985 shows that we're using userdebug instead of user for both builds.  This is most likely the cause in why there's no FTU.  We need to get a user build.
Flags: needinfo?(vwang)
Naoki, in comment 18, I gave james a patch that should make sure NOFTU is not set for user nor userdebug builds. So I'm unsure about your statement in comment 39: if we pull the correct sources with this fix, then building userdebug should expose FTU.
Flags: needinfo?(nhirata.bugzilla)
Hi Alexandre, 
Thank you for the explanation.  I'm confused because of this: http://mxr.mozilla.org/gaia/source/Android.mk#26 and http://mxr.mozilla.org/gaia/source/Makefile#128 ; I'm not sure if I am understanding things correctly.

I believe we pull our own gaia based on https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/nightly/mozilla-b2g28_v1_3t-tarako/latest/sources.xml
looking at <project name="gaia.git" path="gaia" remote="mozillaorg" revision="f0872318d46781bb59d0a13a2e1fffb115b8ca2b"/>
and <remote fetch="https://git.mozilla.org/releases" name="mozillaorg"/>

Are you suggesting that we pull everything from their repo and build from that instead?  I think we have always tested things from our gaia and gecko repos.  Maybe I am wrong...
Flags: needinfo?(nhirata.bugzilla) → needinfo?(lissyx+mozillians)
To note : Using their PAC file I did see a FTU; so it's not their build.  It's something in our build somewhere.

OH!  sorry.  I feel dumb now.  I see what I can check.  You were referring to comment 15 in 18.  Thanks.
Flags: needinfo?(lissyx+mozillians)
Flags: needinfo?(lissyx+mozillians)
By Danny's comment in https://bugzilla.mozilla.org/show_bug.cgi?id=991304#c36, what's the problem now?
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #41)
> Hi Alexandre, 
> Thank you for the explanation.  I'm confused because of this:
> http://mxr.mozilla.org/gaia/source/Android.mk#26 and
> http://mxr.mozilla.org/gaia/source/Makefile#128 ; I'm not sure if I am
> understanding things correctly.
> 
> I believe we pull our own gaia based on
> https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/nightly/mozilla-
> b2g28_v1_3t-tarako/latest/sources.xml
> looking at <project name="gaia.git" path="gaia" remote="mozillaorg"
> revision="f0872318d46781bb59d0a13a2e1fffb115b8ca2b"/>
> and <remote fetch="https://git.mozilla.org/releases" name="mozillaorg"/>
> 
> Are you suggesting that we pull everything from their repo and build from
> that instead?  I think we have always tested things from our gaia and gecko
> repos.  Maybe I am wrong...

It's just that I don't know:
 - how builds from pvtbuilds are done
 - what does QA do and use for testing

So we need to make sure that the device/sprd repository used in builds tested by QA and to produce pvtbuilds images is the one with the fixes.
Flags: needinfo?(lissyx+mozillians)
not sure if rel.eng can assist further on this bug? thanks
Flags: needinfo?(catlee)
Release Engineering's builds use the manifests in gecko to build. e.g.

https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t/file/531ba7442cde/b2g/config/tarako/sources.xml

These manifests are kept up-to-date from the original upstream manifests here:
https://github.com/mozilla-b2g/b2g-manifest/blob/v1.3t/tarako.xml

It looks like we are using a correct version of device/sprd.git, however, due to bug 994985 all our builds are 'userdebug' instead of 'user' or 'eng'. We need that bug fixed, or update prod_sp6821a.mk to also handle the 'userdebug' variant.
Flags: needinfo?(catlee)
If Tarako becomes true userbuilds, we likely won't his this issue anymore.  See: 994985 - All Tarako builds are userdebug, not user or eng
(In reply to Chris AtLee [:catlee] from comment #47)
> Release Engineering's builds use the manifests in gecko to build. e.g.
> 
> https://hg.mozilla.org/releases/mozilla-b2g28_v1_3t/file/531ba7442cde/b2g/
> config/tarako/sources.xml
> 
> These manifests are kept up-to-date from the original upstream manifests
> here:
> https://github.com/mozilla-b2g/b2g-manifest/blob/v1.3t/tarako.xml
> 
> It looks like we are using a correct version of device/sprd.git, however,
> due to bug 994985 all our builds are 'userdebug' instead of 'user' or 'eng'.
> We need that bug fixed, or update prod_sp6821a.mk to also handle the
> 'userdebug' variant.

But even userdebug build should not force NOFTU now, according to comment 23, so I'm wondering what is happening then.
Flags: needinfo?(james.zhang)
Flags: needinfo?(catlee)
We should retest this with the dependency fixed.
Keywords: qawanted
Issue does NOT occur on latest 1.3T on Tarako PVT build

1.3T Environmental Variables:
Device: Tarako 1.3T
BuildID: 20140425014003
Gaia: 293b056683b506ec1b4787d0fbf6033cc30fa953
Gecko: d91121fbca90
Version: 28.1
Firmware Version: sp6821a_gonk4.0_user.pac
Fixed via dependency.
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Keywords: qawanted
Resolution: --- → FIXED
Flags: needinfo?(james.zhang)
Following the STR from Comment 0, witnessed FTE/FTU launches on device reset using latest 1.3T build. 

Environmental Variables:
Device: Tarako 1.3T MOZ
BuildID: 20140428014001
Gaia: 8895b180ed636069473703d0e7b73086989601ce
Gecko: 7caf4b5abfce
Version: 28.1
Firmware Version: sp6821a_gonk4.0_user.pac
Flags: needinfo?(catlee)
Status: RESOLVED → VERIFIED
comment 43 explains why the userdebug does not show ftu.
Flags: needinfo?(lissyx+mozillians)
Flags: needinfo?(lissyx+mozillians)
You need to log in before you can comment on or make changes to this bug.