Closed Bug 991452 Opened 7 years ago Closed 7 years ago

[B2G][ICS][emulator] Add network interface wlan0 for wifi testing

Categories

(Firefox OS Graveyard :: Wifi, defect)

x86_64
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(tracking-b2g:backlog)

RESOLVED DUPLICATE of bug 991025
1.4 S6 (25apr)
tracking-b2g backlog

People

(Reporter: hchang, Assigned: hchang)

References

Details

(Whiteboard: [p=1])

Attachments

(1 file)

The network interface "wlan0" is required for DHCP. One simple solution might be using emulator args "-net nic -net nic -net user" to add eth1 and rename eth1 to wlan0.
Blocks: 991025
Whiteboard: [p=1]
Target Milestone: --- → 1.5 S6 (18july)
Assignee: nobody → hchang
Target Milestone: 1.5 S6 (18july) → 1.4 S6 (25apr)
Blocks: 991450
Attachment #8405161 - Flags: feedback?(vyang)
PR https://github.com/mozilla-b2g/platform_external_qemu/pull/71 will work with PR in Bug 991450 to create a interface wlan0 on ICS emulator for wifi testing.
blocking-b2g: --- → backlog
Moving to bug 991025 along with other WiFi emulation parts as an integral.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 991025
blocking-b2g: backlog → ---
You need to log in before you can comment on or make changes to this bug.