Closed Bug 991803 Opened 6 years ago Closed 6 years ago

[B2G][Tarako][Contacts]Text field does not display keyboard input after attaching image to contact from camera

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v1.3 unaffected, b2g-v1.3T affected)

RESOLVED DUPLICATE of bug 950573
Tracking Status
b2g-v1.3 --- unaffected
b2g-v1.3T --- affected

People

(Reporter: rkuhlman, Assigned: rudyl)

References

()

Details

(Whiteboard: [tarako-exploratory])

Attachments

(1 file)

Attached file Contacts Text Field
After attaching an image to a contact from the camera, the next used text field will not function properly. Typing into the keyboard will not display anything in the text field. The user will have to tap on a different text field in order to make text function, at which point the original text field will work properly again.

Repro Steps:
1) Update a Tarako to BuildID:
2) Launch Contacts app.
3) Create a new contact.
4) Tap on picture icon.
5) Attach a picture from the camera.
6) Tap on any text field 
7) Type some characters.

Actual:
Text input is not registered in text field.

Expected:
Text is properly input.

v1.3T Environmental Variables:
Device: Tarako v1.3T MOZ
BuildID: Tarako - 20140403004001
Gaia: 8d212f640014db62c622e8c939ddbf8595f00438
Gecko: ddd7ba612cfe
Firmware Version: sp8810

Notes:
Issue does not occur in

Repro frequency: 100%
See attached: logcat
Can we check that this doesn't happen on 1.3?
Keywords: qawanted
Hi,

I'm not able to reproduce it on today's (4/4) v1.3 build:
Device: Hamachi
BuildId: 20140404055956
Gecko: 7fb5cbd
Gaia: f06667b
Platform version: 28.0


Following the next STRs:
1- Launch Contacts app
2- Tap on add contact
3- Tap on add picture
4- Select Camera
5- Take a picture and select it
6- Tap on Name field

Actual result: Keyboard appears and the typed text properly appears in the Name field
We need a video of this bug.
Keywords: qawanted
Added video to URL field.
The video here is too much out of focus to be able to see the bug. Can we try getting a clearer video here?
Keywords: qawanted
Replaced URL with a new video.  Hope the video is clearer.
Keywords: qawanted
(In reply to ddixon from comment #6)
> Replaced URL with a new video.  Hope the video is clearer.

Sorry, but it isn't. The last part of the STR still shows the contacts app out of focus.
Keywords: qawanted
Updating url field with new video.

The issue can be seen reproducing at 0:23. The selected text field does not seem to register inputs from the keyboard.
(In reply to J Zimbrick from comment #8)
> Updating url field with new video.
> 
> The issue can be seen reproducing at 0:23. The selected text field does not
> seem to register inputs from the keyboard.

Much better.

This pretty much looks like the keyboard completely doesn't work at all in this use case - there's no text showing up.
blocking-b2g: --- → 1.3T?
Component: Gaia::Contacts → Gaia::Keyboard
Rudy, would you might checking the keyboard app first? Although I suspect mozbrowser/inputmethod API might be at fault here.
Assignee: nobody → rlu
Flags: needinfo?(rlu)
Looks like a Gaia issue, did not see the keyboard do inputContext.sendKey().
Finding the root cause...
Flags: needinfo?(rlu)
This should be a dupe of bug 950573, which we have fixed, but that patch was not uplifted to v1.3 and so not in v1.3t.
Will dupe this to that bug, and nominate that one as v1.3t+.
Status: NEW → RESOLVED
blocking-b2g: 1.3T? → ---
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 950573
You need to log in before you can comment on or make changes to this bug.