Closed Bug 992233 Opened 6 years ago Closed 6 years ago

Bug 984153 regressed the background color for suggestions list

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

defect
Not set

Tracking

(blocking-b2g:1.4+, b2g-v1.4 fixed, b2g-v2.0 fixed)

RESOLVED FIXED
1.4 S6 (25apr)
blocking-b2g 1.4+
Tracking Status
b2g-v1.4 --- fixed
b2g-v2.0 --- fixed

People

(Reporter: julienw, Assigned: steveck)

References

Details

(Keywords: regression)

Attachments

(2 files)

Attached image screenshot.png
Because of the patch in Bug 984153, the background color of the suggestion list is grey instead of white because the specificity of the new selector is higher than the one at [1].

So we need to use a selector with lower specificity to fix bug 984153. Maybe add a class instead of an id? I'd hate to put more specificty at [1]...

[1] https://github.com/mozilla-b2g/gaia/blob/0aaacfb35bc914814904a02a49e1abb9a56ac099/apps/sms/style/sms.css#L973

Requesting 1.4+ because bug 984153 landed in 1.4.
Summary: Add a background color to the thread list |ul| element → Bug 984153 regressed the background color for suggestions list
blocking-b2g: 1.4? → 1.4+
Assignee: nobody → schung
Target Milestone: --- → 1.4 S6 (25apr)
Steve, any update? Thanks.
Flags: needinfo?(schung)
Attached file Link to github
Hi Julien, that's the minimum css changes I could thoug that only apply grey background color for the ul not contained contact-list class.
Attachment #8407446 - Flags: review?(felash)
Flags: needinfo?(schung)
Comment on attachment 8407446 [details] [review]
Link to github

I really open to make it cleaner by adding some more code. One proposal on github is to add a specific class to ULs used as message containers.
Attachment #8407446 - Flags: review?(felash)
Retriage - this is minor user impact, so I think we can live with this.
blocking-b2g: 1.4+ → 1.4?
I'm not sure UX would agree with you here, Jason.
triage with UX, make it white as expected.
blocking-b2g: 1.4? → 1.4+
Steve: since it's 1.4+, I'm fine with your patch on the branch (didn't try it yet though) but I'd like another patch for master then, using a class.
(In reply to Wesley Huang [:wesley_huang] from comment #6)
> triage with UX, make it white as expected.

I don't think that's makes this a compelling argument to block. That just means that they agree it's a bug.
blocking-b2g: 1.4+ → 1.4?
Alright I got the explanation of why this is a blocker. User testing has found that grey indicates to a user that the UI is not clickable, so having a grey background here means the UI risks never being used.
blocking-b2g: 1.4? → 1.4+
Comment on attachment 8407446 [details] [review]
Link to github

As you wish :) I add a 'message-list' class for it.
Attachment #8407446 - Flags: review?(felash)
Comment on attachment 8407446 [details] [review]
Link to github

r=me with the additional CSS change; pick your prefered proposal, just remove that id :)
Attachment #8407446 - Flags: review?(felash) → review+
in master: 559c4b4d8bf5bfeb5c6ad7a22ddcf01949f15c74
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Needs a branch patch for v1.4 uplift.
Flags: needinfo?(schung)
in v1.4 : 3c53bebcc7541e5d19c96cf38ee2603927478f3c
Flags: needinfo?(schung)
You need to log in before you can comment on or make changes to this bug.