[B2G][Passcode] Passcode field stays empty when tapping a passcode quickly with two fingers

RESOLVED WONTFIX

Status

defect
RESOLVED WONTFIX
5 years ago
2 years ago

People

(Reporter: sarsenyev, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g18 affected, b2g-v1.3 affected, b2g-v1.3T affected, b2g-v2.2 affected)

Details

(Whiteboard: [tarako-exploratory], )

Attachments

(1 attachment)

Posted file log442014-5.txt
Description:
On the passcode screen when quickly entering a passcode, even when the numbers response with blue color, the passcode field stays empty

Prerequisites:
Device is locked with passcode "1245"

Repro Steps:
1) Update a Tarako to BuildID: 20140404004001
2) Quickly tap the "1245" passcode with two fingers

Actual:
The passcode screen stays empty

Expected:
The passcode is entered when tapping fast

1.3T Environmental Variables:
Device: Tarako 1.3T MOZ
BuildID: 20140404004001
Gaia: acd18bbd94ebfa534e252a24a75a0617e4b5d5ae
Gecko: 91a1b54da4a6
Version: 28.1
Firmware Version: sp8810

Notes:
Passcode "1245" is easy to repro

Repro frequency: 90% 4/5
See attached: video clip, logcat

The issue DOES repro with 1.3 Buri device

1.3 Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140401004003
Gaia: 24f562fce468fc948ac9e6185e002c23350cb9ee
Gecko: 0adf24a785f2
Version: 28.0
Firmware Version: v1.2-device.cfg
Does this happen on 1.1?
Keywords: qawanted
Unable to reproduce issue on latest Buri 1.1 build.  

If the user quickly and precisely taps the passcode "1245", the phone will unlock correctly.  

NOTE: If the the user does not precisely tap and instead taps and slides their finger to the remaining digits, the phone will not unlock; this seems to be the correct behavior. Further, passcode digits must be entered with precise taps only.  Sliding to other digits does not work.  

1.1 Environmental Variables:
Device: buri 1.1 MOZ
BuildID: 20140331041208
Gaia: 44a2ddf63373f8e95c784faf4ed4d60081699c61
Gecko: 170d87349060
Version: 18.0
Firmware Version: v1.2-device.cfg
Assignee: nobody → ddixon
Keywords: qawanted
Assignee: ddixon → nobody
QA Contact: ddixon
Correction: Issue DOES occur in Buri 1.1 after further investigation.   

Entering the passcode such as "1245" quickly with two fingers causes the UI to be unresponsive.  Thus, the code does not get entered.  

1.1 Environmental Variables:
Device: buri 1.1 MOZ
BuildID: 20140331041208
Gaia: 44a2ddf63373f8e95c784faf4ed4d60081699c61
Gecko: 170d87349060
Version: 18.0
Firmware Version: v1.2-device.cfg
Side note, we're crashing on 1.3 T : bug 991406 

Can you attach the video clip please, Sergey?
Flags: needinfo?(sarsenyev)
attached correct YouTube video
This is still an issue and I was able to repro it.
Component: Gaia::Dialer → Gaia::System::Lockscreen
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.