Closed Bug 992611 Opened 6 years ago Closed 6 years ago

mochitest-bc chunk2 perma-leak on all platforms on Cedar - (DOMStorageManager, EventTokenBucket, Mutex, ReentrantMonitor, Service, ...)

Categories

(Core :: General, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla31
Tracking Status
firefox30 --- fixed
firefox31 --- fixed

People

(Reporter: RyanVM, Assigned: MattN)

References

Details

(Keywords: memory-leak)

Attachments

(1 file)

We're seeing this perma-leak across all platforms when we run mochitest-bc in chunks and devtools split into their own testsuite on Cedar. This is blocking our ability to enable these changes in production.

Andrew, any chance you could lend a hand investigating? Logs are available in any bc2 run shown here:
https://tbpl.mozilla.org/?tree=Cedar&jobname=mochitest.*chrome&rev=860811be1a5d
Which basically agrees with "don't run devtools tests with the rest of mochitest-bc and get leaks"
Hmm.  Looks like networking stuff.
Oh, this is probably a dupe of bug 964369, except now it's a perma-leak.
See Also: → 964369
Can you test the patch in bug 964369 and see if it helps? Thanks
Flags: needinfo?(ryanvm)
I found an xpcshell test for this API but prefs_general.js isn't used on xpcshell so I didn't need to modify it.

Try push: https://tbpl.mozilla.org/?tree=Try&rev=d390d6041643
Assignee: nobody → MattN+bmo
Status: NEW → ASSIGNED
Attachment #8402279 - Flags: review?(mcmanus)
Can you check if this fixes the leaks?
Flags: needinfo?(ryanvm)
Comment on attachment 8402279 [details] [diff] [review]
v.1 Set network.http.speculative-parallel-limit to 0 in non-xpcshell tests

Review of attachment 8402279 [details] [diff] [review]:
-----------------------------------------------------------------

I'm fine with this. The test suite is not supposed to be making external connections and it certainly is doing so in the current state of things.

As comment 7 says, there is at least some coverage for Speculative Connections in xpcshell that is unaffected by at least this change.
Attachment #8402279 - Flags: review?(mcmanus) → review+
should I consider adding this to talos?
Blocks: 990713
(In reply to Joel Maher (:jmaher) from comment #12)
> should I consider adding this to talos?

It would probably be good to do since I believe TART can run with the New Tab Page showing (which also does speculative connections). If the mouse cursor happens to be over a tile, it could make a connection.
https://hg.mozilla.org/mozilla-central/rev/2f612effdfda
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → mozilla31
Duplicate of this bug: 980746
Duplicate of this bug: 964369
Blocks: 617414
You need to log in before you can comment on or make changes to this bug.