[Window management] Prevent homescreen being restarted again and again while call coming.

RESOLVED FIXED

Status

defect
P1
blocker
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: alive, Assigned: timdream)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:1.3T+, b2g-v1.3T fixed)

Details

(Whiteboard: [priority][tarako_only])

Attachments

(1 attachment)

See https://bugzilla.mozilla.org/show_bug.cgi?id=988110#c99

HomescreenWindow is restarting in a case that it thinks it's in foreground but there's callscreen there.

+++ This bug was initially created as a clone of Bug #988110 +++

changeset from 191
=========================
gaia
commit 943ff7984dbb8fbe833c3daef18b09a62c139c1e
Merge: ea0653b f513242
Author: Ryan VanderMeulen <ryanvm@gmail.com>
Date:   Fri Mar 21 10:53:54 2014 -0400

    Merge branch 'v1.3' into v1.3t

commit ea0653b1329d78a569f2e9a19f763ad8881449e2
Merge: 1917b47 e33d80e
Author: Ryan VanderMeulen <rvandermeulen@mozilla.com>
Date:   Fri Mar 21 08:40:25 2014 -0400

    Merge pull request #17422 from timdream/keyboard-mempressure-race
    
    Bug 984238 - Don't kill the keyboard when when it's being launched +shepherd

commit 1917b47b7099de1fab2c9786ae04219122966049
Merge: a170c6f 28e0261
Author: Yuren Ju <yurenju@gmail.com>
Date:   Fri Mar 21 18:25:08 2014 +0800

    Merge pull request #17433 from evanxd/v1.3t-bug-986345
    
    Bug 986345 - Fix CI_ACTION=marionette_js failure on 1.3/1.3t branch. a=testonly

commit f5132420bef0d4dc27dfcb32bb9c5df2ab80530a
Merge: 864957c e66437c
Author: Yuren Ju <yurenju@gmail.com>
Date:   Fri Mar 21 18:25:00 2014 +0800

    Merge pull request #17432 from evanxd/v1.3-bug-986345
    
    Bug 986345 - Fix CI_ACTION=marionette_js failure on 1.3/1.3t branch. a=testonly

commit a170c6f78a2a710e843e68243691ac39746d3456
Merge: a6919e4 ea4731f
Author: Yuren Ju <yurenju@gmail.com>
Date:   Fri Mar 21 18:16:42 2014 +0800

    Merge pull request #17436 from yurenju/wappush-v1.3t
    
    Bug 986380 - fix unit test case "auth_test.js" in wappush app a=testonly

commit 864957ce10921155f702aa60413fddcf0c6b078e
Merge: 001f2e6 5b9c7ff
Author: Yuren Ju <yurenju@gmail.com>
Date:   Fri Mar 21 18:08:20 2014 +0800

    Merge pull request #17435 from yurenju/wappush
    
    Bug 986380 - fix unit test case "auth_test.js" in wappush app a=testonly

commit e66437c5522499cd98d349081691349d29bce4b4
Author: Evan Xd <itoyxd@gmail.com>
Date:   Fri Mar 21 17:17:25 2014 +0800

    Bug 986345 - Add black list on Travis.
Whiteboard: [priority][MP_Blocker] → [priority]
Assignee: nobody → alive
@Tzu-lin, do we need this bug fixed to continue monkey test of bug 988110? If yes, I think we should 1.3T+ this bug.
Flags: needinfo?(tzhuang)
blocking-b2g: --- → 1.3T?
Yes, We need the patch mentioned in https://bugzilla.mozilla.org/show_bug.cgi?id=988110#c69 in 1.3T

All our monkey test ran this week were all with the patch.
Flags: needinfo?(tzhuang)
This bug needs to block because it's the Gaia part of the monkey test fix (bug 988110).
Assignee: alive → timdream
Status: NEW → ASSIGNED
(In reply to Tzu-Lin Huang [:dwi2][:tzhuang] from comment #2)
> Yes, We need the patch mentioned in
> https://bugzilla.mozilla.org/show_bug.cgi?id=988110#c69 in 1.3T
> 
> All our monkey test ran this week were all with the patch.

I think we should need commit 9a57a86 and 9dea96a in https://github.com/timdream/gaia/compare/mozilla-b2g:v1.3t...v1.3t-crazy-monkey actually
After consulting with Alive, we don't think the cause is clear enough for us to come up with a patch in master. I am making this bug tarako only and will file follow-up to investigate.
Whiteboard: [priority] → [priority][tarako_only]
Attachment #8403774 - Flags: review?(alive) → review+
v1.3t: https://github.com/mozilla-b2g/gaia/commit/d735928c3673c8500154177cac8a16fd39787b1a
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
triage: 1.3T+ for stability improvement
blocking-b2g: 1.3T? → 1.3T+
You need to log in before you can comment on or make changes to this bug.