Closed Bug 993517 Opened 6 years ago Closed 6 years ago

OSX: Scrollbar doesn't work

Categories

(Core :: Widget: Cocoa, defect)

28 Branch
x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 987680

People

(Reporter: milan, Unassigned)

References

Details

(Keywords: regression)

Go to a page that needs scrolling.  Try to use drag the thumb to actually scroll - no luck.

I see this on current trunk (31), Jeff also saw it as far back as nightly 3/30 build.  I don't see the problem on aurora (30).

I imagine it's related to bug 989768.
I got a different regression range :)

Last good nightly: 2014-03-20
First bad nightly: 2014-03-21

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e84a391b604b&tochange=c148f0b0c8b4
Odd, when I run this again I get the same result as you. Please ignore comment 1.
For the record, this only happens when you have your system prefs set to only show scrollbars when starting to scroll. Apart from not responding to any drags, the scrollbar also doesn't become larger.

This seems to be caused by bug 926292 - backing out out https://hg.mozilla.org/mozilla-central/rev/d5acc6457aaa from my local build makes the scrollbar work again.
Blocks: 926292
Probably want to take care of this while on the trunk (~ three weeks.)  Markus, is this just a bug, or a fundamental clash of requirements between this and bug 926292?
Flags: needinfo?(mstange)
It also appears this depends on the page - I get the problem shown "all the time" when using bugzilla pages themselves as test pages.  But, for example, going to a random wiki page (e.g., https://wiki.mozilla.org/Platform/GFX/WorkWeekSummary201403), and I don't see the bug.
This bug seems to be fixed by the patch from bug 987680. I'm guessing the hover event wasn't getting to the scrollbar because the display item for the scrollbar was below some other content of the page so the mouse event was finding something else.
Depends on: 987680
Flags: needinfo?(mstange)
Duplicate of this bug: 990476
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 987680
You need to log in before you can comment on or make changes to this bug.