Closed Bug 993528 Opened 8 years ago Closed 8 years ago

Configure the MLS key for pvt builds

Categories

(Release Engineering :: General, defect)

All
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: fabrice, Assigned: catlee)

References

Details

Attachments

(1 file)

See also bug 977456. I'm sending the key by email to catlee.
Assignee: nobody → catlee
Right now the code (device/sprd/sp6821a_gonk/prod_sp6821a.mk) hard-codes the location of the key to be in device/sprd/sp6821a_gonk/mls.key

Can we have this over-rideable by setting an environment variable?
Flags: needinfo?(fabrice)
I initially set gonk-misc/default-gecko-config to use an environment variable, but I did not expected that it would be hijacked like that :(

James, could you remove that from the device/sprd directory and set it differently in your build config?
Flags: needinfo?(fabrice) → needinfo?(james.zhang)
(In reply to Fabrice Desré [:fabrice] from comment #2)
> I initially set gonk-misc/default-gecko-config to use an environment
> variable, but I did not expected that it would be hijacked like that :(
> 
> James, could you remove that from the device/sprd directory and set it
> differently in your build config?

Of course.

Is this patch ok for you? Should I merge this patch to my git repo ?


diff --git a/sp6821a_gonk/prod_sp6821a.mk b/sp6821a_gonk/prod_sp6821a.mk
index 9064fa0..5e065e0 100644
--- a/sp6821a_gonk/prod_sp6821a.mk
+++ b/sp6821a_gonk/prod_sp6821a.mk
@@ -72,7 +72,7 @@ MOZ_PRODUCT_COMPRESS_FONTS := true
 
 # Gecko/Gaia need below export value
 # Using Mozilla API key to support MLS
-export MOZILLA_MLS_KEY_FILE=$(ANDROID_BUILD_TOP)/$(BOARDDIR)/mls.key
+#export MOZILLA_MLS_KEY_FILE=$(ANDROID_BUILD_TOP)/$(BOARDDIR)/mls.key
 export GAIA_DISTRIBUTION_DIR=$(PWD)/device/sprd/sp6821a_gonk/
 export GAIA_APP_SRCDIRS=apps external-apps outoftree_apps customize_apps/engmode/assets customize_apps/ValidationTools/assets
 export PRODUCTION=1
Flags: needinfo?(james.zhang) → needinfo?(fabrice)
I'll let Chris tell what suits our automation.
Flags: needinfo?(fabrice) → needinfo?(catlee)
For automation, it's easier if the build system uses the value of MOZILLA_MLS_KEY_FILE that's in the environment already. Our automation will take care of setting it properly.

If you want to fallback to the existing value if it's not set, that would be fine as well.

e.g.

if [ -z "$MOZILLA_MLS_KEY_FILE" ]; then
export MOZILLA_MLS_KEY_FILE=$(ANDROID_BUILD_TOP)/$(BOARDDIR)/mls.key
fi
Flags: needinfo?(catlee)
James, is this approach suitable?
Flags: needinfo?(james.zhang)
I'll discuss with thomas first. Maybe I'll add pvt device for mozilla pvt build.
Flags: needinfo?(james.zhang) → needinfo?(ttsai)
Hi James: It's ok to follow comment #5.
prod_sp6821a.mk:
if [ -z "$MOZILLA_MLS_KEY_FILE" ]; then
export MOZILLA_MLS_KEY_FILE=$(ANDROID_BUILD_TOP)/$(BOARDDIR)/mls.key
fi
Flags: needinfo?(ttsai) → needinfo?(james.zhang)
fixed on my side.
device/sprd

commit 1498c743ea56b140ced231390d9b62f7c928309c
Author: james.zhang <james.zhang@spreadtrum.com>
Date:   Mon Apr 28 20:57:06 2014 +0800

    Bug#269156 mozilla Bug 993528 - Configure the MLS key for pvt builds
    
    [bug number  ]
    [root cause  ]
    [changes     ]
    [side effects]
    [self test   ] yes
    [reviewers   ]
    
    Change-Id: I8afacc485f05b36772c02f154e6f85a95467d675
Flags: needinfo?(james.zhang)
Depends on: 1002695
Attachment #8414439 - Flags: review?(fabrice)
Attachment #8414439 - Flags: review?(fabrice) → review+
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.