Closed Bug 994053 Opened 6 years ago Closed 5 years ago

[email][rtl] Support rtl/right-to-left languages like Arabic in Email app

Categories

(Firefox OS Graveyard :: Gaia::E-Mail, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1064617

People

(Reporter: aryx, Unassigned)

References

Details

(Keywords: rtl)

Boot2Gecko 1.5.0.0-prerelease 20140407024544 on Geeksphone Keon

Support rtl/right-to-left languages like Arabic in the Email app. At the moment, it seems to be strictly left-to-right.
IMO, deciding whether to add RTL support to Email app or not is one of the hardest decisions. As for Downloads in Settings App and how I chose to keep it LTR, it just made sense to me that it stays LTR.. Also for Email App.. However I'd love to see what core Email app is doing on competitor product, unfortunately I have only a bricked Android phone.

Archaeopteryx, can we check the status of Email App on other OSs? :) Unfortunately I can't since as I mentioned I bricked my Android device a while ago.
Flags: needinfo?(archaeopteryx)
Unfortunately, my Android device (Nexus S running Android 4.1.2) doesn't offer Arabic in the languages menu.

When I filed the bug I was mostly thinking about pour standalone text labels like header, folder names in the sidebar, searchbar placeholder etc.
Flags: needinfo?(archaeopteryx)
Going to resolve this as a duplicate of the new Email Meta bug #1064617 that we'll use to track individual email bugs during 2.2 development.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: email-rtl
Mass Edit: adding the [rtl-meta]
Whiteboard: [rtl-meta]
You need to log in before you can comment on or make changes to this bug.