Closed Bug 994582 Opened 6 years ago Closed 6 years ago

[UX] Tweak panel animation so that it looks good on all platforms/systems

Categories

(Toolkit :: Themes, defect)

31 Branch
x86_64
All
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla32
Tracking Status
firefox31 --- fixed
firefox32 --- fixed

People

(Reporter: alice0775, Assigned: phlsa)

References

(Blocks 1 open bug)

Details

(Whiteboard: [ux] p=5 s=it-32c-31a-30b.2 [qa-])

Attachments

(1 file, 1 obsolete file)

See screen capture: http://youtu.be/duPd-7Ujbbw
An afterimage is obstructive.
Well, that's not good.
I also noticed some rather big differences in how the new animation feels on different platforms and system configurations.
Let's use this bug to find a solution to that problem (since that would also fix your original issue)
Flags: firefox-backlog?
OS: Linux → All
Summary: Panel animation is ugly in slow pc → [UX] Tweak panel animation so that it looks good on all platforms/systems
Flags: firefox-backlog? → firefox-backlog+
Whiteboard: [ux] p=0
Following the triage meetings, this remains unassigned. Philipp, would you be willing to mentor a community member through this bug?
Flags: needinfo?(philipp)
Whiteboard: [ux] p=0 → [ux] p=0 [diamond]
Whiteboard: [ux] p=0 [diamond] → [ux] [diamond] p=5
I think we should avoid any kind of hardware acceleration use. If we use some, we should give users the ability to disable the animation.
(In reply to Mike Hoye [:mhoye] from comment #2)
> Following the triage meetings, this remains unassigned. Philipp, would you
> be willing to mentor a community member through this bug?

Absolutely!

(In reply to Tim Nguyen [:ntim] from comment #3)
> I think we should avoid any kind of hardware acceleration use. If we use
> some, we should give users the ability to disable the animation.

Why should we avoid hardware acceleration? Are you concerned about compatibility?
Flags: needinfo?(philipp) → needinfo?(ntim007)
(In reply to Philipp Sackl [:phlsa] (on PTO Apr 16-23) from comment #4)
> (In reply to Mike Hoye [:mhoye] from comment #2)
> > Following the triage meetings, this remains unassigned. Philipp, would you
> > be willing to mentor a community member through this bug?
> 
> Absolutely!
> 
> (In reply to Tim Nguyen [:ntim] from comment #3)
> > I think we should avoid any kind of hardware acceleration use. If we use
> > some, we should give users the ability to disable the animation.
> 
> Why should we avoid hardware acceleration? Are you concerned about
> compatibility?

Yes, hardware acceleration can be slow on old computers. The ubuntu screencast shows what it can look like.
Flags: needinfo?(ntim007)
(In reply to Tim Nguyen [:ntim] from comment #5)
> (In reply to Philipp Sackl [:phlsa] (on PTO Apr 16-23) from comment #4)
> > (In reply to Mike Hoye [:mhoye] from comment #2)
> > > Following the triage meetings, this remains unassigned. Philipp, would you
> > > be willing to mentor a community member through this bug?
> > 
> > Absolutely!
> > 
> > (In reply to Tim Nguyen [:ntim] from comment #3)
> > > I think we should avoid any kind of hardware acceleration use. If we use
> > > some, we should give users the ability to disable the animation.
> > 
> > Why should we avoid hardware acceleration? Are you concerned about
> > compatibility?
> 
> Yes, hardware acceleration can be slow on old computers. The ubuntu
> screencast shows what it can look like.

Hm, so are you seeing the same effects when a website uses animated CSS transforms? AFAIK those are accelerated as well. I always thought that those animations would degrade by just skipping the animation entirely.
This discussion on hardware acceleration appears to be a red herring. There's no proof that the artifacts seen on Ubuntu are due to hardware acceleration. Even if they were, there's not much we could do about it, since this is controlled by the operating system's window manager.
Component: Toolbars and Customization → Themes
Product: Firefox → Toolkit
Depends on: 1001234
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Whiteboard: [ux] [diamond] p=5 → [ux] p=8 s=it-32c-31a-30b.1 [qa-]
Whiteboard: [ux] p=8 s=it-32c-31a-30b.1 [qa-] → [ux] p=5 s=it-32c-31a-30b.1 [qa-]
Attached patch Patch v1 (obsolete) — Splinter Review
This patch implements a less jarring close animation and also tweaks the opening animation. Since no more shrinking is involved, it might also help with the after-image issues.
Attachment #8418067 - Flags: review?(enndeakin)
Attachment #8418067 - Flags: review?(enndeakin) → review+
This is bitrotted. Please rebase.
Keywords: checkin-needed
Whiteboard: [ux] p=5 s=it-32c-31a-30b.1 [qa-] → [ux] p=5 s=it-32c-31a-30b.2 [qa-]
De-bitrotted. Carrying forward r+ by Neil.
Attachment #8418067 - Attachment is obsolete: true
Attachment #8421636 - Flags: review+
https://hg.mozilla.org/integration/fx-team/rev/7f23305ed404
Keywords: checkin-needed
Whiteboard: [ux] p=5 s=it-32c-31a-30b.2 [qa-] → [ux] p=5 s=it-32c-31a-30b.2 [qa-][fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/7f23305ed404
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [ux] p=5 s=it-32c-31a-30b.2 [qa-][fixed-in-fx-team] → [ux] p=5 s=it-32c-31a-30b.2 [qa-]
Target Milestone: --- → mozilla32
Status: RESOLVED → VERIFIED
Blocks: 1011535
Comment on attachment 8421636 [details] [diff] [review]
Patch v1.1 (r=enndeakin)

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 610545
User impact if declined: Users will see a less-than-optimal animation every time they close an arrowpanel. This animation also caused rendering glitches on some platforms.
Testing completed (on m-c, etc.): On Nightly for a week
Risk to taking this patch (and alternatives if risky): low, because it is only CSS adjustments
String or IDL/UUID changes made by this patch: none
Attachment #8421636 - Flags: approval-mozilla-aurora?
Attachment #8421636 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.