Closed Bug 1001234 Opened 5 years ago Closed 5 years ago

disable arrow panel animation on linux

Categories

(Toolkit :: XUL Widgets, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
mozilla32
Tracking Status
firefox31 --- fixed
firefox32 --- fixed

People

(Reporter: Gavin, Assigned: enndeakin)

References

(Blocks 1 open bug)

Details

(Whiteboard: p=3 s=it-32c-31a-30b.1 [qa!])

Attachments

(1 file, 2 obsolete files)

See bug 994562 comment 13 for the rationale and instructions on how to do this.
Flags: firefox-backlog?
Flags: firefox-backlog? → firefox-backlog+
Whiteboard: p=3
Component: General → XUL Widgets
Blocks: 994582, 610545
Does the patch in bug 994562 fix the problem?
Duplicate of this bug: 984589
Assignee: nobody → enndeakin
Whiteboard: p=3 → p=3 s=it-32c-31a-30b.1 [qa+]
Attached patch Disable animation on Linux (obsolete) — Splinter Review
Attachment #8415646 - Flags: review?(dao)
Comment on attachment 8415646 [details] [diff] [review]
Disable animation on Linux

>   <binding id="arrowpanel" extends="chrome://global/content/bindings/popup.xml#panel">
>-    <content flip="both" side="top" position="bottomcenter topleft" consumeoutsideclicks="false">
>+    <content flip="both" side="top" position="bottomcenter topleft" consumeoutsideclicks="false"
>+#ifdef MOZ_WIDGET_GTK
>+             animate="false"
>+#endif
>+      >

Will this override the attribute in case it was set manually on a popup? I'd prefer if the attribute didn't have to be altered depending on the platform and was just ignored on Linux.

Also, bug 994562 seems like a reasonable compromise to me (it's still a bit ugly with the compositor disabled, but I don't think we should overoptiize for that case).
Attachment #8415646 - Flags: review?(dao)
Attached patch Disable animation on Linux, v2 (obsolete) — Splinter Review
Attachment #8415646 - Attachment is obsolete: true
Attachment #8416596 - Attachment is obsolete: true
Attachment #8416598 - Flags: review?(dao)
Comment on attachment 8416598 [details] [diff] [review]
Disable animation on Linux, v2.1

>--- a/toolkit/content/jar.mn
>+++ b/toolkit/content/jar.mn
>@@ -69,17 +69,17 @@ toolkit.jar:
> *+ content/global/bindings/findbar.xml         (widgets/findbar.xml)
>    content/global/bindings/general.xml         (widgets/general.xml)
>    content/global/bindings/groupbox.xml        (widgets/groupbox.xml)
> *+ content/global/bindings/listbox.xml         (widgets/listbox.xml)
>    content/global/bindings/menu.xml            (widgets/menu.xml)
>    content/global/bindings/menulist.xml        (widgets/menulist.xml)
>    content/global/bindings/notification.xml    (widgets/notification.xml)
>    content/global/bindings/numberbox.xml       (widgets/numberbox.xml)
>-   content/global/bindings/popup.xml           (widgets/popup.xml)
>+*  content/global/bindings/popup.xml           (widgets/popup.xml)

This shouldn't be needed anymore, you're not touching popup.xml in this patch.
Attachment #8416598 - Flags: review?(dao) → review+
QA Contact: catalin.varga
https://hg.mozilla.org/mozilla-central/rev/77aff162aa0c
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla32
Verified as fixed using the following environment:
Environment:
FF 32
Build id:20140507030202
OS: Ubuntu 13.04 x64

The arrow panel animation is disabled, however after this fix I found the following 2 bugs: bug 1007166 and bug 1007188 that appear to be related with this fix.
Status: RESOLVED → VERIFIED
Whiteboard: p=3 s=it-32c-31a-30b.1 [qa+] → p=3 s=it-32c-31a-30b.1 [qa!]
See Also: → 1007283
Neil, can we uplift this?
Flags: needinfo?(enndeakin)
Comment on attachment 8416598 [details] [diff] [review]
Disable animation on Linux, v2.1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 610545
User impact if declined: doorhangers don't work for many linux users
Testing completed (on m-c, etc.): yes
Risk to taking this patch (and alternatives if risky): none
String or IDL/UUID changes made by this patch: none
Attachment #8416598 - Flags: approval-mozilla-aurora?
Flags: needinfo?(enndeakin)
Attachment #8416598 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Blocks: 1007283
You need to log in before you can comment on or make changes to this bug.