Clicking on a named anchor does not scroll horizontally

VERIFIED FIXED in M9

Status

()

Core
Embedding: APIs
P3
normal
VERIFIED FIXED
19 years ago
17 years ago

People

(Reporter: Nisheeth Ranjan, Assigned: troy)

Tracking

Trunk
All
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Assigning this to myself for M9...
(Reporter)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M9
(Reporter)

Comment 1

19 years ago
Ccing troy and setting target milestone to M9...

The problem is that when a named anchor target is located offscreen to the
right, we go to the right vertical position but do not scroll horizontally.  So,
the target does not end up scrolling into the viewable region.
(Reporter)

Updated

19 years ago
Summary: Clicking on a named anchor does not scroll horizontally → [Webshell] Clicking on a named anchor does not scroll horizontally
(Reporter)

Comment 2

19 years ago
It seems like we need to change the way nsPresShell::ScrollFrameIntoView works.
It always defaults the x coordinate to 0 in its call to the ScrollTo() method.
But, the fix is not as simple as using "offset.x" for the x coordinate all the
time because we only want to scroll horizontally when the target frame is not
visible.
(Assignee)

Comment 3

19 years ago
Yes, that's the kind of fix we need.

Feel free to assign it to me if you want
(Reporter)

Updated

19 years ago
Assignee: nisheeth → troy
Status: ASSIGNED → NEW
Summary: [Webshell] Clicking on a named anchor does not scroll horizontally → Clicking on a named anchor does not scroll horizontally
(Reporter)

Comment 4

19 years ago
Reassigning to Troy and putting myself on the cc list.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 5

19 years ago
Using 8/5 Apprunner, verifying bug fixed - this was an offshoot of bug #3152
which I was assigned QA.
You need to log in before you can comment on or make changes to this bug.