Closed Bug 995949 Opened 6 years ago Closed 6 years ago

Cannot add smart collection to homescreen

Categories

(Firefox OS Graveyard :: Gaia::Everything.me, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.0+, b2g-v1.4 unaffected, b2g-v2.0 fixed)

RESOLVED FIXED
2.0 S1 (9may)
blocking-b2g 2.0+
Tracking Status
b2g-v1.4 --- unaffected
b2g-v2.0 --- fixed

People

(Reporter: RobertC, Assigned: amirn)

References

Details

(Keywords: regression, Whiteboard: [fromAutomation][xfail])

Attachments

(2 files)

134.05 KB, text/plain
Details
46 bytes, text/x-github-pull-request
ranbena
: review+
Details | Review
Attached file logcat.txt
Cannot add collection to homescreen.
Issue can be reproduced both manually and with automated tests on master build:

Gaia      aa898163f415fcc05e18b202a13dc8b8c141dd5e
Gecko     https://hg.mozilla.org/mozilla-central/rev/ebdf2740dc3e
BuildID   20140413160202
Version   31.0a1
ro.build.version.incremental=eng.tclxa.20131223.163538
ro.build.date=Mon Dec 23 16:36:04 CST 2013

This issue is not reproduced on v1.4

STR:
1. connect to wifi
2. open context menu
3. tap add smart collection
4. select a collection and tap ok

Expected result:
The collection is added to the homescreen

Actual result:
The collection icon is not present on the homescreen. Entering the collection menu we can see that no collection is selected.

Logcat attached.
Whiteboard: [fromAutomation]
blocking-b2g: --- → 2.0?
QA Contact: jharvey
Inbound B2G Regression Window:

Last Working
Device: Buri 1.5 MOZ
BuildID: 20140409024146
Gaia: e493c34c97b7cc2121c7b3e3324e097b4c0d0a9c
Gecko: 2bf0b8e1e410
Version: 31.0a1
Firmware Version: v1.2-device.cfg

First Broken
Device: Buri 1.5 MOZ
BuildID: 20140409040146
Gaia: d64a687a9018258852f3f79caf29b5b5cc04eb52
Gecko: e081f429737a
Version: 31.0a1
Firmware Version: v1.2-device.cfg

First Broken Gaia Last Working Gecko: Issue DOES reproduce
Gaia: d64a687a9018258852f3f79caf29b5b5cc04eb52
Gecko: 2bf0b8e1e410

Last Working Gaia First Broken Gecko: Issue Does NOT reproduce
Gaia: e493c34c97b7cc2121c7b3e3324e097b4c0d0a9c
Gecko: e081f429737a

Gaia Pushlog: https://github.com/mozilla-b2g/gaia/compare/e493c34c97b7cc2121c7b3e3324e097b4c0d0a9c...d64a687a9018258852f3f79caf29b5b5cc04eb52
Amir, can you take a look please?
Assignee: nobody → amirn
Flags: needinfo?(amirn)
bug 989983 caused this.
Blocks: 989983
blocking-b2g: 2.0? → 2.0+
Whiteboard: [fromAutomation] → [fromAutomation][xfail]
Attached file Pull Request
Attachment #8410157 - Flags: review?(ran)
Flags: needinfo?(amirn)
Thanks guys, attached a fix.
Attachment #8410157 - Flags: review?(ran) → review+
landed: https://github.com/mozilla-b2g/gaia/commit/8be4c38
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Thanks Amir!
Duplicate of this bug: 999990
Target Milestone: --- → 2.0 S1 (9may)
You need to log in before you can comment on or make changes to this bug.