Closed Bug 996028 Opened 7 years ago Closed 7 years ago

Easy browsing data cleanup

Categories

(Firefox for Android Graveyard :: General, defect)

28 Branch
x86
Windows 7
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1001309

People

(Reporter: br.renatosilva, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:28.0) Gecko/20100101 Firefox/28.0 (Beta/Release)
Build ID: 20140314220517

Steps to reproduce:

Browse the web.


Actual results:

Private browsing data keeps available on the phone. Cleanup needs to be performed manually, or using add-ons.


Expected results:

Easy cleanup should be available just like on desktop, where it can be performed on exit or using a keyboard shortcut. A few suggestions:

1. A new optional menu item like "Clean and exit" which would delete the browsing data then close the application.

2. Automated cleanup after a configurable period of time since which the application has been on background.

3. Keep only recent browsing data, for a configurable period, then everything older than that gets automatically deleted.
Duplicate of this bug: 909860
See bug https://bugzilla.mozilla.org/show_bug.cgi?id=1001309 and bug https://bugzilla.mozilla.org/show_bug.cgi?id=998009

This may be duplicated to either of those pending the project direction.
But isn't this more than just clearing history as seen in the two bugs mentioned by :aaronmt ?
Marking as duplicate since my first suggestion has been implemented. Thanks Aaron.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1001309
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.