Intermittent TEST-UNEXPECTED-FAIL | test_settings_change_language.py test_settings_change_language.TestChangeLanguage.test_change_language_settings | after TimeoutException: Timed out after 10.0 seconds

RESOLVED FIXED

Status

defect
P1
normal
RESOLVED FIXED
5 years ago
2 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gaia-ui-test])

Attachments

(1 attachment)

https://tbpl.mozilla.org/php/getParsedLog.php?id=37784482&tree=B2g-Inbound

b2g_macosx64 b2g-inbound opt test gaia-ui-test on 2014-04-14 14:41:24 PDT for push e6136ebda6ba
slave: talos-mtnlion-r5-058

14:54:50     INFO -  TEST-START test_settings_change_language.py
14:55:11     INFO -  test_change_language_settings (test_settings_change_language.TestChangeLanguage) ... ERROR
14:55:11     INFO -  ======================================================================
14:55:11     INFO -  ERROR: None
14:55:11     INFO -  ----------------------------------------------------------------------
14:55:11     INFO -  Traceback (most recent call last):
14:55:11     INFO -    File "/builds/slave/talos-slave/test/build/venv/lib/python2.7/site-packages/marionette/marionette_test.py", line 163, in run
14:55:11     INFO -      testMethod()
14:55:11     INFO -    File "/builds/slave/talos-slave/test/gaia/tests/python/gaia-ui-tests/gaiatest/tests/functional/settings/test_settings_change_language.py", line 22, in test_change_language_settings
14:55:11     INFO -      self.wait_for_condition(lambda m: settings.header_text == u'Param\u00E8tres')
14:55:11     INFO -    File "/builds/slave/talos-slave/test/gaia/tests/python/gaia-ui-tests/gaiatest/gaia_test.py", line 1048, in wait_for_condition
14:55:11     INFO -      Wait(self.marionette, timeout).until(method, message=message)
14:55:11     INFO -    File "/builds/slave/talos-slave/test/build/venv/lib/python2.7/site-packages/marionette/wait.py", line 143, in until
14:55:11     INFO -      cause=last_exc)
14:55:11    ERROR -  TimeoutException: TimeoutException: Timed out after 10.0 seconds
14:55:11     INFO -  TEST-UNEXPECTED-FAIL | test_settings_change_language.py test_settings_change_language.TestChangeLanguage.test_change_language_settings |
14:55:11     INFO -  ----------------------------------------------------------------------
14:55:11     INFO -  Ran 1 test in 20.935s
14:55:11  WARNING -  FAILED (errors=1)
Travis log for safe keeping: Traceback (most recent call last):

File "/home/travis/build/mozilla-b2g/gaia/travis_venv/local/lib/python2.7/site-packages/marionette_client-0.7.6-py2.7.egg/marionette/marionette_test.py", line 163, in run

testMethod()

File "/home/travis/build/mozilla-b2g/gaia/tests/python/gaia-ui-tests/gaiatest/tests/functional/settings/test_settings_change_language.py", line 22, in test_change_language_settings

self.wait_for_condition(lambda m: settings.header_text == u'Param\u00E8tres')

File "/home/travis/build/mozilla-b2g/gaia/tests/python/gaia-ui-tests/gaiatest/gaia_test.py", line 1056, in wait_for_condition

Wait(self.marionette, timeout).until(method, message=message)

File "/home/travis/build/mozilla-b2g/gaia/travis_venv/local/lib/python2.7/site-packages/marionette_client-0.7.6-py2.7.egg/marionette/wait.py", line 143, in until

cause=last_exc)

TimeoutException: TimeoutException: Timed out after 10.1 seconds

TEST-UNEXPECTED-FAIL | test_settings_change_language.py test_settings_change_language.TestChangeLanguage.test_change_language_settings |

----------------------------------------------------------------------

Ran 1 test in 22.769s

FAILED (errors=1)
This is failing too often for travis. Disabled: https://github.com/mozilla-b2g/gaia/commit/1cc066cde6f5d2533e86784b5979e1b97f068b8c
Component: Gaia::Settings → Gaia::UI Tests
Keywords: leave-open
Thanks Zac, sorry about that! I will try to remember to skip only if desktop from here on out, though it seems to be less necessary these days. Very nice work keeping the tests green :)
Reduced the fail rate to 248 pass / 250 tests
Comment on attachment 8422367 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/19205

r-, needs to be 250/250.
Attachment #8422367 - Flags: review?(zcampbell) → review-
Comment on attachment 8422367 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/19205

https://travis-ci.org/mozilla-b2g/gaia/builds/25344839

Can you re review this please?
250/250
Attachment #8422367 - Flags: review- → review?(zcampbell)
Comment on attachment 8422367 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/19205

r+ on functionality,

but it needs the Travis hacks removed and the disabled tags removed from manifest file and tbpl-manifest.ini
Attachment #8422367 - Flags: review?(zcampbell)
Attachment #8422367 - Flags: review?(zcampbell)
Attachment #8422367 - Flags: review?(robert.chira)
Comment on attachment 8422367 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/19205

r+
Attachment #8422367 - Flags: review?(robert.chira) → review+
Comment on attachment 8422367 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/19205

r+
Attachment #8422367 - Flags: review?(zcampbell) → review+
Merged:
https://github.com/mozilla-b2g/gaia/commit/9ad117d9d7f4d9e76ca235b168a3ac79f870f4c1
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Priority: -- → P1
Duplicate of this bug: 1018873
Assignee: florin.strugariu → nobody
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1005272
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
from the screen shot it looks like the language selector is not populated 

I can't reproduce it on device or desktopB2G using manual testing or automation
Kyle, looks like this perma-fail is your doing?
Flags: needinfo?(kyle)
We have a potential fix in on bug 1060462. The problem being, this is a permafail on a platform that is not on try (Linux x64 B2G Desktop Debug). However, applying the fix on Pine showed green, so we're hopeful that this will work.
Flags: needinfo?(kyle)
(In reply to Kyle Machulis [:kmachulis] [:qdot] from comment #112)
> The problem being, this is a permafail on a platform that is not on try
> (Linux x64 B2G Desktop Debug).

Please file a bug for that.
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #113)
> (In reply to Kyle Machulis [:kmachulis] [:qdot] from comment #112)
> > The problem being, this is a permafail on a platform that is not on try
> > (Linux x64 B2G Desktop Debug).
> 
> Please file a bug for that.

Bug 1045200
Looks like this was fixed in bug 1060462
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
Removing leave-open keyword from resolved bugs, per :sylvestre.
Keywords: leave-open
You need to log in before you can comment on or make changes to this bug.