Turbo-Installer does not detect Mozilla process running in turbo mode

VERIFIED FIXED

Status

VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: agracebush, Assigned: slogan)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Steps to reproduce:

1. Install Mozilla in turbo mode
2. Perform various tests (multiple profiles etc)
3. Verify key set, path correct, profiles switch, UI seen
4. Run second install before rightclicking icon to exit

actual results: Install proceeded, two systray icons displayed until mouseover 
removed old one, registry key path references new install, unable to rightclick 
to see icon menu or exit.

expected results: Installer would give me warning that Mozilla was running.

build 2001091405- mozilla
(Reporter)

Comment 1

17 years ago
this does not happen with N6 Installer
QA Contact: bugzilla → gbush

Comment 2

17 years ago
All the uninstaller does is call the main app (in this case mozilla.exe) with a 
-kill.

The -kill feature has probably been affected by all the recent turbo change 
landings.  I've been seeing funny things happen with the turbo feature and how 
it exits.

Adding Bill Law to the CC: list and reassigning to Syd.
Assignee: ssu → syd
nominating nsbranch just to make sure this is looked at. We *know* installing
over a running build causes us grief (6.1 top crash) so we have to be vigilant.
Keywords: nsbranch

Comment 4

17 years ago
oops, I meant to say that the uninstaller and the installer both just call the 
apps with -kill in order to deal with exiting out of turbo mode.

Comment 5

17 years ago
I wonder if this bug is related at all to bug 99677?
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Keywords: nsbranch → nsbranch+
(Assignee)

Comment 6

17 years ago
this is worksforme on win 98 (windows "me" actually, but same family). can I get
confirmation this is only Windows NT (perhaps 2000 too)?

Comment 7

17 years ago
bug 99677 is specific to the advanced pref panel being broken and accidentally
setting turbo off.  So I don't think this is related (I didn't see mention of
the pref panel being used).

I suspect bug 88844.  That code (as currently in the branch; dp has a patch
attached to the bug) screws up xpcom initialization (and random other things?)
whenever you launch mozilla without the -turbo option, but with the registry
entry set that says "run in turbo mode."  That situation would seem to apply
here, right?

The symptoms in that case seem random.  In debug builds, it asserts/crashes.  In
optimized builds it seems to be broken in random ways (lots of dups).  I don't
understand exactly what's happening in this dual-install case, but I'd suspect
bug 88844.  We need to get dp's fix for that in ASAP and see if these other
flaky problems get fixed, as well.

Updated

17 years ago
Blocks: 75599

Updated

17 years ago
No longer blocks: 75599

Comment 8

17 years ago
*** Bug 89936 has been marked as a duplicate of this bug. ***

Comment 9

17 years ago
I've seen this work for me too under NT4 with 09/17 build.  I can test it again 
with today's build and on a Win2k system (as well as NT4).
(Reporter)

Comment 10

17 years ago
tested with 2001091803 branch build- on WinNT, Windows 2000, and WindowsXP
systray icon is removed when Installer starts
(Mozilla and branch builds)

this is working for me

Comment 11

17 years ago
marking this fixed then.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 12

17 years ago
verified with builds mentioned
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.