Closed Bug 996541 Opened 6 years ago Closed 6 years ago

[Tarako][Wifi] [Follow up of bug 989717] netd command error when toggle wifi hotspot quickly.

Categories

(Firefox OS Graveyard :: Vendcom, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:1.3T+, b2g-v1.3T fixed)

RESOLVED FIXED
blocking-b2g 1.3T+
Tracking Status
b2g-v1.3T --- fixed

People

(Reporter: vchang, Assigned: xinhe.yan)

Details

(Whiteboard: [POVB][sprd295455])

I saw below error message if I turn on/off wifi hotspot quickly.  
D/WifiHW  (   85): Unable to unload driver module "itm_ap.ko": No such file or directory
D/WifiHW  (   85): Unable to unload driver module "itm_sta.ko": No such file or directory
W/WifiHW  (   85): insmod filename=/system/lib/modules/itm_sta.ko args= 
E/SoftapController(   85): Softap fwReload - failed: -1
I/Gecko   ( 1899): -*- WifiWorker component: Disable Wifi tethering result: netd command error

I think this should be owned by partner.
Hi xinhe, may I have your comment on netd command error ?
Flags: needinfo?(xinhe.yan)
(In reply to Vincent Chang[:vchang] from comment #0)
> I saw below error message if I turn on/off wifi hotspot quickly.  
> D/WifiHW  (   85): Unable to unload driver module "itm_ap.ko": No such file
> or directory
> D/WifiHW  (   85): Unable to unload driver module "itm_sta.ko": No such file
> or directory
You can ignore this error.
> W/WifiHW  (   85): insmod filename=/system/lib/modules/itm_sta.ko args= 
> E/SoftapController(   85): Softap fwReload - failed: -1
This is our soft ap bug. Turn off/on soft ap quickly, it will be fail to insmod soft ap ko.
> I/Gecko   ( 1899): -*- WifiWorker component: Disable Wifi tethering result:
> netd command error
> 
> I think this should be owned by partner.

We will update wifi code soon, but I don not know whether this will be in this update.
Anyway, I will take it.
Flags: needinfo?(xinhe.yan)
Thank you, xinhe.
Assignee: nobody → xinhe.yan
blocking-b2g: --- → 1.3T?
triage: [POVB] 1.3T+
blocking-b2g: 1.3T? → 1.3T+
Whiteboard: [POVB]
Hi Vincent,
I found this.

04-16 19:46:08.206 W/WifiHW  (   87): wifi_change_fw_path: /system/lib/modules/itm_sta.ko
04-16 19:46:08.206 E/WifiHW  (   87): [rmmod] filename=itm_ap.ko
04-16 19:46:08.206 D/WifiHW  (   87): Unable to unload driver module "itm_ap.ko": No such file or directory
04-16 19:46:08.406 E/WifiHW  (   87): [rmmod] filename=itm_sta.ko
04-16 19:46:08.406 D/WifiHW  (   87): Unable to unload driver module "itm_sta.ko": No such file or directory
04-16 19:46:08.606 W/WifiHW  (   87): insmod filename=/system/lib/modules/itm_sta.ko args= 
04-16 19:46:09.026 E/WifiHW  (   84): [wifi_unload_driver]
04-16 19:46:09.026 E/WifiHW  (   84): [rmmod] filename=itm_ap
04-16 19:46:09.376 E/WifiHW  (   84): [rmmod] filename=itm_sta
04-16 19:46:09.376 D/WifiHW  (   84): Unable to unload driver module "itm_sta": No such file or directory
04-16 19:46:09.576 W/WifiHW  (   84): wifi_load_driver enter 262
04-16 19:46:09.576 W/WifiHW  (   84): DRIVER_MODULE_PATH= DRIVER_MODULE_ARG= 
04-16 19:46:09.576 W/WifiHW  (   84): driver insmod complete 
04-16 19:46:09.576 W/WifiHW  (   84): Driver() loaded succesffuly
04-16 19:46:11.586 W/WifiHW  (   87): wifi_change_fw_path: /system/lib/modules/itm_ap.ko
04-16 19:46:11.586 E/WifiHW  (   87): [rmmod] filename=itm_ap.ko
04-16 19:46:11.586 D/WifiHW  (   87): Unable to unload driver module "itm_ap.ko": No such file or directory
04-16 19:46:11.786 E/WifiHW  (   87): [rmmod] filename=itm_sta.ko
04-16 19:46:11.786 D/WifiHW  (   87): Unable to unload driver module "itm_sta.ko": No such file or directory
04-16 19:46:11.986 W/WifiHW  (   87): insmod filename=/system/lib/modules/itm_ap.ko args= 
04-16 19:46:16.296 W/WifiHW  (   87): wifi_change_fw_path: /system/lib/modules/itm_sta.ko
04-16 19:46:16.296 E/WifiHW  (   87): [rmmod] filename=itm_ap.ko
04-16 19:46:16.296 D/WifiHW  (   87): Unable to unload driver module "itm_ap.ko": No such file or directory
04-16 19:46:16.496 E/WifiHW  (   87): [rmmod] filename=itm_sta.ko
04-16 19:46:16.496 D/WifiHW  (   87): Unable to unload driver module "itm_sta.ko": No such file or directory
04-16 19:46:16.696 W/WifiHW  (   87): insmod filename=/system/lib/modules/itm_sta.ko args= 
04-16 19:46:17.116 E/WifiHW  (   84): [wifi_unload_driver]
04-16 19:46:17.116 E/WifiHW  (   84): [rmmod] filename=itm_ap
04-16 19:46:17.466 E/WifiHW  (   84): [rmmod] filename=itm_sta
04-16 19:46:17.466 D/WifiHW  (   84): Unable to unload driver module "itm_sta": No such file or directory
04-16 19:46:17.666 W/WifiHW  (   84): wifi_load_driver enter 262
04-16 19:46:17.666 W/WifiHW  (   84): DRIVER_MODULE_PATH= DRIVER_MODULE_ARG= 
04-16 19:46:17.666 W/WifiHW  (   84): driver insmod complete 
04-16 19:46:17.676 W/WifiHW  (   84): Driver() loaded succesffuly
04-16 19:46:19.676 W/WifiHW  (   87): wifi_change_fw_path: /system/lib/modules/itm_ap.ko
04-16 19:46:19.676 E/WifiHW  (   87): [rmmod] filename=itm_ap.ko
04-16 19:46:19.676 D/WifiHW  (   87): Unable to unload driver module "itm_ap.ko": No such file or directory
04-16 19:46:19.876 E/WifiHW  (   87): [rmmod] filename=itm_sta.ko
04-16 19:46:19.876 D/WifiHW  (   87): Unable to unload driver module "itm_sta.ko": No such file or directory
04-16 19:46:20.076 W/WifiHW  (   87): insmod filename=/system/lib/modules/itm_ap.ko args= 
04-16 19:46:24.386 W/WifiHW  (   87): wifi_change_fw_path: /system/lib/modules/itm_sta.ko
04-16 19:46:24.386 E/WifiHW  (   87): [rmmod] filename=itm_ap.ko
04-16 19:46:24.386 D/WifiHW  (   87): Unable to unload driver module "itm_ap.ko": No such file or directory
04-16 19:46:24.586 E/WifiHW  (   87): [rmmod] filename=itm_sta.ko
04-16 19:46:24.586 D/WifiHW  (   87): Unable to unload driver module "itm_sta.ko": No such file or directory
04-16 19:46:24.786 W/WifiHW  (   87): insmod filename=/system/lib/modules/itm_sta.ko args= 
04-16 19:46:25.216 E/WifiHW  (   84): [wifi_unload_driver]
04-16 19:46:25.216 E/WifiHW  (   84): [rmmod] filename=itm_ap
04-16 19:46:25.566 E/WifiHW  (   84): [rmmod] filename=itm_sta
04-16 19:46:25.566 D/WifiHW  (   84): Unable to unload driver module "itm_sta": No such file or directory

I guess it take more time to inmod and rmmod.
At last wifi_unload_driver is called to rmmod host ap ko file.

Trout has two ko files. itm_ap for host ap. itm_sta for wifi.

Does patch in 989717 will fix this bug?
I think timing issue should be fixed in wifi_load_driver()/wifi_unload_driver() in wifi.c. 
0.2 seconds may not long enough in wifi_unload_driver().
Hi Vincent,
As post in comment 5, gecko call wifi_unload_driver at last. This will unload ap/sta driver in wifi_itm.c.
It take more time to see WifiHW log. 
After togger soft ap many times, soft ap will be disble in UI. Click panel to enable soft ap immediatelly, but soft ap disable automaticlly.
Partner owns this bug.
Component: Wifi → Vendcom
Whiteboard: [POVB] → [POVB][sprd295455]
Whiteboard: [POVB][sprd295455] → [POVB][sprd295455][need sprd discussion]
This bug already fix in our side. I update wifi hal yesterday. 
D/SoftapController(   88): Softap fwReload - Ok

Vincent,
Can you verify and close this bug?
Whiteboard: [POVB][sprd295455][need sprd discussion] → [POVB][sprd295455]
Looks fine for me after repo sync to new hal code. Thank you.
We have fixed this issue on my side.


commit 9d2b8e5e55afbca8f505352bfcab8abc50032f71
Author: Xinhe Yan <xinhe.yan@spreadtrum.com>
Date:   Tue Apr 22 18:03:16 2014 +0800

    Bug #295455 update wifi hal to MOCORDROID4.0_13A_W13.48_HUIYE_W14.15.6
    
    [bug number  ]
    [root cause  ]
    [changes     ]
    [side effects]
    [self test   ] sp6821a
    [reviewers   ]
    
    Change-Id: Idc22cbaf12b3d7621d2d22aadf650b4bc77f3bff
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Hi ,
i saw below error when on/off wifi hotspot for kitkat 
below are the error 
15 16:13:11.527 I/marvellWirelessDaemon(  125): Wrote 0,OK to client. 

10-15 16:13:11.527 D/WifiHW  (  123): wifi_enable, ret: 0x0

10-15 16:13:13.529 I/Gonk    (  123): Can't parse netd's response

10-15 16:13:13.529 E/SoftapController(  113): SoftAP is not running

10-15 16:13:13.529 D/TetherController(  113): Setting IP forward enable = 1

10-15 16:13:13.529 E/TetherController(  113): Tethering already stopped

10-15 16:13:13.539 I/Gecko   (  123): -*- WifiWorker component: Enable Wifi tethering result: netd command error

10-15 16:13:13.549 I/Gecko   (  123): -*- WifiWorker component: 'tethering.wifi.enabled' is now false

can any one please suggest.
I still see this when disabling wifi quickly after reboot. ondisabled handler on wifi manager runs tho.

D/WifiHW  ( 2759): Unable to unload driver module "itm_ap": No such file or directory
W/Netd    (   84): No subsystem found in netlink event
D/NetlinkEvent(   84): Unexpected netlink message. type=0x11
E/GeckoConsole( 2759): Content JS LOG at app://system.gaiamobile.org/js/plugins/wifi.js:57 in plugin/wifiManager.ondisabled: Wifi was disabled
You need to log in before you can comment on or make changes to this bug.