Panels ("edit bookmark" panel, downloads panel) not showing up on GTK 2.x

RESOLVED DUPLICATE of bug 994562

Status

()

RESOLVED DUPLICATE of bug 994562
5 years ago
4 years ago

People

(Reporter: nix.sasl, Unassigned)

Tracking

({regression})

31 Branch
x86
Linux
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

13.71 KB, image/png
Details
(Reporter)

Description

5 years ago
Posted image bug.png
User Agent: Mozilla/5.0 (X11; Linux i686; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140414030203

Steps to reproduce:

Download Firefox 31.0a1 (2014-04-14) and download any file.
Press the button for "show the progress of.." and nothing appear.


Actual results:

The button for look the download progress does not work in 31.0a1 (2014-04-14)
Only works if I press Ctrl+Shift+Y
In the attached image you can see how the button is pressed but the download progress does not appear


Expected results:

That the button of download progress works in 31.0a1 (2014-04-14)

Comment 1

5 years ago
Does it work in safe mode / on a clean profile? Are there any errors in the browser console (ctrl-shift-j)? 

(I checked, but it works for me...)
Flags: needinfo?(nix.sasl)
(Reporter)

Comment 2

5 years ago
(In reply to :Gijs Kruitbosch from comment #1)
> Does it work in safe mode / on a clean profile? Are there any errors in the
> browser console (ctrl-shift-j)? 
> 
> (I checked, but it works for me...)

Using a new profile + -safe-mode from linux terminal, the bug is the same, and the linux terminal and console of firefox does not show nothing.
The Linux distro is CentOS 6.5 i686 gnome 2.28.
I attach a link with a screencast in youtube, proof of the bug and how it appear (external link because mozilla no allow me attach more than 10mb).

bug video, safe-mode + new profile from linux terminal with firefox console error opened, downloading a debian ISO:

http://youtu.be/iUg6QriBJTM
Flags: needinfo?(nix.sasl)
(Reporter)

Comment 3

5 years ago
Is a regression because in Firefox Aurora 30.0a2 (2014-04-08) works fine on the same machine and OS with the same profile and addons or in safe mode with new profile.

Updated

5 years ago
Component: Untriaged → Downloads Panel
Flags: needinfo?(gijskruitbosch+bugs)
Keywords: regression, regressionwindow-wanted

Comment 4

5 years ago
So I've tried to reproduce on my Fedora VM, also downloading a debian iso image, and it works there, too... :-( 

Around 0:12 in your screencast, you do actually see the panel flashing briefly. I'm not sure why it doesn't stay open... are you clicking only once?

Do you know when this started breaking, or could you try to narrow down a regression range?
Flags: needinfo?(gijskruitbosch+bugs) → needinfo?(nix.sasl)
(Reporter)

Comment 5

5 years ago
(In reply to :Gijs Kruitbosch from comment #4)
> So I've tried to reproduce on my Fedora VM, also downloading a debian iso
> image, and it works there, too... :-( 
> 
> Around 0:12 in your screencast, you do actually see the panel flashing
> briefly. I'm not sure why it doesn't stay open... are you clicking only once?
> 
> Do you know when this started breaking, or could you try to narrow down a
> regression range?

Fedora uses other version of GTK (3), CentOS uses GTK+ 2 (gnome 2.28 and fedora 3.x).
Yes, the panel is flashing, when I press the button quickly i can see how for a 1/10 second flash the panel.
The same bug appear in bookmarks, when I click in:

Bookmark->bookmark this page-> only bookmark the page, and not show me the mini-windows with the name and edit for save a bookmark of kernel.org as linux for example.

I don't remember but the regression started with nightly 31 branch, in April 10 2014 is the last (that I remember) that all works fine. But I do not own the .bz2 tarball or ftp for test it. If you give me some ftp with the 1 to 15 of April of nightly I test it and I can say you wich release introduced the regression.

Test with a CentOS 6.5 in VM, i686, that is the same distro that I use, using firefox from /opt executing the binary using a symlink in /usr/bin to /opt/firefox.

Debian ISO or other download, http, ftp, all the same bug.

Now, using Aurora 30 all work fine, included bookmark window when I add a new page.
Flags: needinfo?(nix.sasl)

Comment 6

5 years ago
(In reply to Nix\ from comment #5)
> (In reply to :Gijs Kruitbosch from comment #4)
> > So I've tried to reproduce on my Fedora VM, also downloading a debian iso
> > image, and it works there, too... :-( 
> > 
> > Around 0:12 in your screencast, you do actually see the panel flashing
> > briefly. I'm not sure why it doesn't stay open... are you clicking only once?
> > 
> > Do you know when this started breaking, or could you try to narrow down a
> > regression range?
> 
> Fedora uses other version of GTK (3), CentOS uses GTK+ 2 (gnome 2.28 and
> fedora 3.x).
> Yes, the panel is flashing, when I press the button quickly i can see how
> for a 1/10 second flash the panel.
> The same bug appear in bookmarks, when I click in:
> 
> Bookmark->bookmark this page-> only bookmark the page, and not show me the
> mini-windows with the name and edit for save a bookmark of kernel.org as
> linux for example.
> 
> I don't remember but the regression started with nightly 31 branch, in April
> 10 2014 is the last (that I remember) that all works fine. But I do not own
> the .bz2 tarball or ftp for test it. If you give me some ftp with the 1 to
> 15 of April of nightly I test it and I can say you wich release introduced
> the regression.
> 
> Test with a CentOS 6.5 in VM, i686, that is the same distro that I use,
> using firefox from /opt executing the binary using a symlink in /usr/bin to
> /opt/firefox.
> 
> Debian ISO or other download, http, ftp, all the same bug.
> 
> Now, using Aurora 30 all work fine, included bookmark window when I add a
> new page.

This is already helpful. To easily narrow it down further, you could try using mozregression. There's a tutorial here: https://www.youtube.com/watch?v=ABrenCFgP3Q . You can probably use https://harthur.wordpress.com/2010/09/13/mozregression-update/ for some text instructions if you prefer. Install with setuptools or pip, then run:

mozregression --good 2014-03-31 --bad 2014-04-14

and it'll automatically download and run the nightlies to get us a regression range.

Thank you!
Flags: needinfo?(nix.sasl)
Summary: Download progress window does not show with button → Panels ("edit bookmark" panel, downloads panel) not showing up on GTK 2.x
(Reporter)

Comment 7

5 years ago
(In reply to :Gijs Kruitbosch from comment #6)
> (In reply to Nix\ from comment #5)
> > (In reply to :Gijs Kruitbosch from comment #4)
> > > So I've tried to reproduce on my Fedora VM, also downloading a debian iso
> > > image, and it works there, too... :-( 
> > > 
> > > Around 0:12 in your screencast, you do actually see the panel flashing
> > > briefly. I'm not sure why it doesn't stay open... are you clicking only once?
> > > 
> > > Do you know when this started breaking, or could you try to narrow down a
> > > regression range?
> > 
> > Fedora uses other version of GTK (3), CentOS uses GTK+ 2 (gnome 2.28 and
> > fedora 3.x).
> > Yes, the panel is flashing, when I press the button quickly i can see how
> > for a 1/10 second flash the panel.
> > The same bug appear in bookmarks, when I click in:
> > 
> > Bookmark->bookmark this page-> only bookmark the page, and not show me the
> > mini-windows with the name and edit for save a bookmark of kernel.org as
> > linux for example.
> > 
> > I don't remember but the regression started with nightly 31 branch, in April
> > 10 2014 is the last (that I remember) that all works fine. But I do not own
> > the .bz2 tarball or ftp for test it. If you give me some ftp with the 1 to
> > 15 of April of nightly I test it and I can say you wich release introduced
> > the regression.
> > 
> > Test with a CentOS 6.5 in VM, i686, that is the same distro that I use,
> > using firefox from /opt executing the binary using a symlink in /usr/bin to
> > /opt/firefox.
> > 
> > Debian ISO or other download, http, ftp, all the same bug.
> > 
> > Now, using Aurora 30 all work fine, included bookmark window when I add a
> > new page.
> 
> This is already helpful. To easily narrow it down further, you could try
> using mozregression. There's a tutorial here:
> https://www.youtube.com/watch?v=ABrenCFgP3Q . You can probably use
> https://harthur.wordpress.com/2010/09/13/mozregression-update/ for some text
> instructions if you prefer. Install with setuptools or pip, then run:
> 
> mozregression --good 2014-03-31 --bad 2014-04-14
> 
> and it'll automatically download and run the nightlies to get us a
> regression range.
> 
> Thank you!
@Gijs:

I tested day by day every release.
The regression was introduced in --good 2014-04-8 --bad 2014-04-9
The .bz2 that works fine is: (md5sum) b526d5a6e9738b5f35d144943b93b82b  firefox-31.0a1.en-US.linux-i686.tar.bz2

With Nightly 31 2014-04-8, bookmarks window after add a website, and download button works fine, with 2014-04-9 both features does not work.

I'm happy to help to mozilla :)

I wait for the fix

Thank you.

Best Regards
Flags: needinfo?(nix.sasl)

Comment 9

5 years ago
Great! This looks like it's a duplicate of bug 994562, which has discussion with the developers about how to fix it already. :-)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 994562
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.