offline: trunk only: get selected messages doesn't work.

VERIFIED FIXED in mozilla0.9.5

Status

SeaMonkey
MailNews: Backend
P1
major
VERIFIED FIXED
16 years ago
13 years ago

People

(Reporter: grylchan, Assigned: Bienvenu)

Tracking

Trunk
mozilla0.9.5

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: PDT+)

Attachments

(1 attachment)

535 bytes, patch
(not reading, please use seth@sspitzer.org instead)
: review+
(not reading, please use seth@sspitzer.org instead)
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

16 years ago
Tested commercial
2001-09-14-09-trunk nt 4.0
2001-09-14-08-trunk linux 2.2, mac 9.1

David, I think this is a regression.

I noticed when I selected mesg(s) in messenger and went
to file|Offline|Get selected messages it did not download
those messages. These messages were ordinary text mesgs and
were 1kb in size. 'Get flagged messages' works fine.

I'm not sure which bug might have caused this. I did a little
regression testing on windows and linux builds.

The last trunk builds that 'get selected messages' was working
  in was the 9-12-08 on linux and 9-12-09 (2001091203) on windows.

The 9-13-08 (linux) and 9-13-05 (windows) is when 'get selected
messages' was first broken in.

I looked at any related offline bugs and the only ones that were
checked into the trunk were bug 79245 and bug 91352. I don't
think these had an affect on "get selected messages" but not sure.
(Assignee)

Comment 1

16 years ago
botched patch application, unfortunately. Fix is to put the code back the way it
was. The branch is now busted the patch was checked into the branch too. Cc'ing
Seth and Navin for review, nominating for branch.
Status: NEW → ASSIGNED
Keywords: nsbranch

Comment 2

16 years ago
Gotta fix this.  Sorry jaime, nsbranch+ and PDT.
Keywords: nsbranch → nsbranch+
Whiteboard: PDT
(Assignee)

Comment 3

16 years ago
Created attachment 49838 [details] [diff] [review]
proposed fix

Comment 4

16 years ago
r=naving
sr=sspitzer
(Assignee)

Comment 6

16 years ago
fix checked into trunk. waiting for approval from pdt for branch checkin.

Updated

16 years ago
Blocks: 99508
Comment on attachment 49838 [details] [diff] [review]
proposed fix

r=naving, sr=sspitzer
Attachment #49838 - Flags: superreview+
Attachment #49838 - Flags: review+

Updated

16 years ago
Severity: normal → major
Keywords: nsenterprise+
Priority: -- → P1
Target Milestone: --- → mozilla0.9.5

Comment 8

16 years ago
Looks like this one is a nsenterprise requirement per Hong. 

MScott/Hong - Pls come by @ noon to tell us why this is tastey, and good eats
for today.

Comment 9

16 years ago
This is a no brainer, put it in.  PDT+
Whiteboard: PDT → PDT+
(Assignee)

Comment 10

16 years ago
fixed on branch
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 11

16 years ago
Verified on
Commercial branch builds
 2001-09-19-05-0.9.4/ win nt 4.0
 2001-09-19-04-0.9.4/ linux 2.2
 2001-09-19-08-0.9.4/ mac 9.1
 2001-09-19-04-0.9.4/  mac 10.0.4

Get selected messages does work. Adding vtrunk to keyword.
Keywords: vtrunk
(Reporter)

Comment 12

16 years ago
commercial trunk
2001-10-08-09-trunk NT 4.0
2001-10-08-08-trunk linux 2.2
2001-10-08-08-trunk mac 9.1

verified 'get selected messages' works.

Removing keyword vtrunk

marking as verified.
Status: RESOLVED → VERIFIED
Keywords: vtrunk
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.