Closed Bug 997124 Opened 6 years ago Closed 5 years ago

Remove DOS encodings that aren't Web-exposed from m-c

Categories

(Core :: Internationalization, enhancement)

enhancement
Not set

Tracking

()

RESOLVED FIXED
mozilla35

People

(Reporter: hsivonen, Assigned: hsivonen)

References

Details

(Keywords: addon-compat)

Attachments

(1 file, 2 obsolete files)

Attached patch WIP (obsolete) — Splinter Review
Cyrillic and Thai will stay. For the rest, if TB wants to have them, they should take them into c-c.
Comment on attachment 8489374 [details] [diff] [review]
Remove DOS encodings other than Cyrillic and Thai, vN

Please remove ucvibm from intl/uconv/directory.txt.
Attachment #8489374 - Flags: review?(VYV03354) → review+
(In reply to Masatoshi Kimura [:emk] from comment #4)
> Please remove ucvibm from intl/uconv/directory.txt.

Thanks. Landed with directory.txt revised:
https://hg.mozilla.org/integration/mozilla-inbound/rev/3f092c5f8c6c
Telemetry shows tiny, tiny usage presumably by extensions: fewer than 20 DOS decoder instantiations in over 322 million sessions. Adding addon-compat in case the add-on doc team cares about this sort of tiny, tiny breakage.

Note that these encodings haven't been exposed to Web content for several releases. Hence, no need to document this change for Web devs.
Keywords: addon-compat
Blocks: 1067807
https://hg.mozilla.org/mozilla-central/rev/3f092c5f8c6c
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla35
Duplicate of this bug: 711101
Depends on: 1186391
You need to log in before you can comment on or make changes to this bug.