Need an update watershed in 29.0bN for beta channel

RESOLVED FIXED

Status

Release Engineering
Release Automation
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: nthomas, Assigned: nthomas)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

3 years ago
To support bug 908134 (release builds on beta channel as an RC), we need to set up updates like this:
   28.0b9 and older --> 29.0bN --> latest
             29.0b* --> latest

This is to make sure they have an updater on disk which understands updatev3.manifests in the mar files, and a precomplete file on disk that doesn't remove update-settings.ini. If we don't do this before they get an RC build, then will not be able to accept beta tagged mar files later.

The 2nd path is an optimization for slightly out of date users, to avoid two-step updates for them. [Bug archaeology - bug 900251, which landed at the same time as 759469, 896223, 896224].

lsblakk, sledru: no changes needed when starting 29.0b9, we just need my upcoming patch to land before then

ashughes: this will impact your update testing, 28.0b* and older will go to 29.0b9 then onwards

FYI CC: hwine, rstrong
(Assignee)

Comment 1

3 years ago
Created attachment 8407905 [details] [diff] [review]
[tools] Remove all but 29.0b* from patcher config

This will stop generating snippets for builds older than 29.0b1, and stop testing update verify for those too (because they're derived from the patcher config). 

Correction:
ashughes: this will impact your update testing - 28.0b* and older will go to 29.0b8 then onwards
Attachment #8407905 - Flags: review?(aki)
(Assignee)

Comment 2

3 years ago
Comment on attachment 8407905 [details] [diff] [review]
[tools] Remove all but 29.0b* from patcher config

>-            <29.0b1>
>+           <29.0b1>

Fixed this unintended whitespace change locally.

Comment 3

3 years ago
Comment on attachment 8407905 [details] [diff] [review]
[tools] Remove all but 29.0b* from patcher config

I would hope the unintentional whitespace change would only have cosmetic consequences, but I wouldn't be surprised if it affected something.
Attachment #8407905 - Flags: review?(aki) → review+
(Assignee)

Comment 4

3 years ago
Comment on attachment 8407905 [details] [diff] [review]
[tools] Remove all but 29.0b* from patcher config

https://hg.mozilla.org/build/tools/rev/6d68be2cb18a
Attachment #8407905 - Flags: checked-in+
(Assignee)

Updated

3 years ago
Blocks: 908134
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1032770
You need to log in before you can comment on or make changes to this bug.