Status

()

bugzilla.mozilla.org
General
P3
major
RESOLVED FIXED
17 years ago
7 years ago

People

(Reporter: CodeMachine, Assigned: justdave)

Tracking

Details

(Reporter)

Description

17 years ago
The new duplicates checks are failing:

Checking duplicates table 

Bug(s) found on duplicates table that are not marked duplicate: 56426, 76936 

Bug(s) found marked resolved duplicate and not on duplicates table: 5977, 8400,
12727, 12771, 14189, 20010, 21962, 21964, 39658, 51511, 61338, 62260, 64318,
65134, 67237, 67261, 68773, 69180, 72022, 72309, 72771, 73024, 73630, 73691,
73975, 74004, 74074, 74097, 74312, 74481, 74509, 74540, 74555, 74556, 74558,
74559, 74560, 74561, 74566, 74572, 74575, 74576, 74577, 74578, 74582, 74583,
74584, 74585, 74586, 74592, 74593, 74604, 74605, 74609, 74610, 74612, 74613,
74614, 74624, 74625, 74626, 74693, 74836, 74892, 74926, 75135, 75285, 75466,
75852, 76780, 76829, 76845, 76877, 77004, 78867, 80153, 80728, 80947, 81338,
81438, 81515, 82373, 82656, 85000, 85121, 85260, 85395, 85436, 86114, 87197,
87985, 88085, 91162, 91315, 92472, 92556, 93696, 96397, 96880
OK. The two bugs found in the dupes table which are not dupes have very strange
Bug Activities. I'm not sure if this is the fault of the duplicates code.

After a quick look, the thing in common I can see about the longer list of
duplicates not in the table is that a comment was added at the same time in all
of them. This could be the problem.

I will look into this on Monday.

Gerv
OK, having talked this over with myk, we are going to keep an eye on the problem
and see if it gets worse. Out of 27,000 duplicates, 100 mistakes isn't too bad. 

It could be caused by people killing their window (and so closing the
connection) before the script completes. This problem would be helped by
templatisation.

Gerv
(Reporter)

Comment 3

17 years ago
Surely you jest?  Why should a script die if you close the window?  If that's
the case, that's a serious problem that needs to be fixed in the absence of
transactions.
That's what myk said. If you close the window or press stop, the web browser
closes the connection and that can cause the script to abort.

Gerv
And yes, I've proved that it works that way, too...
When I did the original mass move of closed bugs that choked because of the
owner reassignments, I had 690 bugs queued for the mass-move. I got disconnected
part-way through, which is why we only had 151 screwed up bugs instead of 690,
since the script aborted when I disconnected.
(Reporter)

Comment 6

17 years ago
This makes kinda sense when a "print" occurs, which we need to have a long think
about, but I doubt it occurs when it doesn't (I'm hoping?), which is probably
the case here.
What needs to be done for this bug is to clean up the database so we have no
more errors being reported, then watch to see if any new ones show up and file a
bug against Bugzilla itself (if there isn't one already) with any new ones if we
can figure out how they happened.  The existing bugs on the list are too old to
know what version of Bugzilla it was running on at the time, and it certainly
wasn't current :)
Assignee: endico → justdave
Priority: -- → P3
OK, the database is clean.

If anyone sees any of these show up again, file a new bug (against Bugzilla product)
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
*** Bug 255986 has been marked as a duplicate of this bug. ***
Component: Bugzilla: Other b.m.o Issues → General
Product: mozilla.org → bugzilla.mozilla.org
You need to log in before you can comment on or make changes to this bug.