"make mochitest-robocop" and "make mochitest-remote" fail to start httpd.js

VERIFIED FIXED

Status

defect
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: gbrown, Assigned: gbrown)

Tracking

Trunk
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Assignee

Description

5 years ago
Local runs of robocop and android mochitests are failing, apparently because httpd.js is not starting up. 

mozpad:~/objdirs/droid$ make mochitest-robocop
Error deleting /data/anr/traces.txt
Mochi-Remote INFO | Device info: {}
Mochi-Remote INFO | Test root: /mnt/sdcard/tests
Mochi-Remote INFO | Android sdk version '10'; will use this to filter manifests
Mochi-Remote INFO | TEST-INFO | skipping testAboutPage | skip-if: android_version == "10"
MochitestServer : launching [u'/home/gbrown/objdirs/firefox/dist/bin/xpcshell', '-g', '/home/gbrown/objdirs/firefox/dist/bin', '-v', '170', '-f', '/home/gbrown/objdirs/droid/httpd.js', '-e', "const _PROFILE_PATH = '/tmp/tmp7x39Uw'; const _SERVER_PORT = '8888'; const _SERVER_ADDR = '192.168.0.82'; const _TEST_PREFIX = undefined; const _DISPLAY_RESULTS = false;", '-f', '/home/gbrown/objdirs/droid/_tests/testing/mochitest/server.js']
runtests.py | Server pid: 27735
TEST-UNEXPECTED-FAIL | runtests.py | Timed out while waiting for server startup.

This appears to be a regression from bug 912243. If I backout that patch, I can run robocop and mochitests without any problems.

Ashish was having a similar problem today, where it appeared that xpcshell would not start because required libraries could not be found.
I have confirmation on irc from gbrown that removing --httpd-path from the cli in the makefile target (http://dxr.mozilla.org/mozilla-central/source/testing/testsuite-targets.mk#61) works.

gbrown, any concerns with doing that?
Flags: needinfo?(gbrown)
Assignee

Comment 2

5 years ago
Note the path to httpd.js, '/home/gbrown/objdirs/droid/httpd.js'. This arises because the makefile target specifies "--httpd-path=.", http://dxr.mozilla.org/mozilla-central/source/testing/testsuite-targets.mk#61 and http://dxr.mozilla.org/mozilla-central/source/testing/testsuite-targets.mk#72.

Removing --httpd-path from the makefile targets allows the tests to run for me, but the httpd path is different from what it was before:

MochitestServer : launching [u'/home/gbrown/objdirs/firefox/dist/bin/xpcshell', '-g', '/home/gbrown/objdirs/firefox/dist/bin', '-v', '170', '-f', '/home/gbrown/objdirs/firefox/dist/bin/components/httpd.js', '-e', "const _PROFILE_PATH = '/tmp/tmpvkXLrA'; const _SERVER_PORT = '8888'; const _SERVER_ADDR = '192.168.0.82'; const _TEST_PREFIX = undefined; const _DISPLAY_RESULTS = false;", '-f', '/home/gbrown/objdirs/droid/_tests/testing/mochitest/server.js']

vs. (with backout of 912242):

MochitestServer : launching [u'/home/gbrown/objdirs/firefox/dist/bin/xpcshell', '-g', '/home/gbrown/objdirs/firefox/dist/bin', '-v', '170', '-f', '/home/gbrown/objdirs/droid/_tests/testing/mochitest/httpd.js', '-e', "const _PROFILE_PATH = '/tmp/tmpq8c8et'; const _SERVER_PORT = '8888'; const _SERVER_ADDR = '192.168.0.82'; const _TEST_PREFIX = undefined; const _DISPLAY_RESULTS = false;", '-f', './server.js']
Assignee

Comment 3

5 years ago
I am only slightly troubled by the difference in Comment 2...but it works, so, no objection.
Flags: needinfo?(gbrown)

Comment 5

5 years ago
Hi gbrown ,

so what is the final soultion for this issue  ?
i am still not able to proceed due to this error

fromm comment1

removing -- httpd-path from
(http://dxr.mozilla.org/mozilla-central/source/testing/testsuite-targets.mk#61)

--testing-modules-dir=$(abspath _tests/modules) --httpd-path=. \

will it work ?

BR,
Ashish N
Ashish, have you tried removing --httpd-path as indicated in comment 1?
Assignee

Comment 7

5 years ago
Assignee: nobody → gbrown
Attachment #8411028 - Flags: review?(jmaher)
Comment on attachment 8411028 [details] [diff] [review]
remove -httpd-path argument from test targets

Review of attachment 8411028 [details] [diff] [review]:
-----------------------------------------------------------------

sold
Attachment #8411028 - Flags: review?(jmaher) → review+
https://hg.mozilla.org/mozilla-central/rev/32616a509bed
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla31

Comment 11

5 years ago
Verified as fixed after updating to the latest sources. Tests are starting now.
Status: RESOLVED → VERIFIED
Target Milestone: mozilla31 → ---
You need to log in before you can comment on or make changes to this bug.