Closed Bug 998464 Opened 6 years ago Closed 5 years ago

Detect if network goes offline during sign in/sign up flow and notify the user

Categories

(Firefox OS Graveyard :: FxA, defect, P1)

defect

Tracking

(b2g-v2.1 fixed)

RESOLVED FIXED
2.1 S3 (29aug)
Tracking Status
b2g-v2.1 --- fixed

People

(Reporter: _6a68, Assigned: _6a68)

References

Details

(Whiteboard: [fxa4fxos2.0][qa+])

Attachments

(1 file)

This is in the spec but not yet implemented.

If the user is in the FTE flow, starts to sign up for FxA, but their network connection is wonky, they will enter email, get to the "Connecting..." overlay, and then be literally trapped until the phone is restarted.

We should set a timer when we open the 'Connecting' overlay, and bail after some length of time which is reasonable on crappie 2G networks (maybe 15-30 sec?)
We have to pay attention to state in Gecko, so that a UX-level cancellation stays in sync with Gecko promises.
Depends on: 973635
An alternative UX approach might be to say, "it looks like we're having trouble connecting. Want to continue waiting, or try again later?"
No longer depends on: 973635
I think it's not a blocker. The case where this occurs is pretty remote. Demoting to nice-to-have.

I'm not even sure this is a good fix, maybe giving the user a cancel button is better: what if their network is laggy/droppy, but they know that, and don't want us to give up for them?
Blocks: 996054
No longer blocks: 987416
No longer blocks: 996054
P3 until/unless QA process shows us that this occurs frequently
Priority: -- → P3
OS: Mac OS X → All
Hardware: x86 → All
Whiteboard: [fxa4fxos2.0]
Duplicate of this bug: 1026603
Since this bug has turned up in independent QA testing, bumping priority and asking for review on priority.

Bhavana, any thoughts on whether this should block 2.0? The description in the duplicate bug 1026603 is much more complete.
Assignee: nobody → 6a68
blocking-b2g: --- → 2.0?
Flags: needinfo?(bbajaj)
Priority: P3 → P2
Whiteboard: [fxa4fxos2.0] → [fxa4fxos2.0][qa+]
(In reply to Jared Hirsch [:_6a68] [@6a68] from comment #6)
> Since this bug has turned up in independent QA testing, bumping priority and
> asking for review on priority.
> 
> Bhavana, any thoughts on whether this should block 2.0? The description in
> the duplicate bug 1026603 is much more complete.

Hi Jaredm,

I've asked a question in https://bugzilla.mozilla.org/show_bug.cgi?id=1026603#c4, lets wait to here back on that usecase before making a (non)blocking call here.
Flags: needinfo?(bbajaj)
Clearing the nom per https://bugzilla.mozilla.org/show_bug.cgi?id=1026603#c5
blocking-b2g: 2.0? → ---
Summary: FTE: Dismiss 'Connecting...' overlay after timeout → Detect if network goes offline during sign in/sign up flow and notify the user
Duplicate of this bug: 1037406
Priority bump for 2.1
Priority: P2 → P1
Target Milestone: --- → 2.1 S3 (29aug)
Attached file Github PR 23222
Hey Borja!

Do you have time to take a look at a small firefox accounts bug? If not, care to recommend any other reviewers while ferjm is out?

Thanks!

Jared
Attachment #8477618 - Flags: review?(borja.bugzilla)
Comment on attachment 8477618 [details] [review]
Github PR 23222

Hi Jared! Small comments in the PR quite easy to address and we are ready to merge this.
After reading the requirement, I was thinking that probably we should add a 'cancel' button in every 'overlay' with a spinner, and this would let the user to cancel the request (because if something happens -for example the server needs more than 30 seconds to answer in an horrible 2G connection-), the user could feel that the UI is blocked or frozen. We should improve this in the future as a nice-to-have for our UX, but as in a different bug. Thanks for your patch!
Attachment #8477618 - Flags: review?(borja.bugzilla) → review+
Awesome, thanks Borja! Updated, waiting on gaia-try before merging.
Tests are green (except for Gij, which doesn't seem reliable these days). Merging.

Master: https://github.com/mozilla-b2g/gaia/commit/95b316b188e133516234c8489f9fe3a1db26c593
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.