Closed Bug 999936 Opened 7 years ago Closed 6 years ago

Some animateMotion cases are broken

Categories

(Core :: SVG, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox28 --- affected
firefox29 --- affected
firefox30 - affected
firefox31 - affected
firefox-esr24 --- unaffected

People

(Reporter: birtles, Unassigned)

References

()

Details

(Keywords: regression, site-compat)

Attachments

(2 files, 2 obsolete files)

In the test URL, the characters that walk across the earth no longer appear. mozregression gives the following range for the regression:

http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a475f94bb1b1&tochange=beddd6d4bcdf

Some possible suspects are:

Bug 937994 - Make the SMIL animate motion code use a Moz2D PathBuilder instead of gfxContext
Bug 938569 - Path fails to render, with comma between move command and implied line command
Bug 938388 - Convert all remaining code for calculating path lengths and position at an offset along a path in content/svg to Moz2D (kill off all uses of gfxPath)
Bug 930577 - Make SVGPathData::ToPath use the Moz2D version of SVGPathData::ConstructPath so that it no longer expecting a device space path from Moz2D backed gfxContext

This appears to be similar to bug 946540 where the culprit was Bug 930577
http://parapara.mozlabs.jp/walls/kobe-manga/sessions/2/gallery is hopefully a slightly less performance intensive version of the same test case
Regressed by
4f086025350f	Jonathan Watt — Bug 930577 - Convert much of the SVG code for calculating path lengths and position at an offset along a path to Moz2D. r=heycam
Thanks Alice!
OS: All → Windows 7
Hardware: All → x86_64
Keywords: site-compat
Jonathan, could you have a look to this bug? Thanks
Flags: needinfo?(jwatt)
Attached image reduced testcase (obsolete) —
red rect should animate along the outline of the black shape, but it's nowhere to be seen
Flags: needinfo?(jwatt)
I'm forgetting that keyPoints is broken ATM. Let me change those for versions without that attribute.
Attached image reduced testcase
Attachment #8431186 - Attachment is obsolete: true
Bas, is this enough for you to work with?
Flags: needinfo?(bas)
This doesn't look like a release blocker as it's been in product since at least FF28 according to flags.  We're also putting FF30 to bed next week and can no longer take speculative fixes there.  Please nominate for uplift if you have a low risk fix worth putting on Aurora.
(Brian, note that the original page that you reported in the URL field contains invalid SVG that stops the characters from animating now that bug 974698 has been fixed. So even once this is fixed that particular case won't animate.)
(In reply to Jonathan Watt [:jwatt] from comment #12)
> (Brian, note that the original page that you reported in the URL field
> contains invalid SVG that stops the characters from animating now that bug
> 974698 has been fixed. So even once this is fixed that particular case won't
> animate.)

Oh no, I wanted to preserve that behaviour. It's really useful. I've even added it to Web Animations. :(
is this still broken? seems ok to me now.
WFM on Firefox31ESR , Firefox36b2 , Aurora37.0a2 and Nightly38.0 on Windows7
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
Flags: needinfo?(bas)
You need to log in before you can comment on or make changes to this bug.